aboutsummaryrefslogtreecommitdiffstats
path: root/packages/qpdf2/qpdf2_2.2.1.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-30 14:40:07 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2004-12-30 14:40:07 +0000
commit94e2841059a034199ca01e4fea29c06c70207722 (patch)
tree45d1fe89f5c4c1ec419e0eaf95d63eb44fb3407e /packages/qpdf2/qpdf2_2.2.1.bb
parentd60950092d470359471ae17ca14ae9a783f9d300 (diff)
downloadopenembedded-94e2841059a034199ca01e4fea29c06c70207722.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2004/12/30 15:38:06+01:00 hrw.one.pl!hrw qt/e 2.3.9: extra visibility patch to get opie-freetype working 2004/12/30 15:08:09+01:00 hrw.one.pl!hrw qpdf2: fixed "SIGSEGV on start" 2004/12/30 15:03:06+01:00 hrw.one.pl!hrw t1lib: package doc separately BKrev: 41d41347CDQOS3CttoCFE8uD_aaBHQ
Diffstat (limited to 'packages/qpdf2/qpdf2_2.2.1.bb')
-rw-r--r--packages/qpdf2/qpdf2_2.2.1.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/qpdf2/qpdf2_2.2.1.bb b/packages/qpdf2/qpdf2_2.2.1.bb
index e69de29bb2..997c866ab5 100644
--- a/packages/qpdf2/qpdf2_2.2.1.bb
+++ b/packages/qpdf2/qpdf2_2.2.1.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "QPDF2 is a Viewer for PDF documents. An unnecessary fork based on opie-qpdf."
+PRIORITY = "optional"
+SECTION = "opie/applications"
+LICENSE = "GPL"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+NOTE = "This is so hacky you won't believe it until you look at the source..."
+DEPENDS = "t1lib freetype"
+APPNAME = "qpdf"
+APPTYPE = "binary"
+APPDESKTOP = "${S}/ipkg-render-freetype/opt/QtPalmtop/apps/Applications"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf2/qpdf2_2.2.1_20040217b.tgz \
+ file://hack-the-hack.patch;patch=1 \
+ file://fix-sigsegv.patch;patch=1"
+S = "${WORKDIR}/qpdf2_${PV}"
+
+inherit opie
+
+QMAKE_PROFILES = "qpdf_render-freetype.pro"
+EXTRA_QMAKEVARS_POST = "TARGET=qpdf"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+ find . -name "*.o"|xargs rm -f
+ find . -name "*.a"|xargs rm -f
+ find . -name "*.la"|xargs rm -f
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/pics/qpdf
+ install -m 0644 ipkg-render-freetype/opt/QtPalmtop/pics/qpdf/*.* ${D}${palmtopdir}/pics/qpdf/
+}
+