aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mono
diff options
context:
space:
mode:
authorHenryk Ploetz <henryk@openmoko.org>2007-10-03 20:59:46 +0000
committerCliff Brake <cbrake@bec-systems.com>2007-10-03 20:59:46 +0000
commit28bbfa1c1ce42dfd54653330f59e1a11b6456371 (patch)
tree4fbae3db99613f3a3576f62d6d51c8a22d596363 /packages/mono
parent493a9dae7b8d0f0d1e05901bceaa48132c9d2c3e (diff)
downloadopenembedded-28bbfa1c1ce42dfd54653330f59e1a11b6456371.tar.gz
mono 1.2.5.1: patch genmdesc.pl to use cpp from staging instead of host
Diffstat (limited to 'packages/mono')
-rw-r--r--packages/mono/files/genmdesc-cpp.patch22
-rw-r--r--packages/mono/mono_1.2.5.1.bb3
2 files changed, 24 insertions, 1 deletions
diff --git a/packages/mono/files/genmdesc-cpp.patch b/packages/mono/files/genmdesc-cpp.patch
new file mode 100644
index 0000000000..56eca8effd
--- /dev/null
+++ b/packages/mono/files/genmdesc-cpp.patch
@@ -0,0 +1,22 @@
+--- mono-1.2.5.1/mono/mini/genmdesc.pl.orig 2007-10-03 21:02:07.000000000 +0200
++++ mono-1.2.5.1/mono/mini/genmdesc.pl 2007-10-03 21:06:16.000000000 +0200
+@@ -36,7 +36,9 @@
+ $i++;
+ }
+ close (OPS);
+- my $cpp = "cpp -undef ";
++ my $cpp = $ENV{"CPP"};
++ $cpp = "cpp" unless defined $cpp;
++ $cpp .= " -undef ";
+ foreach (@defines) {
+ $cpp .= " -U$_";
+ $arch_found = 1 if $arch eq $_;
+@@ -44,7 +46,7 @@
+ die "$arch arch is not supported.\n" unless $arch_found;
+
+ $cpp .= " -D$arch $srcdir/mini-ops.h|";
+- #print "Running: $cpp\n";
++ print "Running: $cpp\n";
+ open (OPS, $cpp) || die "Cannot execute cpp: $!";
+ while (<OPS>) {
+ next unless /MINI_OP\s*\(\s*(\S+?)\s*,\s*"(.*?)"/;
diff --git a/packages/mono/mono_1.2.5.1.bb b/packages/mono/mono_1.2.5.1.bb
index 9a3d4971fd..c3ea1818ad 100644
--- a/packages/mono/mono_1.2.5.1.bb
+++ b/packages/mono/mono_1.2.5.1.bb
@@ -4,7 +4,8 @@ DEPENDS = "mono-native mono-mcs-intermediate glib-2.0 perl-native"
PR = "r2"
-SRC_URI += "file://configure.patch;patch=1"
+SRC_URI += "file://configure.patch;patch=1 \
+ file://genmdesc-cpp.patch;patch=1"
# Per http://www.mono-project.com/Mono:ARM
EXTRA_OECONF += " --disable-mcs-build "