aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lilo-sh/lilo-sh_21.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-07-03 03:09:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-03 03:09:47 +0000
commit9b820e6f7a397dbf74f92b2596bd58fd2528283b (patch)
tree557abd9a84850f0cec55ac9d2637998df3f1afdb /packages/lilo-sh/lilo-sh_21.bb
parentd25e4d60596edd332dbfd2fc63c5e22899ac3600 (diff)
downloadopenembedded-9b820e6f7a397dbf74f92b2596bd58fd2528283b.tar.gz
lilo-sh 0.21: Add lilo-sh, a port of the LILO bootloader to the sh
architecture. Required for the titan SH4 boards to boot from the internal flash which has a translation layer to make it look like a standard block device.
Diffstat (limited to 'packages/lilo-sh/lilo-sh_21.bb')
-rw-r--r--packages/lilo-sh/lilo-sh_21.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/lilo-sh/lilo-sh_21.bb b/packages/lilo-sh/lilo-sh_21.bb
new file mode 100644
index 0000000000..eb4ba0cccf
--- /dev/null
+++ b/packages/lilo-sh/lilo-sh_21.bb
@@ -0,0 +1,41 @@
+#
+# Bootloader for sh4 based devices using a HDD or block translation
+# layer over the flash. NOTE that this version has the 1024 cylinder
+# limit, so you probably need a seperate /boot partition as the first
+# partition on the disk. Tested on the NP51R (Titan) booting from the
+# onboard flash
+#
+DESCRIPTION="LILO (LInux LOader) is a basic system program which \
+boots your Linux system. LILO loads the Linux kernel from a floppy or \
+a hard drive, boots the kernel, and passes control of the system to \
+the kernel. LILO can also boot other operating systems. LILO-sh is a \
+port of LILO to the SH processor."
+SECTION="bootloader"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "http://twibble.org/dist/sh4/src/lilosh/lilo-21.tar.gz \
+ file://lilo-0.21-include.patch;patch=1 \
+ file://lilo-0.21-1.1.patch;patch=1 \
+ file://lilo.patch;patch=1 \
+ file://lilo.raid1;patch=1 \
+ file://lilo-0.21-loopdev.patch;patch=1 \
+ file://lilo-0.21-second.patch;patch=1;pnum=0 \
+ file://lilo-sh-linux.patch;patch=1 \
+ file://lilo-linkgear.patch;patch=1 \
+ file://lilo-noconfig-h.patch;patch=1"
+S = "${WORKDIR}/lilo"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+# Include /boot in the package
+FILES_${PN} = "${base_sbindir} /boot"
+
+do_install() {
+ # Create the base directores
+ mkdir -p ${D}${sysconfdir} ${D}${sbindir}
+ oe_runmake ROOT=${D} install
+ # We don't ship this file
+ rm ${D}/usr/sbin/keytab-lilo.pl
+}