aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libmrss
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-04-07 12:30:48 +0000
committerHolger Freyther <zecke@selfish.org>2007-04-07 12:30:48 +0000
commit41b13b4beba086ce1eb00bc15a6c27b83f6b3fc5 (patch)
tree4ee13665ac7a344930c69a176805872a437f01cd /packages/libmrss
parent8679a9849d2d635859f9207326cd1e94d982f454 (diff)
downloadopenembedded-41b13b4beba086ce1eb00bc15a6c27b83f6b3fc5.tar.gz
packages/libmrss: Move to 0.17.1 and drop all patches
The patches were applied upstream, move to the new version and update the checksums.
Diffstat (limited to 'packages/libmrss')
-rw-r--r--packages/libmrss/files/.mtn2git_empty0
-rw-r--r--packages/libmrss/files/atom-changes.patch17
-rw-r--r--packages/libmrss/files/bump-version.patch16
-rw-r--r--packages/libmrss/files/fix-memleaks.patch17
-rw-r--r--packages/libmrss/files/fix_atom_date_locale.patch121
-rw-r--r--packages/libmrss/libmrss_0.17.1.bb (renamed from packages/libmrss/libmrss_0.17.bb)8
6 files changed, 2 insertions, 177 deletions
diff --git a/packages/libmrss/files/.mtn2git_empty b/packages/libmrss/files/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/libmrss/files/.mtn2git_empty
+++ /dev/null
diff --git a/packages/libmrss/files/atom-changes.patch b/packages/libmrss/files/atom-changes.patch
deleted file mode 100644
index 42f74d00f2..0000000000
--- a/packages/libmrss/files/atom-changes.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Make sure to always set a pubDate
-
-Index: libmrss-0.17/src/mrss_parser.c
-===================================================================
---- libmrss-0.17.orig/src/mrss_parser.c 2007-03-22 19:40:54.000000000 +0100
-+++ libmrss-0.17/src/mrss_parser.c 2007-03-22 19:44:15.000000000 +0100
-@@ -270,6 +270,10 @@
- && data->version == MRSS_VERSION_ATOM_1_0)
- item->pubDate =
- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
-+ else if (!strcmp(cur->value, "updated" ) && !item->pubDate
-+ && data->version == MRSS_VERSION_ATOM_1_0)
-+ item->pubDate =
-+ __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
-
- /* issued -> pubDate (Atom 0.3) */
- else if (!strcmp (cur->value, "issued") && !item->pubDate)
diff --git a/packages/libmrss/files/bump-version.patch b/packages/libmrss/files/bump-version.patch
deleted file mode 100644
index 2eeb6931c8..0000000000
--- a/packages/libmrss/files/bump-version.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Bump the version info, specially as I changed the struct in a binary
-incompatible way.
-
-Index: libmrss-0.17/src/Makefile.am
-===================================================================
---- libmrss-0.17.orig/src/Makefile.am 2007-04-01 16:43:58.000000000 +0200
-+++ libmrss-0.17/src/Makefile.am 2007-04-01 16:44:10.000000000 +0200
-@@ -10,7 +10,7 @@
- mrss_options.c \
- mrss_search.c
-
--libmrss_la_LDFLAGS = -version-info 0:16:0
-+libmrss_la_LDFLAGS = -version-info 0:17:0
-
- EXTRA_DIST = mrss.h mrss_internal.h
-
diff --git a/packages/libmrss/files/fix-memleaks.patch b/packages/libmrss/files/fix-memleaks.patch
deleted file mode 100644
index c88570c72e..0000000000
--- a/packages/libmrss/files/fix-memleaks.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: libmrss-0.17/src/mrss_parser.c
-===================================================================
---- libmrss-0.17.orig/src/mrss_parser.c 2007-04-01 22:23:22.000000000 +0200
-+++ libmrss-0.17/src/mrss_parser.c 2007-04-01 22:23:42.000000000 +0200
-@@ -186,10 +186,10 @@
- cat->allocated = 1;
- cat->category = c;
-
-- if (!(c = nxmle_find_attribute (cur, "scheme", NULL)))
-+ if (c = nxmle_find_attribute (cur, "scheme", NULL))
- cat->domain = c;
-
-- if (!(c = nxmle_find_attribute (cur, "label", NULL)))
-+ if (c = nxmle_find_attribute (cur, "label", NULL))
- cat->label = c;
-
- if (!*category)
diff --git a/packages/libmrss/files/fix_atom_date_locale.patch b/packages/libmrss/files/fix_atom_date_locale.patch
deleted file mode 100644
index 111a4859cd..0000000000
--- a/packages/libmrss/files/fix_atom_date_locale.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-The Atom date formating code tries to create a RFC822 date. This date
-requires to use the C locale for the date (for weekday-names and month-names).
-
-This patch uses new POSIX functionality to create a C locale and strftime_l
-to create a right RFC822 date.
-
-Index: libmrss-0.17/src/mrss.h
-===================================================================
---- libmrss-0.17.orig/src/mrss.h 2007-02-02 12:23:49.000000000 +0100
-+++ libmrss-0.17/src/mrss.h 2007-04-01 19:46:41.000000000 +0200
-@@ -364,6 +364,9 @@
- mrss_element_t element;
- int allocated;
-
-+ /** For internal use only: */
-+ void* c_locale;
-+
- /* Data: */
-
- char *file;
-Index: libmrss-0.17/src/mrss_free.c
-===================================================================
---- libmrss-0.17.orig/src/mrss_free.c 2007-02-02 12:47:46.000000000 +0100
-+++ libmrss-0.17/src/mrss_free.c 2007-04-01 19:46:41.000000000 +0200
-@@ -22,9 +22,14 @@
- # error Use configure; make; make install
- #endif
-
-+#define _GNU_SOURCE
-+
- #include "mrss.h"
- #include "mrss_internal.h"
-
-+#include <locale.h>
-+
-+
- static void __mrss_free_channel (mrss_t * mrss);
- static void __mrss_free_category (mrss_category_t * category);
- static void __mrss_free_hour (mrss_hour_t * hour);
-@@ -202,6 +207,9 @@
- __mrss_free_item ((mrss_item_t *) old);
- }
-
-+ if (mrss->c_locale)
-+ freelocale (mrss->c_locale);
-+
- if (mrss->allocated)
- free (mrss);
- }
-Index: libmrss-0.17/src/mrss_parser.c
-===================================================================
---- libmrss-0.17.orig/src/mrss_parser.c 2007-04-01 19:46:41.000000000 +0200
-+++ libmrss-0.17/src/mrss_parser.c 2007-04-01 20:38:06.000000000 +0200
-@@ -22,9 +22,13 @@
- # error Use configure; make; make install
- #endif
-
-+#define _GNU_SOURCE
-+
- #include "mrss.h"
- #include "mrss_internal.h"
-
-+#include <locale.h>
-+
- static void
- __mrss_parse_tag_insert (mrss_tag_t ** where, mrss_tag_t * what)
- {
-@@ -133,7 +137,7 @@
- }
-
- static char *
--__mrss_atom_prepare_date (char *datestr)
-+__mrss_atom_prepare_date (mrss_t *data, char *datestr)
- {
- char *ret = NULL;
- if (datestr)
-@@ -150,8 +154,13 @@
- stm.tm_year -= 1900;
- char datebuf[256];
- free (datestr);
-- strftime (datebuf, sizeof (datebuf), "%a, %d %b %Y %H:%M:%S %z",
-- &stm);
-+
-+ if (!data->c_locale) {
-+ data->c_locale = newlocale(LC_ALL_MASK,"C",NULL);
-+ }
-+
-+ strftime_l (datebuf, sizeof (datebuf), "%a, %d %b %Y %H:%M:%S %z",
-+ &stm, data->c_locale);
- ret = strdup (datebuf);
- }
- }
-@@ -269,16 +278,16 @@
- else if (!strcmp (cur->value, "published") && !item->pubDate
- && data->version == MRSS_VERSION_ATOM_1_0)
- item->pubDate =
-- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
-+ __mrss_atom_prepare_date (data, nxmle_get_string (cur, NULL));
- else if (!strcmp(cur->value, "updated" ) && !item->pubDate
- && data->version == MRSS_VERSION_ATOM_1_0)
- item->pubDate =
-- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
-+ __mrss_atom_prepare_date (data, nxmle_get_string (cur, NULL));
-
- /* issued -> pubDate (Atom 0.3) */
- else if (!strcmp (cur->value, "issued") && !item->pubDate)
- item->pubDate =
-- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
-+ __mrss_atom_prepare_date (data, nxmle_get_string (cur, NULL));
-
- /* id -> guid */
- else if (!strcmp (cur->value, "id") && !item->guid
-@@ -701,7 +710,7 @@
- /* updated -> lastBuildDate */
- else if (!strcmp (cur->value, "updated"))
- data->lastBuildDate =
-- __mrss_atom_prepare_date (nxmle_get_string (cur, NULL));
-+ __mrss_atom_prepare_date (data, nxmle_get_string (cur, NULL));
-
- /* author -> managingeditor */
- else if (!strcmp (cur->value, "author"))
diff --git a/packages/libmrss/libmrss_0.17.bb b/packages/libmrss/libmrss_0.17.1.bb
index 0d23a2b54f..fe2e87ca51 100644
--- a/packages/libmrss/libmrss_0.17.bb
+++ b/packages/libmrss/libmrss_0.17.1.bb
@@ -3,15 +3,11 @@ LICENSE = "LGPL"
HOMEPAGE = "http://www2.autistici.org/bakunin/codes.php"
DEPENDS = "libnxml curl"
-PR = "r1"
+PR = "r0"
inherit autotools pkgconfig
-SRC_URI = "http://www2.autistici.org/bakunin/libmrss/libmrss-${PV}.tar.gz \
- file://atom-changes.patch;patch=1 \
- file://fix_atom_date_locale.patch;patch=1 \
- file://fix-memleaks.patch;patch=1 \
- file://bump-version.patch;patch=1 "
+SRC_URI = "http://www2.autistici.org/bakunin/libmrss/libmrss-${PV}.tar.gz"
do_stage() {
autotools_stage_all