aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libgpg-error
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-02 17:58:56 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-02 17:58:56 +0000
commit4b97055203367b551a5091f699bc02c36d883af0 (patch)
tree802d7409916d1f4722eebe3f10941df957632e6b /packages/libgpg-error
parentedd940192d3cfa231e9116f09720944b73c345b3 (diff)
downloadopenembedded-4b97055203367b551a5091f699bc02c36d883af0.tar.gz
libgpg-error: unify. partly closes 1688.
Diffstat (limited to 'packages/libgpg-error')
-rw-r--r--packages/libgpg-error/libgpg-error.inc28
-rw-r--r--packages/libgpg-error/libgpg-error_0.7.bb27
-rw-r--r--packages/libgpg-error/libgpg-error_1.0.bb30
-rw-r--r--packages/libgpg-error/libgpg-error_1.3.bb30
-rw-r--r--packages/libgpg-error/libgpg-error_1.4.bb30
5 files changed, 36 insertions, 109 deletions
diff --git a/packages/libgpg-error/libgpg-error.inc b/packages/libgpg-error/libgpg-error.inc
new file mode 100644
index 0000000000..20f62da63b
--- /dev/null
+++ b/packages/libgpg-error/libgpg-error.inc
@@ -0,0 +1,28 @@
+DESCRIPTION = "GPG-Error library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
+ file://pkgconfig.patch;patch=1"
+
+# move libgpg-error-config into -dev package
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/*"
+
+inherit autotools binconfig pkgconfig
+
+do_stage() {
+ oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
+ install -d ${STAGING_BINDIR_CROSS}/
+ install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
+
+ install -d ${STAGING_INCDIR}/
+ for X in gpg-error.h
+ do
+ install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
+}
diff --git a/packages/libgpg-error/libgpg-error_0.7.bb b/packages/libgpg-error/libgpg-error_0.7.bb
index 7edea97fe1..edbe91afea 100644
--- a/packages/libgpg-error/libgpg-error_0.7.bb
+++ b/packages/libgpg-error/libgpg-error_0.7.bb
@@ -1,29 +1,6 @@
+require libgpg-error.inc
+
PR = "r4"
-DESCRIPTION = "GPG-Error library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
SRC_URI = "ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/libgpg-error-${PV}.tar.gz \
file://pkgconfig.patch;patch=1"
-
-# move libgpg-error-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}"
-
-inherit autotools binconfig pkgconfig
-
-do_stage() {
- oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
- install -d ${STAGING_BINDIR_CROSS}/
- install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
-
- install -d ${STAGING_INCDIR}/
- for X in gpg-error.h
- do
- install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
- done
-
- install -d ${STAGING_DATADIR}/aclocal
- install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
-}
diff --git a/packages/libgpg-error/libgpg-error_1.0.bb b/packages/libgpg-error/libgpg-error_1.0.bb
index e520a23ae0..bdbbed0b34 100644
--- a/packages/libgpg-error/libgpg-error_1.0.bb
+++ b/packages/libgpg-error/libgpg-error_1.0.bb
@@ -1,29 +1,3 @@
-PR = "r1"
-DESCRIPTION = "GPG-Error library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
-
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
- file://pkgconfig.patch;patch=1"
-
-# move libgpg-error-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}/*"
-
-inherit autotools binconfig pkgconfig
+require libgpg-error.inc
-do_stage() {
- oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
- install -d ${STAGING_BINDIR_CROSS}/
- install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
-
- install -d ${STAGING_INCDIR}/
- for X in gpg-error.h
- do
- install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
- done
-
- install -d ${STAGING_DATADIR}/aclocal
- install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
-}
+PR = "r1"
diff --git a/packages/libgpg-error/libgpg-error_1.3.bb b/packages/libgpg-error/libgpg-error_1.3.bb
index e520a23ae0..bdbbed0b34 100644
--- a/packages/libgpg-error/libgpg-error_1.3.bb
+++ b/packages/libgpg-error/libgpg-error_1.3.bb
@@ -1,29 +1,3 @@
-PR = "r1"
-DESCRIPTION = "GPG-Error library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
-
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
- file://pkgconfig.patch;patch=1"
-
-# move libgpg-error-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}/*"
-
-inherit autotools binconfig pkgconfig
+require libgpg-error.inc
-do_stage() {
- oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
- install -d ${STAGING_BINDIR_CROSS}/
- install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
-
- install -d ${STAGING_INCDIR}/
- for X in gpg-error.h
- do
- install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
- done
-
- install -d ${STAGING_DATADIR}/aclocal
- install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
-}
+PR = "r1"
diff --git a/packages/libgpg-error/libgpg-error_1.4.bb b/packages/libgpg-error/libgpg-error_1.4.bb
index e520a23ae0..bdbbed0b34 100644
--- a/packages/libgpg-error/libgpg-error_1.4.bb
+++ b/packages/libgpg-error/libgpg-error_1.4.bb
@@ -1,29 +1,3 @@
-PR = "r1"
-DESCRIPTION = "GPG-Error library"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL LGPL FDL"
-
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgpg-error/libgpg-error-${PV}.tar.gz \
- file://pkgconfig.patch;patch=1"
-
-# move libgpg-error-config into -dev package
-FILES_${PN} = "${libdir}/lib*.so.*"
-FILES_${PN}-dev += "${bindir}/*"
-
-inherit autotools binconfig pkgconfig
+require libgpg-error.inc
-do_stage() {
- oe_libinstall -a -so -C src libgpg-error ${STAGING_LIBDIR}
- install -d ${STAGING_BINDIR_CROSS}/
- install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
-
- install -d ${STAGING_INCDIR}/
- for X in gpg-error.h
- do
- install -m 0644 ${S}/src/$X ${STAGING_INCDIR}/$X
- done
-
- install -d ${STAGING_DATADIR}/aclocal
- install -m 0644 src/gpg-error.m4 ${STAGING_DATADIR}/aclocal/
-}
+PR = "r1"