aboutsummaryrefslogtreecommitdiffstats
path: root/packages/fuse
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2007-11-17 16:18:16 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2007-11-17 16:18:16 +0000
commit702d82aa16bb05d638353677359846af2d125674 (patch)
treea7a589f1d36101e50a30a4a537cbd0d3828bfe99 /packages/fuse
parent305088ed5cac5103ccc3b03087a2dc8cf02debcc (diff)
downloadopenembedded-702d82aa16bb05d638353677359846af2d125674.tar.gz
gmailfs: add 0.8.0
Diffstat (limited to 'packages/fuse')
-rw-r--r--packages/fuse/gmailfs.inc22
-rw-r--r--packages/fuse/gmailfs_0.7.3.bb23
-rw-r--r--packages/fuse/gmailfs_0.8.0.bb1
3 files changed, 24 insertions, 22 deletions
diff --git a/packages/fuse/gmailfs.inc b/packages/fuse/gmailfs.inc
new file mode 100644
index 0000000000..9f1c676c87
--- /dev/null
+++ b/packages/fuse/gmailfs.inc
@@ -0,0 +1,22 @@
+DESCRIPTION = "GmailFS provides a mountable Linux filesystem which uses your Gmail account as its storage medium."
+HOMEPAGE = "http://richard.jones.name/google-hacks/gmail-filesystem/gmail-filesystem.html"
+LICENSE = "GPLv2"
+
+DEPENDS = "fuse python-libgmail python-fuse"
+RDEPENDS = "fuse python-libgmail python-fuse python-unixadmin python-lang python-textutils python-core"
+
+SRC_URI = "http://richard.jones.name/google-hacks/gmail-filesystem/${PN}-${PV}.tar.gz"
+
+
+do_install() {
+
+install -d ${D}${datadir}/gmailfs
+install -d ${D}${bindir}
+install -d ${D}${sysconfdir}
+
+install -m 755 ${S}/gmailfs.py ${D}${datadir}/gmailfs/
+install -m 755 ${S}/mount.gmailfs ${D}${bindir}
+install -m 644 ${S}/*.conf ${D}${sysconfdir}
+
+}
+
diff --git a/packages/fuse/gmailfs_0.7.3.bb b/packages/fuse/gmailfs_0.7.3.bb
index 9f1c676c87..de4ea18089 100644
--- a/packages/fuse/gmailfs_0.7.3.bb
+++ b/packages/fuse/gmailfs_0.7.3.bb
@@ -1,22 +1 @@
-DESCRIPTION = "GmailFS provides a mountable Linux filesystem which uses your Gmail account as its storage medium."
-HOMEPAGE = "http://richard.jones.name/google-hacks/gmail-filesystem/gmail-filesystem.html"
-LICENSE = "GPLv2"
-
-DEPENDS = "fuse python-libgmail python-fuse"
-RDEPENDS = "fuse python-libgmail python-fuse python-unixadmin python-lang python-textutils python-core"
-
-SRC_URI = "http://richard.jones.name/google-hacks/gmail-filesystem/${PN}-${PV}.tar.gz"
-
-
-do_install() {
-
-install -d ${D}${datadir}/gmailfs
-install -d ${D}${bindir}
-install -d ${D}${sysconfdir}
-
-install -m 755 ${S}/gmailfs.py ${D}${datadir}/gmailfs/
-install -m 755 ${S}/mount.gmailfs ${D}${bindir}
-install -m 644 ${S}/*.conf ${D}${sysconfdir}
-
-}
-
+require gmailfs.inc
diff --git a/packages/fuse/gmailfs_0.8.0.bb b/packages/fuse/gmailfs_0.8.0.bb
new file mode 100644
index 0000000000..de4ea18089
--- /dev/null
+++ b/packages/fuse/gmailfs_0.8.0.bb
@@ -0,0 +1 @@
+require gmailfs.inc