aboutsummaryrefslogtreecommitdiffstats
path: root/packages/avr-evtd
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-23 16:20:33 +0000
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-23 16:20:33 +0000
commit3a826984ace4ea5667d117b2c87d0b959dac0f6a (patch)
tree20bda0880d473d735795d7de35dd726b2a4c8e9e /packages/avr-evtd
parenta41bdd6cda499d2629ce2a156348620b7ab7afc4 (diff)
downloadopenembedded-3a826984ace4ea5667d117b2c87d0b959dac0f6a.tar.gz
avr-evtd: Install init script and start at boot - tested on lsppchd/lsppchg.
Diffstat (limited to 'packages/avr-evtd')
-rw-r--r--packages/avr-evtd/avr-evtd_1.7.2.bb23
1 files changed, 13 insertions, 10 deletions
diff --git a/packages/avr-evtd/avr-evtd_1.7.2.bb b/packages/avr-evtd/avr-evtd_1.7.2.bb
index 51f8843693..7d79b42467 100644
--- a/packages/avr-evtd/avr-evtd_1.7.2.bb
+++ b/packages/avr-evtd/avr-evtd_1.7.2.bb
@@ -1,18 +1,23 @@
DESCRIPTION = "A simple and small user space interface daemon to the Linkstation/Kuro AVR micro-controller"
HOMEPAGE = "http://sourceforge.net/projects/ppc-evtd"
SECTION = "console/network"
-PR = "r0"
+PR = "r1"
LICENSE = "GPL"
+
SRC_URI = "${SOURCEFORGE_MIRROR}/ppc-evtd/avr_evtd_${PV}.release.tar.gz \
file://dont-ignore-config.patch;patch=1 \
file://avr_evtd.conf \
file://EventScript \
- "
+ file://init"
S = "${WORKDIR}/usr/src/avr_evtd"
+inherit update-rc.d
+
COMPATIBLE_MACHINE = "(lsppchd|lsppchg|lsmipsel)"
+INITSCRIPT_NAME = "avr-evtd"
+INITSCRIPT_PARAMS = "defaults"
-# This is a simple thing, and we will only ever need this for powerpc and mipsel
+# This is a simple thing and we will only ever need this for powerpc and mipsel
# on the platforms above. Pretty important though to stop death by watchdog.
do_compile_powerpc() {
@@ -24,17 +29,15 @@ do_compile_mipsel() {
}
do_install() {
- install -d ${D}${sbindir}
- install -d ${D}${sysconfdir}/default
- install -m 644 ${WORKDIR}/avr_evtd.conf ${D}${sysconfdir}/default/avr_evtd
- install -d ${D}${sysconfdir}/avr_evtd
- install -m 755 ${WORKDIR}/EventScript ${D}${sysconfdir}/avr_evtd/EventScript
+ install -D -m 0644 ${WORKDIR}/avr_evtd.conf ${D}${sysconfdir}/default/avr_evtd
+ install -D -m 0755 ${WORKDIR}/EventScript ${D}${sysconfdir}/avr_evtd/EventScript
+ install -D -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/avr-evtd
}
do_install_append_powerpc() {
- install -c -m 755 ${S}/PPC/avr_evtd ${D}${sbindir}/avr_evtd
+ install -D -m 0755 ${S}/PPC/avr_evtd ${D}${sbindir}/avr_evtd
}
do_install_append_mipsel() {
- install -c -m 755 ${S}/MIPS/avr_evtd ${D}${sbindir}/avr_evtd
+ install -D -m 0755 ${S}/MIPS/avr_evtd ${D}${sbindir}/avr_evtd
}