aboutsummaryrefslogtreecommitdiffstats
path: root/packages/abiword/abiword-plugins_2.4.5.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-07-04 14:55:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-04 14:55:46 +0000
commit8aba54be36f1c8ea60f376a55c4036449ad9bc99 (patch)
treefb7228f3a9f84897758e11e0eb4dd2fcf827dbdf /packages/abiword/abiword-plugins_2.4.5.bb
parentbb0e56bcdd2b71e640badbfce4a8c75c777da1cc (diff)
downloadopenembedded-8aba54be36f1c8ea60f376a55c4036449ad9bc99.tar.gz
abiword_2.4.5.bb, abiword-plugins_2.4.5.bb : new versions.
Diffstat (limited to 'packages/abiword/abiword-plugins_2.4.5.bb')
-rw-r--r--packages/abiword/abiword-plugins_2.4.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/abiword/abiword-plugins_2.4.5.bb b/packages/abiword/abiword-plugins_2.4.5.bb
new file mode 100644
index 0000000000..75861792dd
--- /dev/null
+++ b/packages/abiword/abiword-plugins_2.4.5.bb
@@ -0,0 +1,26 @@
+DESCRIPTION ="AbiWord is free word processing program similar to Microsoft(r) Word""
+HOMEPAGE="http://www.abiword.org""
+MAINTAINER="Koen Kooi <koen@dominion.kabel.utwente.nl>"
+LICENSE="GPLv2"
+
+DEPENDS = "abiword libwpd librsvg goffice poppler"
+PR="r0"
+
+SRC_URI = "http://www.abiword.org/downloads/abiword/${PV}/source/abiword-${PV}.tar.gz \
+ file://abiword-plugin-pdf-poppler.patch;patch=1;pnum=2"
+S = "${WORKDIR}/abiword-${PV}/abiword-plugins"
+
+inherit autotools
+
+PARALLEL_MAKE=""
+
+EXTRA_OECONF = "--without-libwmf"
+
+PACKAGES_DYNAMIC = "abiword-plugin-*"
+
+python populate_packages_prepend () {
+ abiword_libdir = bb.data.expand('${libdir}/AbiWord-2.4/plugins', d)
+
+ do_split_packages(d, abiword_libdir, '^libAbi(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
+}
+