aboutsummaryrefslogtreecommitdiffstats
path: root/libtool
diff options
context:
space:
mode:
authorChris Larson <clarson@kergoth.com>2003-10-24 21:51:45 +0000
committerChris Larson <clarson@kergoth.com>2003-10-24 21:51:45 +0000
commit9902888d91654eae979284e2bc886805c82d48d0 (patch)
tree5e97c1fe880a5c5b254ae7e443bf839b9df0d2b4 /libtool
parent197393e1ff8b18c8818621788cdcc32403fd9dd1 (diff)
downloadopenembedded-9902888d91654eae979284e2bc886805c82d48d0.tar.gz
Build and install libltdl (finally hit a build of an app that needs it).
BKrev: 3f999ef1FWtuQXqjGSMkDQ2ipWAxMA
Diffstat (limited to 'libtool')
-rw-r--r--libtool/libtool-cross_1.5.oe7
-rw-r--r--libtool/libtool_1.5.oe18
2 files changed, 25 insertions, 0 deletions
diff --git a/libtool/libtool-cross_1.5.oe b/libtool/libtool-cross_1.5.oe
index ac8f0ca4a8..465860dfbc 100644
--- a/libtool/libtool-cross_1.5.oe
+++ b/libtool/libtool-cross_1.5.oe
@@ -24,6 +24,13 @@ do_stage () {
install -c -m 0644 ltmain.sh ${STAGING_DIR}/share/libtool/
install -c -m 0644 libtool.m4 ${STAGING_DIR}/share/aclocal/
install -c -m 0644 ltdl.m4 ${STAGING_DIR}/share/aclocal/
+
+ install -m 0644 libltdl/.libs/libltdl.a ${STAGING_LIBDIR}/
+ install -m 0644 libltdl/.libs/libltdl.lai ${STAGING_LIBDIR}/libltdl.la
+ install -m 0755 libltdl/.libs/libltdl.so.3.1.0 ${STAGING_LIBDIR}/
+ ln -sf libltdl.so.3.1.0 ${STAGING_LIBDIR}/libltdl.so.3
+ ln -sf libltdl.so.3.1.0 ${STAGING_LIBDIR}/libltdl.so
+ install -m 0644 libltdl/ltdl.h ${STAGING_DIR}/target/include/
}
do_install () {
diff --git a/libtool/libtool_1.5.oe b/libtool/libtool_1.5.oe
index e69de29bb2..e47a1ff771 100644
--- a/libtool/libtool_1.5.oe
+++ b/libtool/libtool_1.5.oe
@@ -0,0 +1,18 @@
+DESCRIPTION = Generic library support script\
+ This is GNU libtool, a generic library support script. Libtool hides\
+ the complexity of generating special library types (such as shared\
+ libraries) behind a consistent interface. To use libtool, add the\
+ new generic library building commands to your Makefile, Makefile.in,\
+ or Makefile.am. See the documentation for details. Libtool supports\
+ building static libraries on all platforms.\
+ Libtool supports generation of C, C++ and Java libraries.
+
+SRC_URI = http://ftp.club.cc.cmu.edu/pub/gnu/libtool/libtool-1.5.tar.gz
+S = "${WORKDIR}/${P}"
+
+inherit autotools
+
+#EXTRA_OECONF = --disable-ltdl-install
+do_configure_prepend () {
+ ./bootstrap
+}