aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-08 02:40:07 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-08 02:40:07 +0000
commit0ff77391ed2b7599e7c99f233c707bb27338a6fd (patch)
tree0a4a7b13957ecca8987b60b476facca3b628fa3f /classes
parentb686d0b3b4db8d5f795a5ed479ca6da008e7cc9b (diff)
downloadopenembedded-0ff77391ed2b7599e7c99f233c707bb27338a6fd.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/08 03:16:08+01:00 uni-frankfurt.de!mickeyl workaround parsing error in opie-taskbar 2005/01/08 03:01:20+01:00 uni-frankfurt.de!mickeyl Merge 2005/01/08 02:58:47+01:00 uni-frankfurt.de!mickeyl more adjustments for an openzaurus image w/ kernel 2.6 2005/01/08 02:57:34+01:00 uni-frankfurt.de!mickeyl compile scripts/genksyms in kernel builds. this is needed for external modules 2005/01/07 20:54:57+01:00 uni-frankfurt.de!mickeyl openzaurus-2.6: add defconfig for combined machine BKrev: 41df4807VWBmhl2Rfn7MdKt1lbGHOw
Diffstat (limited to 'classes')
-rw-r--r--classes/kernel.bbclass7
1 files changed, 6 insertions, 1 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index 8177654371..ad263d6d31 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -82,10 +82,15 @@ kernel_do_stage() {
install -d ${STAGING_KERNEL_DIR}/arch/${ARCH}
install -m 0644 arch/${ARCH}/Makefile ${STAGING_KERNEL_DIR}/arch/${ARCH}
fi
- cp -fR scripts ${STAGING_KERNEL_DIR}/
cp -fR include/config* ${STAGING_KERNEL_DIR}/include/
install -m 0644 ${KERNEL_OUTPUT} ${STAGING_KERNEL_DIR}/${KERNEL_IMAGETYPE}
install -m 0644 System.map ${STAGING_KERNEL_DIR}/System.map-${PV}
+
+ # Check if scripts/genksyms exists and if so, build it
+ if [ -e scripts/genksyms/ ]; then
+ oe_runmake SUBDIRS="scripts/genksyms"
+ fi
+ cp -fR scripts ${STAGING_KERNEL_DIR}/
}
kernel_do_install() {