aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-11-23 15:29:35 +0100
committerEric Bénard <eric@eukrea.com>2010-11-23 20:05:23 +0100
commitfff6f483701ca8cdcc4c9bdf0cef41bd5b39f32b (patch)
treedf9b2e5608fb8588cdd99e96514e9e3dd420a536
parent62fa381b2f40822d680a7c7fa020a52445dfa543 (diff)
downloadopenembedded-fff6f483701ca8cdcc4c9bdf0cef41bd5b39f32b.tar.gz
mx31ads: make linux 2.6.36 compile
and set this kernel as default version for now. Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/linux/linux-2.6.36/mx31ads/0001-add-missing-include.patch52
-rw-r--r--recipes/linux/linux_2.6.36.bb3
2 files changed, 55 insertions, 0 deletions
diff --git a/recipes/linux/linux-2.6.36/mx31ads/0001-add-missing-include.patch b/recipes/linux/linux-2.6.36/mx31ads/0001-add-missing-include.patch
new file mode 100644
index 0000000000..c76b987595
--- /dev/null
+++ b/recipes/linux/linux-2.6.36/mx31ads/0001-add-missing-include.patch
@@ -0,0 +1,52 @@
+From d123b6ce668fe331c31c504e8d611d0cf7f48a39 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Eric=20B=C3=A9nard?= <eric@eukrea.com>
+Date: Mon, 22 Nov 2010 21:37:50 +0100
+Subject: [PATCH] add missing include
+
+---
+ arch/arm/plat-mxc/include/mach/board-mx31ads.h | 33 +++++++++++++++++++++++++++++
+ 1 files changed, 33 insertions(+), 0 deletions(-)
+ create mode 100644 arch/arm/plat-mxc/include/mach/board-mx31ads.h
+
+diff --git a/arch/arm/plat-mxc/include/mach/board-mx31ads.h b/arch/arm/plat-mxc/include/mach/board-mx31ads.h
+new file mode 100644
+index 0000000..94b60dd
+--- /dev/null
++++ b/arch/arm/plat-mxc/include/mach/board-mx31ads.h
+@@ -0,0 +1,33 @@
++/*
++ * Copyright 2005-2007 Freescale Semiconductor, Inc. All Rights Reserved.
++ */
++
++/*
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License version 2 as
++ * published by the Free Software Foundation.
++ */
++
++#ifndef __ASM_ARCH_MXC_BOARD_MX31ADS_H__
++#define __ASM_ARCH_MXC_BOARD_MX31ADS_H__
++
++#include <mach/hardware.h>
++
++/*
++ * These symbols are used by drivers/net/cs89x0.c.
++ * This is ugly as hell, but we have to provide them until
++ * someone fixed the driver.
++ */
++
++/* Base address of PBC controller */
++#define PBC_BASE_ADDRESS MX31_CS4_BASE_ADDR_VIRT
++/* Offsets for the PBC Controller register */
++
++/* Ethernet Controller IO base address */
++#define PBC_CS8900A_IOBASE 0x020000
++
++#define MXC_EXP_IO_BASE (MXC_BOARD_IRQ_START)
++
++#define EXPIO_INT_ENET_INT (MXC_EXP_IO_BASE + 8)
++
++#endif /* __ASM_ARCH_MXC_BOARD_MX31ADS_H__ */
+--
+1.7.2.3
+
diff --git a/recipes/linux/linux_2.6.36.bb b/recipes/linux/linux_2.6.36.bb
index d15dcee5e9..a395c04e4c 100644
--- a/recipes/linux/linux_2.6.36.bb
+++ b/recipes/linux/linux_2.6.36.bb
@@ -2,9 +2,12 @@ require linux.inc
# Mark archs/machines that this kernel supports
DEFAULT_PREFERENCE = "-1"
+DEFAULT_PREFERENCE_mx31ads = "1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/${P}.tar.bz2;name=kernel \
file://defconfig "
+SRC_URI_append_mx31ads = "file://0001-add-missing-include.patch"
+
SRC_URI[kernel.md5sum] = "61f3739a73afb6914cb007f37fb09b62"
SRC_URI[kernel.sha256sum] = "15a076d1a435a6bf8e92834eba4b390b4ec094ce06d47f89d071ca9e5788ce04"