aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian@kernelconcepts.de>2011-01-28 18:30:19 +0100
committerFlorian Boor <florian.boor@kernelconcepts.de>2012-09-27 16:22:26 +0200
commite6f37a0032e1b5fea5874a5852a9e1353ca26399 (patch)
treefa7fae9e4d8754b658f765fe278b643ce3c75932
parent463a9761e092af149b1e1ed22a28d47625a12f64 (diff)
downloadopenembedded-e6f37a0032e1b5fea5874a5852a9e1353ca26399.tar.gz
gmp: Add some bits to make sdk package
In order to properly build a SDK package for gmp we need to change some bits that fail for SDK builds. Seems not to cause any harm and the change was tested for various target architectures. Signed-off-by: Florian Boor <florian.boor@kernelconcepts.de>
-rw-r--r--recipes/gmp/files/configure-no-doc.patch22
-rw-r--r--recipes/gmp/files/configure-sdk.patch21
-rw-r--r--recipes/gmp/gmp.inc7
3 files changed, 48 insertions, 2 deletions
diff --git a/recipes/gmp/files/configure-no-doc.patch b/recipes/gmp/files/configure-no-doc.patch
new file mode 100644
index 0000000000..9b359bf17d
--- /dev/null
+++ b/recipes/gmp/files/configure-no-doc.patch
@@ -0,0 +1,22 @@
+--- a/configure.in.old 2011-01-28 17:22:16.383634484 +0100
++++ b/configure.in 2011-01-28 17:22:23.637966213 +0100
+@@ -3376,7 +3376,7 @@
+ tests/mpf/Makefile tests/mpn/Makefile tests/mpq/Makefile \
+ tests/mpz/Makefile tests/rand/Makefile tests/misc/Makefile \
+ tests/cxx/Makefile \
+- doc/Makefile tune/Makefile \
++ tune/Makefile \
+ demos/Makefile demos/calc/Makefile demos/expr/Makefile \
+ gmp.h:gmp-h.in mp.h:mp-h.in])
+ AC_OUTPUT
+--- a/Makefile.am.old 2011-01-28 17:30:47.657966226 +0100
++++ b/Makefile.am 2011-01-28 17:31:01.302633088 +0100
+@@ -92,7 +92,7 @@
+ LIBMP_LT_AGE = 1
+
+
+-SUBDIRS = tests mpn mpz mpq mpf printf scanf cxx mpbsd demos tune doc
++SUBDIRS = tests mpn mpz mpq mpf printf scanf cxx mpbsd demos tune
+
+ EXTRA_DIST = configfsf.guess configfsf.sub .gdbinit INSTALL.autoconf
+
diff --git a/recipes/gmp/files/configure-sdk.patch b/recipes/gmp/files/configure-sdk.patch
new file mode 100644
index 0000000000..0c1a8e27bd
--- /dev/null
+++ b/recipes/gmp/files/configure-sdk.patch
@@ -0,0 +1,21 @@
+--- a/configure.in 2011-01-28 16:53:37.554253281 +0100
++++ b/configure.in 2011-01-28 16:53:06.833979262 +0100
+@@ -35,12 +35,12 @@
+ # $build_alias, $host_alias and $target_alias are set to
+ # "athlon-pc-freebsd3.5".
+ #
+-if test -n "$target_alias" && test "$target_alias" != "$host_alias"; then
+- AC_MSG_ERROR([--target is not appropriate for GMP
+-Use --build=CPU-VENDOR-OS if you need to specify your CPU and/or system
+-explicitly. Use --host if cross-compiling (see "Installing GMP" in the
+-manual for more on this).])
+-fi
++#if test -n "$target_alias" && test "$target_alias" != "$host_alias"; then
++# AC_MSG_ERROR([--target is not appropriate for GMP
++#Use --build=CPU-VENDOR-OS if you need to specify your CPU and/or system
++#explicitly. Use --host if cross-compiling (see "Installing GMP" in the
++#manual for more on this).])
++#fi
+
+ GMP_INIT(config.m4)
+
diff --git a/recipes/gmp/gmp.inc b/recipes/gmp/gmp.inc
index 522189d630..127931b264 100644
--- a/recipes/gmp/gmp.inc
+++ b/recipes/gmp/gmp.inc
@@ -2,10 +2,12 @@ SECTION = "libs"
DESCRIPTION = "GNU multiprecision arithmetic library"
HOMEPAGE = "http://www.swox.com/gmp/"
LICENSE = "GPL LGPL"
-INC_PR = "r1"
+INC_PR = "r2"
SRC_URI = "${GNU_MIRROR}/gmp/gmp-${PV}.tar.bz2;name=gmp \
file://configure.patch \
+ file://configure-sdk.patch \
+ file://configure-no-doc.patch \
file://amd64.patch"
inherit autotools
@@ -15,8 +17,9 @@ ARM_INSTRUCTION_SET = "arm"
EXTRA_OECONF_append_virtclass-native = " --enable-static"
-BBCLASSEXTEND = "native nativesdk"
+BBCLASSEXTEND = "native nativesdk sdk"
NATIVE_INSTALL_WORKS = "1"
acpaths = ""
+CFLAGS_EXTRA_virtclass-sdk = ""