aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-17 07:57:24 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-17 07:57:24 +0000
commit8acb9bf89b406402eaaa75a65dc3377f71463000 (patch)
tree92523272a7a8128542127f81d60e83e4096df79f
parent9e4b06645805a05f16e5c49efff98bb07220ddea (diff)
downloadopenembedded-8acb9bf89b406402eaaa75a65dc3377f71463000.tar.gz
angstrom-libc-fixup-hack: add hack to fix runtime crashes for programs that linked against libc.so in the time the toolchain was broken. This package will be used till the feeds have been cleaned out.
-rw-r--r--packages/angstrom/angstrom-libc-fixup-hack.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/packages/angstrom/angstrom-libc-fixup-hack.bb b/packages/angstrom/angstrom-libc-fixup-hack.bb
new file mode 100644
index 0000000000..bf4339a031
--- /dev/null
+++ b/packages/angstrom/angstrom-libc-fixup-hack.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Fixup some miscompiled apps by making an extra symlink"
+
+PACKAGE_ARCH = "all"
+ALLOW_EMPTY_${PN} = "1"
+
+pkg_postinst_${PN}() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+ln -sf /lib/libc.so.6 /lib/libc.so
+}