aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2007-01-16 14:31:48 +0000
committerPhil Blundell <philb@gnu.org>2007-01-16 14:31:48 +0000
commit899938af012159b28ca9b695b3cffd4cbf2de6f4 (patch)
treec413fc8df630c1db485931e48acb1cd461d46a24
parent5f7d57bae80dc3ac3da0c1781a7eb1a8d58831a7 (diff)
downloadopenembedded-899938af012159b28ca9b695b3cffd4cbf2de6f4.tar.gz
lame: add -lm to final link for libmp3lame
-rw-r--r--packages/lame/lame/Makefile-lm.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/lame/lame/Makefile-lm.patch b/packages/lame/lame/Makefile-lm.patch
new file mode 100644
index 0000000000..cbbb1706ce
--- /dev/null
+++ b/packages/lame/lame/Makefile-lm.patch
@@ -0,0 +1,22 @@
+--- lame-3.96.1/libmp3lame/Makefile.am.old 2007-01-16 13:41:48.000000000 +0000
++++ lame-3.96.1/libmp3lame/Makefile.am 2007-01-16 13:41:53.000000000 +0000
+@@ -18,7 +18,7 @@
+ decoder_ldadd =
+ endif
+
+-libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd)
++libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd) -lm
+ libmp3lame_la_LDFLAGS = -version-info @LIB_MAJOR_VERSION@:@LIB_MINOR_VERSION@ \
+ -no-undefined
+
+--- lame-3.96.1/libmp3lame/Makefile.in.old 2007-01-16 13:47:17.000000000 +0000
++++ lame-3.96.1/libmp3lame/Makefile.in 2007-01-16 13:47:29.000000000 +0000
+@@ -177,7 +177,7 @@
+ @LIB_WITH_DECODER_TRUE@decoder_ldadd = $(top_builddir)/mpglib/libmpgdecoder.la
+ @LIB_WITH_DECODER_FALSE@decoder_ldadd =
+
+-libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd)
++libmp3lame_la_LIBADD = $(nasm_ldadd) $(decoder_ldadd) -lm
+ libmp3lame_la_LDFLAGS = -version-info @LIB_MAJOR_VERSION@:@LIB_MINOR_VERSION@ \
+ -no-undefined
+