aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-22 18:01:10 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-22 18:01:10 +0200
commit62720413fea17c1dc380c901cab8d356892a6b2e (patch)
treea6388da706878aa43a22895e230ecf6910717edc
parent039c7a332f66e06d450c307ce011170992020978 (diff)
downloadopenembedded-62720413fea17c1dc380c901cab8d356892a6b2e.tar.gz
bluez4: add 4.42
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/bluez/bluez4_4.42.bb67
2 files changed, 71 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 21aa9a4f7c..6bbc5d2e14 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -2798,6 +2798,10 @@ sha256=1208d8e986f8b545659db21c8220ec28b48979627158123dd9018f9733d858d2
md5=4629236517df280be321f009917a52be
sha256=0b22f518085528b71aa9eab8bbc44d2696458c85d902c6a6686076ae10d64549
+[http://www.kernel.org/pub/linux/bluetooth/bluez-4.42.tar.gz]
+md5=d24dfd3ca42847123e29f58b29af6948
+sha256=ed7631a6d22b456eb26b881bdbe46ea47f93d2f192da420408bad4bbc245f796
+
[http://www.kernel.org/pub/linux/bluetooth/bluez-4.7.tar.gz]
md5=2aa806940d2c841e57a9b2ab7302b750
sha256=ed384dea4f5f21157758fcd7db64db19ce0b410509c26630706e4a3c779287a0
diff --git a/recipes/bluez/bluez4_4.42.bb b/recipes/bluez/bluez4_4.42.bb
new file mode 100644
index 0000000000..340a6d3081
--- /dev/null
+++ b/recipes/bluez/bluez4_4.42.bb
@@ -0,0 +1,67 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libsndfile1 gst-plugins-base alsa-lib libusb-compat dbus-glib"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+
+# For angstrom we want this to replace at least bluez-libs
+PROVIDES_append_angstrom = " bluez-utils bluez-libs"
+
+SRC_URI = "\
+ http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz \
+ file://fix-dfutool-usb-declaration-mismatch.patch;patch=1 \
+ file://sbc-thumb.patch;patch=1 \
+ file://bluetooth.conf \
+"
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools_stage update-rc.d
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+EXTRA_OECONF = "\
+ --enable-gstreamer \
+ --enable-alsa \
+ --enable-usb \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --enable-hidd \
+ --enable-pandd \
+ --enable-dund \
+ --disable-cups \
+ --enable-test \
+ --enable-manpages \
+ --enable-configfiles \
+ --enable-initscripts \
+ --disable-pcmciarules \
+"
+
+do_install_append() {
+ install -m 0644 ${S}/audio/audio.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/network/network.conf ${D}/${sysconfdir}/bluetooth/
+ install -m 0644 ${S}/input/input.conf ${D}/${sysconfdir}/bluetooth/
+ # at_console doesn't really work with the current state of OE, so punch some more holes so people can actually use BT
+ install -m 0644 ${WORKDIR}/bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
+}
+
+INITSCRIPT_NAME = "bluetooth"
+INITSCRIPT_PARAMS = "defaults 23 19"
+
+PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
+
+FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
+FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
+FILES_${PN}-dev += "\
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/alsa-lib/*.la \
+ ${libdir}/gstreamer-0.10/*.la \
+"
+
+FILES_${PN}-dbg += "\
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/*/.debug \
+"