aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn E. Connolly <jconnolly@buglabs.net>2011-03-31 12:38:45 -0400
committerStefan Schmidt <stefan@buglabs.net>2011-05-16 10:01:35 +0200
commit5550904aaff1a6e8a8392b33fb46fb1ac4f9b380 (patch)
treed77dc88711d15dbaa2e8b19a93d8d34ebd971b95
parent3de75ac543bc25f8fe9c926ff8d48e88b3c46a02 (diff)
downloadopenembedded-5550904aaff1a6e8a8392b33fb46fb1ac4f9b380.tar.gz
com.buglabs.bug.{module,jni}.motion.bb: Add recipes and add them to task-bug
Signed-off-by: Stefan Schmidt <stefan@datenfreihafen.org>
-rw-r--r--conf/distro/include/buglabs-autorev.inc2
-rw-r--r--recipes/buglabs-osgi/com.buglabs.bug.jni.motion.bb8
-rw-r--r--recipes/buglabs-osgi/com.buglabs.bug.module.motion.bb3
-rw-r--r--recipes/tasks/task-bug.bb4
4 files changed, 16 insertions, 1 deletions
diff --git a/conf/distro/include/buglabs-autorev.inc b/conf/distro/include/buglabs-autorev.inc
index 84ae8796d1..779b20328e 100644
--- a/conf/distro/include/buglabs-autorev.inc
+++ b/conf/distro/include/buglabs-autorev.inc
@@ -11,6 +11,7 @@ SRCREV_pn-com.buglabs.bug.jni.libmatthew = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.jni.pb = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.jni.rxtx = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.jni.vonhippel = "${AUTOREV}"
+SRCREV_pn-com.buglabs.bug.jni.motion = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.module = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.module.camera = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.module.gps = "${AUTOREV}"
@@ -18,6 +19,7 @@ SRCREV_pn-com.buglabs.bug.module.lcd = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.module.pb = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.module.video = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.module.vonhippel = "${AUTOREV}"
+SRCREV_pn-com.buglabs.bug.module.motion = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.program = "${AUTOREV}"
SRCREV_pn-com.buglabs.bug.service = "${AUTOREV}"
SRCREV_pn-com.buglabs.common = "${AUTOREV}"
diff --git a/recipes/buglabs-osgi/com.buglabs.bug.jni.motion.bb b/recipes/buglabs-osgi/com.buglabs.bug.jni.motion.bb
new file mode 100644
index 0000000000..bef3f3cba4
--- /dev/null
+++ b/recipes/buglabs-osgi/com.buglabs.bug.jni.motion.bb
@@ -0,0 +1,8 @@
+require bug-osgi.inc
+inherit jni-library
+
+SRC_URI = "svn://bugcamp.net/bug/branches/trunk-precleaned;module=${PN};proto=svn "
+PR = "${INC_PR}.5+svnr${SRCREV}"
+FILES_${PN} += "${JNI_LIB_DIR}/libMotion.so"
+
+DEPENDS += "com.buglabs.common com.buglabs.bug.jni.common com.buglabs.bug.jni.accelerometer classpath virtual/kernel"
diff --git a/recipes/buglabs-osgi/com.buglabs.bug.module.motion.bb b/recipes/buglabs-osgi/com.buglabs.bug.module.motion.bb
new file mode 100644
index 0000000000..b4f6d22426
--- /dev/null
+++ b/recipes/buglabs-osgi/com.buglabs.bug.module.motion.bb
@@ -0,0 +1,3 @@
+require bug-osgi.inc
+PR = "${INC_PR}.5+svnr${SRCREV}"
+DEPENDS += "com.buglabs.common com.buglabs.bug.module com.buglabs.bug.jni.motion com.buglabs.bug.jni.accelerometer com.buglabs.bug.jni.common felix-configadmin"
diff --git a/recipes/tasks/task-bug.bb b/recipes/tasks/task-bug.bb
index f81c56a100..140f635838 100644
--- a/recipes/tasks/task-bug.bb
+++ b/recipes/tasks/task-bug.bb
@@ -1,6 +1,6 @@
# Copyright (C) 2011 Bug Labs, Inc
-PR = "r89"
+PR = "r90"
ALLOW_EMPTY = "1"
@@ -95,11 +95,13 @@ RDEPENDS_${PN}-java-osgi = " \
com.buglabs.bug.jni.rxtx \
com.buglabs.bug.jni.vonhippel \
com.buglabs.bug.jni.camera \
+ com.buglabs.bug.jni.motion \
com.buglabs.bug.module.camera \
com.buglabs.bug.module.vonhippel \
com.buglabs.bug.module.gps \
com.buglabs.bug.module.lcd \
com.buglabs.bug.module.video \
+ com.buglabs.bug.module.motion \
com.buglabs.bug.module \
com.buglabs.bug.program \
com.buglabs.bug.service \