aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-16 10:45:16 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-16 10:45:16 +0000
commit13bf6c31893884cbcb7ee9f2a68bdb998bac108e (patch)
tree395bbb3537037dc2bad1fa92519931423d042c82
parent24169f53f0c8a12123e192e6cf0c488f9f648ce4 (diff)
downloadopenembedded-13bf6c31893884cbcb7ee9f2a68bdb998bac108e.tar.gz
sword: inherit lib_package
-rw-r--r--packages/sword/sword_1.5.7.bb25
-rw-r--r--packages/sword/sword_1.5.8.bb27
-rw-r--r--packages/sword/sword_1.5.9.bb18
3 files changed, 5 insertions, 65 deletions
diff --git a/packages/sword/sword_1.5.7.bb b/packages/sword/sword_1.5.7.bb
deleted file mode 100644
index e20dadc23f..0000000000
--- a/packages/sword/sword_1.5.7.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "The SWORD Project is an open source, cross-platform \
-(Linux, Windows, Solaris, MacOSX etc.) API and library for \
-Bible software with a constantly growing list of front-ends \
-(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL"
-PR = "r5"
-
-SRC_URI = "http://www.crosswire.org/~dglassey/sword-1.5.7a.tar.gz"
-
-inherit autotools
-
-EXTRA_OECONF = "--without-clucene --without-curl"
-
-do_stage() {
- oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/sword/
- for f in include/*.h
- do
- install -m 0644 $f ${STAGING_INCDIR}/sword/
- done
-
-}
diff --git a/packages/sword/sword_1.5.8.bb b/packages/sword/sword_1.5.8.bb
deleted file mode 100644
index b16e1fb013..0000000000
--- a/packages/sword/sword_1.5.8.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "The SWORD Project is an open source, cross-platform \
-(Linux, Windows, Solaris, MacOSX etc.) API and library for \
-Bible software with a constantly growing list of front-ends \
-(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL"
-PR = "r2"
-
-SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz"
-
-inherit autotools pkgconfig
-
-EXTRA_OECONF = "--without-clucene --without-curl"
-
-do_stage() {
- oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/sword/
- for f in include/*.h
- do
- install -m 0644 $f ${STAGING_INCDIR}/sword/
- done
-
-}
-
-FILES_${PN} = "${libdir}/libsword*so ${sysconfdir} ${bindir} ${datadir}"
diff --git a/packages/sword/sword_1.5.9.bb b/packages/sword/sword_1.5.9.bb
index 2c180ac7e3..303d7f9fcc 100644
--- a/packages/sword/sword_1.5.9.bb
+++ b/packages/sword/sword_1.5.9.bb
@@ -3,26 +3,18 @@ DESCRIPTION = "The SWORD Project is an open source, cross-platform \
Bible software with a constantly growing list of front-ends \
(GUI, textmode, web-based, etc.) and a library of over 200 text modules"
SECTION = "libs"
+HOMEPAGE = "http://www.e-sword.net/"
PRIORITY = "optional"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/sword-${PV}.tar.gz \
- file://gcc-visibility.patch;patch=1"
+ file://gcc-visibility.patch;patch=1"
-inherit autotools pkgconfig
+inherit autotools pkgconfig lib_package
EXTRA_OECONF = "--without-clucene --without-curl"
do_stage() {
- oe_libinstall -so -C lib libsword ${STAGING_LIBDIR}
-
- install -d ${STAGING_INCDIR}/sword/
- for f in include/*.h
- do
- install -m 0644 $f ${STAGING_INCDIR}/sword/
- done
-
+ autotools_stage_all
}
-
-FILES_${PN} = "${libdir}/libsword*so ${sysconfdir} ${bindir} ${datadir}"