aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEyal Reizer <eyalreizer@googlemail.com>2011-05-26 15:43:17 +0000
committerDenys Dmytriyenko <denys@ti.com>2011-06-07 22:39:11 -0400
commit0720d95fcb26bbae4620078de4f093057f08bf43 (patch)
treef263e85f8bfc2b3ebcc3b0eb10866c507ce922e0
parente992a948b8a542e1f500342fca0a991f47bfbe9c (diff)
downloadopenembedded-0720d95fcb26bbae4620078de4f093057f08bf43.tar.gz
wpa-gui-e: build the latest version from git sources
Builds wpa-gui for qt4-embedded from the latest wpa-supplicant (0.8x) git sources Signed-off-by: Eyal Reizer <eyalr@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes/wpa-supplicant/wpa-gui-e_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/wpa-supplicant/wpa-gui-e_git.bb b/recipes/wpa-supplicant/wpa-gui-e_git.bb
new file mode 100644
index 0000000000..d90ca901e0
--- /dev/null
+++ b/recipes/wpa-supplicant/wpa-gui-e_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Qt embedded interface for choosing which configured network \
+to connect to. It also provides a method for browsing 802.11 SSID scan \
+results, an event history log of messages generated by wpa_supplicant, and \
+a method to add or edit wpa_supplicant networks."
+
+HOMEPAGE = "http://hostap.epitest.fi/wpa_supplicant/"
+SECTION = "network"
+LICENSE = "GPLv2 | BSD"
+RDEPENDS_${PN} = "wpa-supplicant"
+
+SRCREV = "b8fb017272ed4794339978c9fbc0e74571a44728"
+
+PV = "0.7.3+0.8.0-rc"
+PR = "r0"
+PR_append = "+gitr${SRCPV}"
+
+SRC_URI = "git://w1.fi/srv/git/hostap.git;protocol=git"
+
+S = "${WORKDIR}/git/wpa_supplicant/wpa_gui-qt4"
+
+inherit qt4e
+ARM_INSTRUCTION_SET = "arm"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 755 wpa_gui ${D}/${bindir}/wpa_gui-e
+}