aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2009-10-11 16:23:47 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-10-13 11:49:15 +0200
commit04da2236c67af2981c2384c1f6f05af32da8507e (patch)
tree96f77aa9e8e025c007ca111b7191feb62fff65b2
parent62beef6e927c5a4eec2d79ef189645e087d5e6f8 (diff)
downloadopenembedded-04da2236c67af2981c2384c1f6f05af32da8507e.tar.gz
shr/merge: downgrade glibc to 2.7, update libefso, openmoko-agpsui and paroli recipe
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
-rw-r--r--conf/distro/include/preferred-shr-versions.inc10
-rw-r--r--recipes/efl1/libefso_svn.bb2
-rw-r--r--recipes/openmoko-projects/openmoko-agpsui_svn.bb5
-rw-r--r--recipes/openmoko-projects/paroli_git.bb166
4 files changed, 171 insertions, 12 deletions
diff --git a/conf/distro/include/preferred-shr-versions.inc b/conf/distro/include/preferred-shr-versions.inc
index 8f071342a0..83270d4b53 100644
--- a/conf/distro/include/preferred-shr-versions.inc
+++ b/conf/distro/include/preferred-shr-versions.inc
@@ -470,8 +470,8 @@ PREFERRED_VERSION_glib-1.2 ?= "1.2.10"
PREFERRED_VERSION_glib-1.2-native ?= "1.2.10"
PREFERRED_VERSION_glib-2.0 ?= "2.22.1"
PREFERRED_VERSION_glib-2.0-native ?= "2.22.1"
-PREFERRED_VERSION_glibc ?= "2.9"
-PREFERRED_VERSION_glibc-initial ?= "2.9"
+PREFERRED_VERSION_glibc ?= "2.7"
+PREFERRED_VERSION_glibc-initial ?= "2.7"
PREFERRED_VERSION_glibmm ?= "2.22.1"
PREFERRED_VERSION_glider ?= "1.0.0"
PREFERRED_VERSION_gloox ?= "0.8.9"
@@ -643,8 +643,8 @@ PREFERRED_VERSION_gtkterm2 ?= "0.2.3"
PREFERRED_VERSION_gtk-xfce-engine ?= "2.4.1"
PREFERRED_VERSION_gtracer ?= "0.0.10"
PREFERRED_VERSION_guichan ?= "0.7.1"
-PREFERRED_VERSION_guile ?= "1.6.4"
-PREFERRED_VERSION_guile-native ?= "1.8.2"
+PREFERRED_VERSION_guile ?= "1.8.6"
+PREFERRED_VERSION_guile-native ?= "1.8.6"
PREFERRED_VERSION_gutenprint ?= "5.1.3"
PREFERRED_VERSION_gutenprint-native ?= "5.1.3"
PREFERRED_VERSION_gvim ?= "7.0"
@@ -1201,7 +1201,7 @@ PREFERRED_VERSION_matrixssl ?= "1.1.1"
PREFERRED_VERSION_mb-applet-tasks ?= "1.0.0"
PREFERRED_VERSION_mb-desktop-xine ?= "0.4"
PREFERRED_VERSION_mbmerlin ?= "0.8.1-2"
-PREFERRED_VERSION_mc ?= "4.6.1"
+PREFERRED_VERSION_mc ?= "4.6.2"
PREFERRED_VERSION_mce-dev ?= "1.5.6"
PREFERRED_VERSION_mdadm ?= "2.5.5"
PREFERRED_VERSION_mdev ?= "1.2.1"
diff --git a/recipes/efl1/libefso_svn.bb b/recipes/efl1/libefso_svn.bb
index 276cd100ef..64be520b98 100644
--- a/recipes/efl1/libefso_svn.bb
+++ b/recipes/efl1/libefso_svn.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "EFL FSO wrapper library"
SECTION = "e/libs"
LICENSE = "GPLv2"
-DEPENDS = "ecore edbus"
+DEPENDS = "ecore edbus efreet"
PV = "0.0.1+svnr${SRCREV}"
SRC_URI = "svn://svn.om.vptt.ch/trunk/;proto=http;module=libefso"
diff --git a/recipes/openmoko-projects/openmoko-agpsui_svn.bb b/recipes/openmoko-projects/openmoko-agpsui_svn.bb
index b9b2de2de7..347eee7b3a 100644
--- a/recipes/openmoko-projects/openmoko-agpsui_svn.bb
+++ b/recipes/openmoko-projects/openmoko-agpsui_svn.bb
@@ -4,9 +4,10 @@ SECTION = "openmoko/apps"
LICENSE = "GPL"
DEPENDS = "gtk+"
PV = "0.1+svnr${SRCREV}"
-PR = "r0"
+PR = "r1"
-SRC_URI = "svn://svn.projects.openmoko.org/svnroot/openmoko-agpsui;module=trunk;proto=https"
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/openmoko-agpsui;module=trunk;proto=http \
+file://fix-configure-for-new-autotools.patch;patch=1;pnum=2"
S = "${WORKDIR}/trunk"
diff --git a/recipes/openmoko-projects/paroli_git.bb b/recipes/openmoko-projects/paroli_git.bb
index e485996f4b..03d31335fa 100644
--- a/recipes/openmoko-projects/paroli_git.bb
+++ b/recipes/openmoko-projects/paroli_git.bb
@@ -1,20 +1,178 @@
DESCRIPTION = "Paroli"
SECTION = "x11"
LICENSE = "GPL"
-PV = "0.2+gitr${SRCREV}"
-PR = "r0"
+PV = "0.2.1+gitr${SRCPV}"
+PR = "r29"
-SRC_URI = "git://git.paroli-project.org/paroli.git;protocol=http"
+SRC_URI = "git://git.paroli-project.org/paroli.git;protocol=http;branch=shr"
S = "${WORKDIR}/git"
inherit distutils
+PACKAGES += "${PN}-autostart ${PN}-theme ${PN}-sounds ${PN}-calculator"
+
RDEPENDS = "\
python-datetime \
python-subprocess \
python-textutils \
python-dbus \
python-pygobject \
+ python-elementary \
+ dbus-x11 \
+ task-fso-compliance \
+ elementary \
+ elementary-themes \
+ edbus-ehal \
"
-FILES_${PN} += "${sysconfdir}/dbus-1 ${sysconfdir}/paroli ${datadir}"
+E_CONFIG_DIR="/usr/share/enlightenment/data"
+
+RULES_YAML = rules.yaml
+RULES_YAML_om-gta01 = gta01_rules.yaml
+
+do_configure_append() {
+ # fix absolute etc reference
+ sed -i "s|/etc/|../../etc/|" ${S}/setup.py
+ sed -i "s|prefix,|'../../usr/',|" ${S}/setup.py
+ sed -i "s|core/|/usr/lib/python2.6/site-packages/|" ${S}/scripts/paroli
+ sed -i "s|services|/usr/share/paroli/services|" ${S}/scripts/paroli.fso.cfg
+ sed -i "s|applications|/usr/share/paroli/applications|" ${S}/scripts/paroli.fso.cfg
+}
+
+do_install_append() {
+# install ${D}${sysconfdir}/paroli/paroli.fso.cfg ${D}${sysconfdir}/paroli/paroli.cfg
+
+ # install paroli theme
+ install -d ${D}${E_CONFIG_DIR}/themes
+ install ${S}/data/e-config/paroli.edj ${D}${E_CONFIG_DIR}/themes/
+ install ${S}/data/e-config/serenity.edj ${D}${E_CONFIG_DIR}/themes/
+ install -d ${D}${E_CONFIG_DIR}/config/paroli
+ install ${S}/data/e-config/paroli/* ${D}${E_CONFIG_DIR}/config/paroli/
+ install -d ${D}${E_CONFIG_DIR}/config/paroli-serenity
+ install ${S}/data/e-config/paroli-serenity/* ${D}${E_CONFIG_DIR}/config/paroli-serenity/
+
+ install -d ${D}${datadir}/elementary/themes
+ install ${S}/data/paroli.edj ${D}${datadir}/elementary/themes
+
+ install -d ${D}${datadir}/icons
+ install ${S}/data/paroli.png ${D}${datadir}/icons
+
+ install -d ${D}${datadir}/applications
+ install ${S}/data/paroli.desktop ${D}${datadir}/applications
+
+ # install autostart
+ install -d ${D}${E_CONFIG_DIR}/applications/all
+ cp ${D}/usr/share/applications/paroli.desktop ${D}${E_CONFIG_DIR}/applications/all
+ install -d ${D}${E_CONFIG_DIR}/applications/startup
+ echo "${E_CONFIG_DIR}/applications/all/paroli.desktop" >> ${D}${E_CONFIG_DIR}/applications/startup/.order
+
+# install -d ${D}${sysconfdir}/freesmartphone/oevents
+# install ${S}/data/${RULES_YAML} ${D}${sysconfdir}/freesmartphone/oevents/paroli_rules.yaml
+# install ${S}/data/frameworkd.conf ${D}${sysconfdir}/paroli_frameworkd.conf
+
+ install -d ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone
+ install ${S}/data/default.yaml ${D}${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml
+
+ install -d ${D}${datadir}/dbus-1/system-services/
+ install ${S}/data/dbus/org.tichy.launcher.service ${D}${datadir}/dbus-1/system-services/
+
+ install -d ${D}${datadir}/sounds
+ install ${S}/data/sounds/* ${D}${datadir}/sounds
+
+}
+
+pkg_postinst_${PN}-autostart() {
+#!/bin/sh
+# do this off or on line
+if [ "x$D" != "x" ]; then
+ ROOTFS=${IMAGE_ROOTFS}
+else
+ ROOTFS=""
+fi
+
+# post installation script
+if [ -x $ROOTFS${sysconfdir}/X11/Xsession.d/80zhone ]; then
+ echo "*******************************************"
+ echo "Deactivating zhone autostart"
+ echo "*******************************************"
+ chmod -x $ROOTFS${sysconfdir}/X11/Xsession.d/80zhone || true
+fi
+exit 0
+}
+
+#pkg_postinst_${PN}-sounds() {
+#!/bin/sh
+# do this off or on line
+#if [ "x$D" != "x" ]; then
+# ROOTFS=${IMAGE_ROOTFS}
+#else
+# ROOTFS=""
+#fi
+# post installation script
+#if [ ! -e /$ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/old_default.yaml ] ; then
+# echo "Backing up ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml"
+# mv $ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml $ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/old_default.yaml
+#fi
+#cp $ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/paroli_default.yaml $ROOTFS${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml
+#exit 0
+#}
+
+pkg_postinst_${PN}-theme() {
+#!/bin/sh
+# do this off or on line
+if [ "x$D" != "x" ]; then
+ ROOTFS=${IMAGE_ROOTFS}
+else
+ ROOTFS=""
+fi
+# post installation script
+echo 'E_PROFILE="-profile paroli"' > $ROOTFS${sysconfdir}/enlightenment/default_profile
+exit 0
+}
+
+FILES_${PN} = " \
+ ${sysconfdir}/dbus-1 \
+ ${sysconfdir}/paroli \
+ ${sysconfdir}/freesmartphone/oevents \
+ ${prefix}/lib \
+ ${prefix}/bin \
+ ${datadir}/paroli/applications/common-for-edje \
+ ${datadir}/paroli/applications/inout \
+ ${datadir}/paroli/applications/telephony \
+ ${datadir}/paroli/applications/messages \
+ ${datadir}/paroli/applications/launcher \
+ ${datadir}/paroli/applications/people \
+ ${datadir}/paroli/applications/settings \
+ ${datadir}/applications \
+ ${datadir}/elementary \
+ ${datadir}/paroli/services \
+ ${datadir}/paroli/data \
+ ${datadir}/pixmaps \
+ ${datadir}/icons \
+ ${datadir}/dbus-1/system-services/ \
+ "
+
+FILES_${PN}-theme = " \
+ ${E_CONFIG_DIR}/themes \
+ ${E_CONFIG_DIR}/config \
+ "
+
+FILES_${PN}-autostart = "${E_CONFIG_DIR}/applications"
+
+FILES_${PN}-sounds = " \
+ ${datadir}/sounds/ \
+ ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
+ "
+
+FILES_${PN}-calculator = " \
+ ${datadir}/paroli/applications/calculator \
+ "
+
+CONFFILES_${PN} += " \
+ ${sysconfdir}/paroli/paroli.fallback.cfg \
+ ${sysconfdir}/paroli/paroli.pyneo.cfg \
+ ${sysconfdir}/paroli/paroli.fso.cfg \
+ "
+CONFFILES_${PN}-sounds += " \
+ ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
+ "