aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-01-20 15:39:28 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-01-20 15:39:28 +0000
commitdd766b65197c71b5583aaa3b3274c3099793c293 (patch)
tree35988e2d59e17091d507b9e39f2ff2645d376f9e
parentdbd24d30de95046e35e172d94725fc01db3dcb4d (diff)
parentecdf83fac30e8e2652194c50c129864ca74abe3f (diff)
downloadopenembedded-dd766b65197c71b5583aaa3b3274c3099793c293.tar.gz
merge of '2013dc89bec97cf3f3479d301666511c1e8b34d6'
and '991bdefc0c20378a74650c650530041b206d7c4c'
-rw-r--r--conf/distro/angstrom-2007.1.conf2
-rw-r--r--packages/cairo/cairo_1.3.12.bb (renamed from packages/cairo/cairo_1.3.10.bb)0
-rw-r--r--packages/cairo/cairo_git.bb2
-rw-r--r--packages/hal/files/99_hal1
-rw-r--r--packages/hal/hal_0.5.8.1.bb34
5 files changed, 35 insertions, 4 deletions
diff --git a/conf/distro/angstrom-2007.1.conf b/conf/distro/angstrom-2007.1.conf
index b1d67e0405..a08413ef8a 100644
--- a/conf/distro/angstrom-2007.1.conf
+++ b/conf/distro/angstrom-2007.1.conf
@@ -98,7 +98,7 @@ PREFERRED_PROVIDER_virtual/libxine ?= "libxine-x11"
PREFERRED_VERSION_fontconfig = "2.4.1"
PREFERRED_VERSION_freetype = "2.2.1"
#fix screen corruption issues
-PREFERRED_VERSION_cairo = "1.3.10"
+PREFERRED_VERSION_cairo = "1.3.12"
#work around a segfault in gcc for armv4t
PREFERRED_VERSION_glib-2.0_ep93xx = "2.12.3"
diff --git a/packages/cairo/cairo_1.3.10.bb b/packages/cairo/cairo_1.3.12.bb
index 883884d15f..883884d15f 100644
--- a/packages/cairo/cairo_1.3.10.bb
+++ b/packages/cairo/cairo_1.3.12.bb
diff --git a/packages/cairo/cairo_git.bb b/packages/cairo/cairo_git.bb
index 55bdc019f0..26eaf78879 100644
--- a/packages/cairo/cairo_git.bb
+++ b/packages/cairo/cairo_git.bb
@@ -7,7 +7,7 @@ DEPENDS = "virtual/libx11 libsm libpng fontconfig libxrender"
DESCRIPTION = "Cairo graphics library"
LICENSE = "MPL LGPL"
-PV = "1.3.11+git${SRCDATE}"
+PV = "1.3.13+git${SRCDATE}"
SRC_URI = "git://git.cairographics.org/git/cairo;protocol=git \
"
diff --git a/packages/hal/files/99_hal b/packages/hal/files/99_hal
new file mode 100644
index 0000000000..f3d477231e
--- /dev/null
+++ b/packages/hal/files/99_hal
@@ -0,0 +1 @@
+d root root 0700 /var/run/hald none
diff --git a/packages/hal/hal_0.5.8.1.bb b/packages/hal/hal_0.5.8.1.bb
index 4b2196f875..dc07d62846 100644
--- a/packages/hal/hal_0.5.8.1.bb
+++ b/packages/hal/hal_0.5.8.1.bb
@@ -8,9 +8,10 @@ RDEPENDS += "udev"
#RDEPENDS_hal-device-manager = "python hal python-pygnome"
RRECOMMENDS = "udev-utils"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
+SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
+ file://99_hal"
S = "${WORKDIR}/hal-${PV}"
@@ -24,6 +25,11 @@ EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
--disable-policy-kit \
"
+do_install_append() {
+ install -d ${D}/etc/default/volatiles
+ install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
+}
+
do_stage() {
autotools_stage_all
install -d ${STAGING_LIBDIR}
@@ -31,6 +37,30 @@ do_stage() {
install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
}
+# At the time the postinst runs, dbus might not be setup so only restart if running
+pkg_postinst_hal () {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ /etc/init.d/populate-volatile.sh update
+
+ grep haldaemon /etc/group || addgroup haldaemon
+ grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
+
+ DBUSPID=`pidof dbus-daemon`
+
+ if [ "x$DBUSPID" != "x" ]; then
+ /etc/init.d/dbus-1 force-reload
+ fi
+}
+
+pkg_postrm_hal () {
+ deluser haldaemon || true
+ delgroup haldaemon || true
+}
+
#PACKAGES += "hal-device-manager"
#FILES_hal-device-manager = " \