aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-16 15:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-16 15:40:08 +0000
commitd1afa39cedb38baa8896661dc614f9cf49379bd7 (patch)
treea5b3f4878c0f816165fada7f287b6e26b6d6cd89
parent2e131be3b12703e3103d9f354ace459073dc13b8 (diff)
downloadopenembedded-d1afa39cedb38baa8896661dc614f9cf49379bd7.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/16 15:27:45+00:00 nexus.co.uk!pb Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into stealth.nexus.co.uk:/home/pb/oe/oe 2005/01/16 15:27:32+00:00 nexus.co.uk!pb apply pcmcia-cs patch from Florian Boor to disable bogus /etc/fstab additions for ide devices 2005/01/16 16:09:25+01:00 uni-frankfurt.de!mickeyl openzaurus-pxa-2.6.conf: +udev +sysfsutils -chkhinge 2005/01/16 16:10:16+01:00 vanille.de!mickeyl kernel.bbclass: compile genksyms a bit later in the process BKrev: 41ea8ad8khNLy9Au5Nikuh759HWW4w
-rw-r--r--classes/kernel.bbclass11
-rw-r--r--conf/machine/openzaurus-pxa-2.6.conf6
-rw-r--r--packages/pcmcia-cs/pcmcia-cs-3.2.8/ide.opts25
-rw-r--r--packages/pcmcia-cs/pcmcia-cs_3.2.8.bb2
4 files changed, 36 insertions, 8 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index ad263d6d31..36d004bfe5 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -86,10 +86,6 @@ kernel_do_stage() {
install -m 0644 ${KERNEL_OUTPUT} ${STAGING_KERNEL_DIR}/${KERNEL_IMAGETYPE}
install -m 0644 System.map ${STAGING_KERNEL_DIR}/System.map-${PV}
- # Check if scripts/genksyms exists and if so, build it
- if [ -e scripts/genksyms/ ]; then
- oe_runmake SUBDIRS="scripts/genksyms"
- fi
cp -fR scripts ${STAGING_KERNEL_DIR}/
}
@@ -107,6 +103,13 @@ kernel_do_install() {
install -m 0644 System.map ${D}/boot/System.map-${PV}
install -m 0644 .config ${D}/boot/config-${PV}
install -d ${D}/etc/modutils
+
+ # Check if scripts/genksyms exists and if so, build it
+ if [ -e scripts/genksyms/ ]; then
+ oe_runmake SUBDIRS="scripts/genksyms"
+ fi
+
+ cp -fR scripts ${STAGING_KERNEL_DIR}/
}
kernel_do_configure() {
diff --git a/conf/machine/openzaurus-pxa-2.6.conf b/conf/machine/openzaurus-pxa-2.6.conf
index b1f5c24a7c..29b2402907 100644
--- a/conf/machine/openzaurus-pxa-2.6.conf
+++ b/conf/machine/openzaurus-pxa-2.6.conf
@@ -7,10 +7,10 @@ include conf/machine/zaurus-clamshell.conf
PREFERRED_PROVIDER_virtual/kernel = "openzaurus"
PREFERRED_VERSION_orinoco-modules = "20050101"
-BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel hostap-modules orinoco-modules chkhinge \
+BOOTSTRAP_EXTRA_DEPENDS = "virtual/kernel udev sysfsutils hostap-modules orinoco-modules \
pcmcia-cs apmd ppp wireless-tools irda-utils openswan hostap-wpa-supplicant-nossl lrzsz ppp-dialin"
-BOOTSTRAP_EXTRA_RDEPENDS = "kernel hostap-modules-cs orinoco-modules-cs chkhinge \
-pcmcia-cs apm ppp wireless-tools irda-utils"
+BOOTSTRAP_EXTRA_RDEPENDS = "kernel udev sysfsutils hostap-modules-cs orinoco-modules-cs \
+pcmcia-cs apm ppp wireless-tools irda-utils udev-utils"
# kernel-module-net-fd kernel-module-registers kernel-module-pxa-bi \
# kernel-module-usbdcore kernel-module-usbdmonitor chkhinge"
diff --git a/packages/pcmcia-cs/pcmcia-cs-3.2.8/ide.opts b/packages/pcmcia-cs/pcmcia-cs-3.2.8/ide.opts
index e69de29bb2..d13dab0015 100644
--- a/packages/pcmcia-cs/pcmcia-cs-3.2.8/ide.opts
+++ b/packages/pcmcia-cs/pcmcia-cs-3.2.8/ide.opts
@@ -0,0 +1,25 @@
+# ATA/IDE drive adapter configuration
+#
+# The address format is "scheme,socket,serial_no[,part]".
+#
+# For multi-partition devices, first return list of partitions in
+# $PARTS. Then, we'll get called for each partition.
+#
+case "$ADDRESS" in
+*,*,*,1)
+ #INFO="Sample IDE setup"
+ DO_FSTAB="n";
+ #DO_FSCK="y" ;
+ DO_MOUNT="y"
+ #FSTYPE="msdos"
+ #FSTYPE="auto"
+ #OPTS=""
+ #MOUNTPT="/mnt/ide"
+ ;;
+*,*,*)
+ PARTS="1"
+ # Card eject policy options
+ NO_CHECK=n
+ NO_FUSER=y
+ ;;
+esac
diff --git a/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb b/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
index d170611c5a..17ef69a7d8 100644
--- a/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
+++ b/packages/pcmcia-cs/pcmcia-cs_3.2.8.bb
@@ -3,7 +3,7 @@ SECTION = "base"
PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "virtual/kernel"
-PR = "r13"
+PR = "r14"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcmcia-cs/pcmcia-cs-${PV}.tar.gz \
file://busybox.patch;patch=1 \