aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2006-11-09 22:54:26 +0000
committerRichard Purdie <rpurdie@rpsys.net>2006-11-09 22:54:26 +0000
commitb74404fea18ab4304a409f395ab65c185c750d23 (patch)
treeb2f646b0bfc92774c7780e32262ade1d11ad54b0
parent13932dbeac7d0e2760e42618705485e1bb05422a (diff)
downloadopenembedded-b74404fea18ab4304a409f395ab65c185c750d23.tar.gz
gcc: Factor get_gcc_fpu_setting() into a common .inc file (removing method errors)
-rw-r--r--packages/gcc/gcc-fpu.inc6
-rw-r--r--packages/gcc/gcc3-build.inc5
-rw-r--r--packages/gcc/gcc_3.3.3.bb5
-rw-r--r--packages/gcc/gcc_3.3.4.bb5
4 files changed, 9 insertions, 12 deletions
diff --git a/packages/gcc/gcc-fpu.inc b/packages/gcc/gcc-fpu.inc
new file mode 100644
index 0000000000..bb03d95567
--- /dev/null
+++ b/packages/gcc/gcc-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_gcc_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--with-float=soft"
+ return ""
+
diff --git a/packages/gcc/gcc3-build.inc b/packages/gcc/gcc3-build.inc
index 6260a51533..2924f0f9dd 100644
--- a/packages/gcc/gcc3-build.inc
+++ b/packages/gcc/gcc3-build.inc
@@ -54,10 +54,7 @@ ARCH_FLAGS_FOR_TARGET_slugos = "${TARGET_CC_ARCH}"
ARCH_FLAGS_FOR_TARGET_unslung = "${TARGET_CC_ARCH}"
EXTRA_OEMAKE += "ARCH_FLAGS_FOR_TARGET='${ARCH_FLAGS_FOR_TARGET}'"
-def get_gcc_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--with-float=soft"
- return ""
+require gcc-fpu.inc
python __anonymous () {
import bb, re
diff --git a/packages/gcc/gcc_3.3.3.bb b/packages/gcc/gcc_3.3.3.bb
index 8852f81def..0c237a9166 100644
--- a/packages/gcc/gcc_3.3.3.bb
+++ b/packages/gcc/gcc_3.3.3.bb
@@ -124,10 +124,7 @@ EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
EXTRA_OECONF += "${@get_gcc_fpu_setting(bb, d)}"
-def get_gcc_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--with-float=soft"
- return ""
+require gcc-fpu.inc
python __anonymous () {
import bb, re
diff --git a/packages/gcc/gcc_3.3.4.bb b/packages/gcc/gcc_3.3.4.bb
index 49f14cd888..bb52fa6a1f 100644
--- a/packages/gcc/gcc_3.3.4.bb
+++ b/packages/gcc/gcc_3.3.4.bb
@@ -103,10 +103,7 @@ EXTRA_OECONF_uclibc = "--disable-__cxa_atexit"
EXTRA_OECONF_glibc = "--enable-__cxa_atexit"
EXTRA_OECONF += "${@get_gcc_fpu_setting(bb, d)}"
-def get_gcc_fpu_setting(bb, d):
- if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
- return "--with-float=soft"
- return ""
+require gcc-fpu.inc
python __anonymous () {
import bb, re