aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-03-28 15:07:35 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-03-28 15:07:35 +0000
commitaae834760ee0eb60cfa60353ad09c6b6431acee4 (patch)
tree3ed6dc639b6c1276b7aea5ced391c4e625fc3c75
parent927702f5c5888a272366de915ae873a714a771ed (diff)
parentb5ec0f380297cfc2074318a7d7b95e69cbb8a816 (diff)
downloadopenembedded-aae834760ee0eb60cfa60353ad09c6b6431acee4.tar.gz
merge of '13170805eb277bcec085eb013dda836930e5bee7'
and 'd2c1007682618105ff49ee76ac59d9b164de9572'
-rw-r--r--classes/kernel.bbclass4
-rw-r--r--classes/package.bbclass2
-rw-r--r--packages/ftpd-topfield/files/syslog.patch26
-rwxr-xr-xpackages/ftpd-topfield/ftpd-topfield_0.7.5.bb (renamed from packages/ftpd-topfield/ftpd-topfield_0.7.4.bb)6
-rw-r--r--packages/linux/linux-ixp4xx/defconfig-2.6.24.424
-rw-r--r--packages/linux/linux-ixp4xx/nslu2/defconfig-2.6.24.424
-rw-r--r--packages/linux/linux-ixp4xx_2.6.24.4.bb2
-rw-r--r--packages/linux/linux-rp-2.6.24/sharpsl-rc-r1.patch10
-rw-r--r--packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch180
-rw-r--r--packages/linux/linux-rp_2.6.24.bb11
-rw-r--r--packages/linux/linux.inc14
11 files changed, 274 insertions, 29 deletions
diff --git a/classes/kernel.bbclass b/classes/kernel.bbclass
index f111c9f092..06ae2466ea 100644
--- a/classes/kernel.bbclass
+++ b/classes/kernel.bbclass
@@ -5,6 +5,8 @@ DEPENDS += "virtual/${TARGET_PREFIX}depmod-${@get_kernelmajorversion('${PV}')} v
KERNEL_IMAGETYPE ?= "zImage"
+# Add dependency on mkimage for kernels that build a uImage
+
python __anonymous () {
import bb
@@ -12,7 +14,7 @@ python __anonymous () {
kerneltype = bb.data.getVar('KERNEL_IMAGETYPE', d, 1) or ''
if kerneltype == 'uImage':
depends = bb.data.getVar("DEPENDS", d, 1)
- depends = "%s u-boot-mkimage-native" % depends
+ depends = "%s u-boot-mkimage-openmoko-native" % depends
bb.data.setVar("DEPENDS", depends, d)
}
diff --git a/classes/package.bbclass b/classes/package.bbclass
index eb43856c55..814715e1fa 100644
--- a/classes/package.bbclass
+++ b/classes/package.bbclass
@@ -904,7 +904,7 @@ python package_depchains() {
for suffix in pkgs:
for pkg in pkgs[suffix]:
(base, func) = pkgs[suffix][pkg]
- if suffix == "-dev":
+ if suffix == "-dev" and not pkg.startswith("kernel-module-"):
pkg_adddeprrecs(pkg, base, suffix, func, depends, d)
if len(pkgs[suffix]) == 1:
pkg_addrrecs(pkg, base, suffix, func, rdepends, d)
diff --git a/packages/ftpd-topfield/files/syslog.patch b/packages/ftpd-topfield/files/syslog.patch
new file mode 100644
index 0000000000..8c2bf294f5
--- /dev/null
+++ b/packages/ftpd-topfield/files/syslog.patch
@@ -0,0 +1,26 @@
+--- ftpd-topfield/ftpd.c~ 2008-02-16 09:49:30.000000000 +1030
++++ ftpd-topfield/ftpd.c 2008-03-24 21:45:15.000000000 +1030
+@@ -1190,6 +1190,7 @@
+ if (debug) {
+ fprintf(stderr, "Transfer failed %lld bytes %s\n", (long long)current, srcpath);
+ }
++ syslog(LOG_INFO, "retrieve: Failed transfer of %s @%Ld", srcpath, (long long)current);
+ perror_reply (550, name);
+ }
+
+@@ -1363,6 +1364,7 @@
+ #endif
+
+ if (ret != 0) {
++ syslog(LOG_INFO, "store: Failed transfer of %s @%Ld", destpath, (long long)current);
+ perror_reply (553, name);
+
+ LOGCMD (*mode == 'w' ? "put" : "append", name);
+@@ -1451,6 +1453,7 @@
+ }
+ }
+
++ syslog(LOG_INFO, "store: Failed transfer of %s @%Ld", destpath, (long long)current);
+ /* Failed to cancel the put, so give up */
+ perror_reply (426, "Data Connection");
+ }
diff --git a/packages/ftpd-topfield/ftpd-topfield_0.7.4.bb b/packages/ftpd-topfield/ftpd-topfield_0.7.5.bb
index 356a6018a2..74a3743b1e 100755
--- a/packages/ftpd-topfield/ftpd-topfield_0.7.4.bb
+++ b/packages/ftpd-topfield/ftpd-topfield_0.7.5.bb
@@ -3,9 +3,11 @@ DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
HOMEPAGE = "http://sourceforge.net/projects/puppy"
SECTION = "net"
LICENSE = "MIT"
+PR = "r1"
-SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_4 \
- cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_4 \
+SRC_URI = "cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_7_5 \
+ cvs://anonymous@puppy.cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_7_5 \
+ file://syslog.patch;patch=1 \
file://init"
# The source will end up in the subdirectory 'ftpd-topfield' - no release name
diff --git a/packages/linux/linux-ixp4xx/defconfig-2.6.24.4 b/packages/linux/linux-ixp4xx/defconfig-2.6.24.4
index 0a3c0eb47d..de78fc3741 100644
--- a/packages/linux/linux-ixp4xx/defconfig-2.6.24.4
+++ b/packages/linux/linux-ixp4xx/defconfig-2.6.24.4
@@ -30,7 +30,6 @@ CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config"
#
CONFIG_EXPERIMENTAL=y
CONFIG_BROKEN_ON_SMP=y
-CONFIG_LOCK_KERNEL=y
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_LOCALVERSION=""
# CONFIG_LOCALVERSION_AUTO is not set
@@ -217,7 +216,7 @@ CONFIG_PCI_SYSCALL=y
CONFIG_TICK_ONESHOT=y
CONFIG_NO_HZ=y
CONFIG_HIGH_RES_TIMERS=y
-CONFIG_PREEMPT=y
+# CONFIG_PREEMPT is not set
CONFIG_HZ=100
CONFIG_AEABI=y
CONFIG_OABI_COMPAT=y
@@ -304,9 +303,26 @@ CONFIG_INET_XFRM_MODE_TUNNEL=y
CONFIG_INET_XFRM_MODE_BEET=m
CONFIG_INET_DIAG=y
CONFIG_INET_TCP_DIAG=y
-# CONFIG_TCP_CONG_ADVANCED is not set
+CONFIG_TCP_CONG_ADVANCED=y
+# CONFIG_TCP_CONG_BIC is not set
CONFIG_TCP_CONG_CUBIC=y
-CONFIG_DEFAULT_TCP_CONG="cubic"
+# CONFIG_TCP_CONG_WESTWOOD is not set
+# CONFIG_TCP_CONG_HTCP is not set
+# CONFIG_TCP_CONG_HSTCP is not set
+# CONFIG_TCP_CONG_HYBLA is not set
+# CONFIG_TCP_CONG_VEGAS is not set
+# CONFIG_TCP_CONG_SCALABLE is not set
+# CONFIG_TCP_CONG_LP is not set
+# CONFIG_TCP_CONG_VENO is not set
+# CONFIG_TCP_CONG_YEAH is not set
+# CONFIG_TCP_CONG_ILLINOIS is not set
+# CONFIG_DEFAULT_BIC is not set
+# CONFIG_DEFAULT_CUBIC is not set
+# CONFIG_DEFAULT_HTCP is not set
+# CONFIG_DEFAULT_VEGAS is not set
+# CONFIG_DEFAULT_WESTWOOD is not set
+CONFIG_DEFAULT_RENO=y
+CONFIG_DEFAULT_TCP_CONG="reno"
# CONFIG_TCP_MD5SIG is not set
# CONFIG_IP_VS is not set
CONFIG_IPV6=m
diff --git a/packages/linux/linux-ixp4xx/nslu2/defconfig-2.6.24.4 b/packages/linux/linux-ixp4xx/nslu2/defconfig-2.6.24.4
index 01f91b572a..2a382b34b3 100644
--- a/packages/linux/linux-ixp4xx/nslu2/defconfig-2.6.24.4
+++ b/packages/linux/linux-ixp4xx/nslu2/defconfig-2.6.24.4
@@ -30,7 +30,6 @@ CONFIG_DEFCONFIG_LIST="/lib/modules/$UNAME_RELEASE/.config"
#
CONFIG_EXPERIMENTAL=y
CONFIG_BROKEN_ON_SMP=y
-CONFIG_LOCK_KERNEL=y
CONFIG_INIT_ENV_ARG_LIMIT=32
CONFIG_LOCALVERSION=""
# CONFIG_LOCALVERSION_AUTO is not set
@@ -217,7 +216,7 @@ CONFIG_PCI_SYSCALL=y
CONFIG_TICK_ONESHOT=y
CONFIG_NO_HZ=y
CONFIG_HIGH_RES_TIMERS=y
-CONFIG_PREEMPT=y
+# CONFIG_PREEMPT is not set
CONFIG_HZ=100
CONFIG_AEABI=y
CONFIG_OABI_COMPAT=y
@@ -305,9 +304,26 @@ CONFIG_INET_XFRM_MODE_TUNNEL=m
CONFIG_INET_XFRM_MODE_BEET=m
CONFIG_INET_DIAG=m
CONFIG_INET_TCP_DIAG=m
-# CONFIG_TCP_CONG_ADVANCED is not set
+CONFIG_TCP_CONG_ADVANCED=y
+# CONFIG_TCP_CONG_BIC is not set
CONFIG_TCP_CONG_CUBIC=y
-CONFIG_DEFAULT_TCP_CONG="cubic"
+# CONFIG_TCP_CONG_WESTWOOD is not set
+# CONFIG_TCP_CONG_HTCP is not set
+# CONFIG_TCP_CONG_HSTCP is not set
+# CONFIG_TCP_CONG_HYBLA is not set
+# CONFIG_TCP_CONG_VEGAS is not set
+# CONFIG_TCP_CONG_SCALABLE is not set
+# CONFIG_TCP_CONG_LP is not set
+# CONFIG_TCP_CONG_VENO is not set
+# CONFIG_TCP_CONG_YEAH is not set
+# CONFIG_TCP_CONG_ILLINOIS is not set
+# CONFIG_DEFAULT_BIC is not set
+# CONFIG_DEFAULT_CUBIC is not set
+# CONFIG_DEFAULT_HTCP is not set
+# CONFIG_DEFAULT_VEGAS is not set
+# CONFIG_DEFAULT_WESTWOOD is not set
+CONFIG_DEFAULT_RENO=y
+CONFIG_DEFAULT_TCP_CONG="reno"
# CONFIG_TCP_MD5SIG is not set
# CONFIG_IP_VS is not set
CONFIG_IPV6=m
diff --git a/packages/linux/linux-ixp4xx_2.6.24.4.bb b/packages/linux/linux-ixp4xx_2.6.24.4.bb
index d7ccb4c096..1964c23839 100644
--- a/packages/linux/linux-ixp4xx_2.6.24.4.bb
+++ b/packages/linux/linux-ixp4xx_2.6.24.4.bb
@@ -8,7 +8,7 @@ KERNEL_RELEASE = "2.6.24.4"
#PV = "${VANILLA_VERSION}+${KERNEL_RELEASE}+svnr${SRCREV}"
PV = "${KERNEL_RELEASE}+svnr${SRCREV}"
-PR = "r0"
+PR = "r1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${VANILLA_VERSION}.tar.bz2 \
${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/patch-${KERNEL_RELEASE}.bz2;patch=1 \
diff --git a/packages/linux/linux-rp-2.6.24/sharpsl-rc-r1.patch b/packages/linux/linux-rp-2.6.24/sharpsl-rc-r1.patch
index 32a94c7cea..bed41c55d5 100644
--- a/packages/linux/linux-rp-2.6.24/sharpsl-rc-r1.patch
+++ b/packages/linux/linux-rp-2.6.24/sharpsl-rc-r1.patch
@@ -1,3 +1,13 @@
+This patch adds support for Sharp CE-RH2 on Spitz.
+
+It is not clean enough to be upstreamed:
+- It is a bit syslog-noisy.
+- Does not support other Zaurus models.
+- Maybe split to more parts:
+ * MAX1111 driver
+ * linear input device
+ * virtual keyboard on top of linear input device
+
Index: linux-2.6.24/arch/arm/mach-pxa/spitz.c
===================================================================
--- linux-2.6.24.orig/arch/arm/mach-pxa/spitz.c 2008-03-10 17:05:37.000000000 +0000
diff --git a/packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch b/packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch
new file mode 100644
index 0000000000..6fb34ec179
--- /dev/null
+++ b/packages/linux/linux-rp-2.6.24/sharpsl-rc-r2.patch
@@ -0,0 +1,180 @@
+This patch adds support for Sharp CE-RH2 on Akita and CE-RH1 on C7x0.
+
+This patch is a bit ugly:
+- Device specific functions should be moved to platform infrastructure.
+- Maybe define generic *_scoopexp functions handling Akita x Spitz differences.
+
+Index: linux-2.6.24/drivers/input/keyboard/sharpsl_rc.c
+===================================================================
+--- linux-2.6.24.orig/drivers/input/keyboard/sharpsl_rc.c 2008-03-08 19:29:02.000000000 +0000
++++ linux-2.6.24/drivers/input/keyboard/sharpsl_rc.c 2008-03-08 22:23:35.000000000 +0000
+@@ -21,12 +21,10 @@
+ #include <linux/module.h>
+ #include <linux/slab.h>
+
+-#ifdef CONFIG_MACH_SPITZ
++#include <asm/mach-types.h>
+ #include <asm/arch/spitz.h>
+-#endif
+-#ifdef CONFIG_MACH_CORGI
++#include <asm/arch/akita.h>
+ #include <asm/arch/corgi.h>
+-#endif
+
+ #include <asm/arch/hardware.h>
+ #include <asm/arch/pxa-regs.h>
+@@ -42,12 +40,8 @@
+ unsigned char key;
+ };
+
+-#ifdef CONFIG_MACH_SPITZ
+-#define REMOTE_AKIN_PULLUP SPITZ_SCP2_AKIN_PULLUP
+-#define REMOTE_SCOOP_DEVICE spitzscoop2_device
+-#define REMOTE_GPIO_INT SPITZ_GPIO_AK_INT
+-#define REMOTE_IRQ_INT SPITZ_IRQ_GPIO_AK_INT
+-static struct remote_control_key remote_keys[] = {
++static struct remote_control_key remote_keys_spitz[] = {
++ /* CE-RH2 values */
+ { 25, 35, KEY_STOPCD},
+ { 55, 65, KEY_PLAYPAUSE},
+ { 85, 95, KEY_NEXTSONG},
+@@ -56,23 +50,15 @@
+ { 180, 190, KEY_MUTE},
+ { 215, 225, KEY_VOLUMEDOWN},
+ };
+-#endif
+-#ifdef CONFIG_MACH_CORGI
+-#define REMOTE_AKIN_PULLUP CORGI_SCP_AKIN_PULLUP
+-#define REMOTE_SCOOP_DEVICE corgiscoop_device
+-#define REMOTE_GPIO_INT CORGI_GPIO_AK_INT
+-#define REMOTE_IRQ_INT CORGI_IRQ_GPIO_AK_INT
+-static struct remote_control_key remote_keys[] = {
+- //These need to be fixed for the CE-RH1's values
+- { 25, 35, KEY_STOPCD},
+- { 55, 65, KEY_PLAYPAUSE},
+- { 85, 95, KEY_NEXTSONG},
+- { 115, 125, KEY_VOLUMEUP},
+- { 145, 155, KEY_PREVIOUSSONG},
+- { 180, 190, KEY_MUTE},
+- { 215, 225, KEY_VOLUMEDOWN},
++static struct remote_control_key remote_keys_corgi[] = {
++ /* CE-RH1 values */
++ { 27, 35, KEY_STOPCD},
++ { 7, 13, KEY_PLAYPAUSE},
++ { 77, 93, KEY_NEXTSONG},
++ { 115, 132, KEY_VOLUMEUP},
++ { 46, 58, KEY_PREVIOUSSONG},
++ { 170, 186, KEY_VOLUMEDOWN},
+ };
+-#endif
+
+ #define RELEASE_HI 230
+ #define MAX_EARPHONE 6
+@@ -98,9 +84,17 @@
+ static int get_remocon_raw(void)
+ {
+ int i, val;
++ struct remote_control_key *remote_keys;
++
++ if (machine_is_borzoi() || machine_is_spitz() || machine_is_akita())
++ remote_keys = remote_keys_spitz;
++ else
++ remote_keys = remote_keys_corgi;
+
+ val = sharpsl_pm_pxa_read_max1111(MAX1111_REMCOM);
+- for (i = 0; i < ARRAY_SIZE(remote_keys); ++i) {
++ for (i = 0; i < (machine_is_borzoi() || machine_is_spitz() || machine_is_akita() ?
++ ARRAY_SIZE(remote_keys_spitz) : ARRAY_SIZE(remote_keys_corgi));
++ ++i) {
+ if (val >= remote_keys[i].min
+ && val <= remote_keys[i].max) {
+ printk("get_remocon_raw: VAL=%i, KEY=%i\n", val, remote_keys[i].key);
+@@ -121,8 +115,12 @@
+ data->state = 0;
+ data->last_key = 0;
+
+- reset_scoop_gpio(&REMOTE_SCOOP_DEVICE.dev, REMOTE_AKIN_PULLUP);
+-
++ if (machine_is_borzoi() || machine_is_spitz())
++ reset_scoop_gpio(platform_scoop_config->devs[1].dev, SPITZ_SCP2_AKIN_PULLUP);
++ else if (machine_is_akita())
++ akita_reset_ioexp(&akitaioexp_device.dev, AKITA_IOEXP_AKIN_PULLUP);
++ else
++ reset_scoop_gpio(platform_scoop_config->devs[0].dev, CORGI_SCP_AKIN_PULLUP);
+ mod_timer(&data->rctimer, jiffies + msecs_to_jiffies(RC_POLL_MS));
+ }
+ return IRQ_HANDLED;
+@@ -182,7 +180,12 @@
+ if (timer) {
+ mod_timer(&data->rctimer, jiffies + msecs_to_jiffies(RC_POLL_MS));
+ } else {
+- set_scoop_gpio(&REMOTE_SCOOP_DEVICE.dev, REMOTE_AKIN_PULLUP);
++ if (machine_is_borzoi() || machine_is_spitz())
++ set_scoop_gpio(platform_scoop_config->devs[1].dev, SPITZ_SCP2_AKIN_PULLUP);
++ else if (machine_is_akita())
++ akita_set_ioexp(&akitaioexp_device.dev, AKITA_IOEXP_AKIN_PULLUP);
++ else
++ set_scoop_gpio(platform_scoop_config->devs[0].dev, CORGI_SCP_AKIN_PULLUP);
+ data->handling_press = 0;
+ }
+ }
+@@ -192,6 +195,7 @@
+ struct sharpsl_rc *sharpsl_rc;
+ struct input_dev *input_dev;
+ int i, ret;
++ struct remote_control_key *remote_keys;
+
+ dev_dbg(&pdev->dev, "sharpsl_rc_probe\n");
+
+@@ -225,17 +229,32 @@
+
+ input_dev->evbit[0] = BIT(EV_KEY);
+
+- for (i = 0; i <= ARRAY_SIZE(remote_keys); i++)
++ if (machine_is_borzoi() || machine_is_spitz() || machine_is_akita())
++ remote_keys = remote_keys_spitz;
++ else
++ remote_keys = remote_keys_corgi;
++ for (i = 0; i < (machine_is_borzoi() || machine_is_spitz() || machine_is_akita() ?
++ ARRAY_SIZE(remote_keys_spitz) : ARRAY_SIZE(remote_keys_corgi));
++ ++i)
+ set_bit(remote_keys[i].key, input_dev->keybit);
+
+ input_register_device(sharpsl_rc->input);
+
+- pxa_gpio_mode(REMOTE_GPIO_INT | GPIO_IN);
+- ret = request_irq(REMOTE_IRQ_INT,
+- sharpsl_rc_interrupt,
+- IRQF_DISABLED | IRQF_TRIGGER_RISING | IRQF_TRIGGER_FALLING | IRQF_SHARED,
+- "sharpsl_rc",
+- sharpsl_rc);
++ if (machine_is_borzoi() || machine_is_spitz() || machine_is_akita()) {
++ pxa_gpio_mode(SPITZ_GPIO_AK_INT | GPIO_IN);
++ ret = request_irq(SPITZ_IRQ_GPIO_AK_INT,
++ sharpsl_rc_interrupt,
++ IRQF_DISABLED | IRQF_TRIGGER_RISING | IRQF_TRIGGER_FALLING | IRQF_SHARED,
++ "sharpsl_rc",
++ sharpsl_rc);
++ } else {
++ pxa_gpio_mode(CORGI_GPIO_AK_INT | GPIO_IN);
++ ret = request_irq(CORGI_IRQ_GPIO_AK_INT,
++ sharpsl_rc_interrupt,
++ IRQF_DISABLED | IRQF_TRIGGER_RISING | IRQF_TRIGGER_FALLING | IRQF_SHARED,
++ "sharpsl_rc",
++ sharpsl_rc);
++ }
+ if (ret < 0) {
+ dev_dbg(&pdev->dev, "Can't get IRQ: %d!\n", i);
+ kfree(sharpsl_rc);
+@@ -252,7 +271,10 @@
+
+ dev_dbg(&pdev->dev, "sharpsl_rc_remove\n");
+
+- free_irq(REMOTE_IRQ_INT, sharpsl_rc);
++ if (machine_is_borzoi() || machine_is_spitz() || machine_is_akita())
++ free_irq(SPITZ_IRQ_GPIO_AK_INT, sharpsl_rc);
++ else
++ free_irq(CORGI_IRQ_GPIO_AK_INT, sharpsl_rc);
+ del_timer_sync(&sharpsl_rc->rctimer);
+ input_unregister_device(sharpsl_rc->input);
+ kfree(sharpsl_rc);
diff --git a/packages/linux/linux-rp_2.6.24.bb b/packages/linux/linux-rp_2.6.24.bb
index 2b13fc47f1..32a3b0544e 100644
--- a/packages/linux/linux-rp_2.6.24.bb
+++ b/packages/linux/linux-rp_2.6.24.bb
@@ -1,6 +1,6 @@
require linux-rp.inc
-PR = "r5"
+PR = "r6"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_collie = "1"
@@ -58,6 +58,7 @@ SRC_URI = "${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
file://connectplus-prevent-oops-HACK.patch;patch=1;status=hack \
file://binutils-buildid-arm.patch;patch=1 \
file://versatile-armv6.patch;patch=1 \
+ file://htcuni.patch;patch=1 \
file://defconfig-c7x0 \
file://defconfig-hx2000 \
file://defconfig-collie \
@@ -74,7 +75,6 @@ SRC_URI = "${KERNELORG_MIRROR}pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
# FIXMEs before made default
# ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
-# file://htcuni.patch;patch=1 \
# Add this to enable pm debug code (useful with a serial lead)
# ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
@@ -183,6 +183,7 @@ SRC_URI_append_akita = "\
file://mtd-module.patch;patch=1;status=external \
file://wm8750-treble.patch;patch=1;status=external \
file://sharpsl-rc-r1.patch;patch=1 \
+ file://sharpsl-rc-r2.patch;patch=1 \
"
SRC_URI_append_spitz = "\
@@ -190,6 +191,12 @@ SRC_URI_append_spitz = "\
file://wm8750-treble.patch;patch=1;status=external \
file://spitz_h_rewrite.patch;patch=1;status=external \
file://sharpsl-rc-r1.patch;patch=1 \
+ file://sharpsl-rc-r2.patch;patch=1 \
+ "
+
+SRC_URI_append_c7x0 = "\
+ file://sharpsl-rc-r1.patch;patch=1 \
+ file://sharpsl-rc-r2.patch;patch=1 \
"
SRC_URI_append_htcuniversal ="\
diff --git a/packages/linux/linux.inc b/packages/linux/linux.inc
index 66636ba50e..e46061610d 100644
--- a/packages/linux/linux.inc
+++ b/packages/linux/linux.inc
@@ -4,20 +4,6 @@ LICENSE = "GPL"
inherit kernel
-# Add dependency on mkimage for kernels that build a uImage
-
-python __anonymous () {
-
- import bb
-
- kerneltype = bb.data.getVar('KERNEL_IMAGETYPE', d, 1) or ''
- if kerneltype == 'uImage':
- depends = bb.data.getVar("DEPENDS", d, 1)
- depends = "%s u-boot-mkimage-openmoko-native" % depends
- bb.data.setVar("DEPENDS", depends, d)
-}
-
-
RPSRC = "http://www.rpsys.net/openzaurus/patches/archive"
# Specify the commandline for your device