aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-17 01:08:05 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-05-17 01:08:05 +0000
commita5d41de93e5b446d96dbb0262ac3b025e61336f8 (patch)
tree032a822e3af014e017c587964608b3061228019e
parentcdd775817695d7e28102e07783718d1f31a4fbdd (diff)
downloadopenembedded-a5d41de93e5b446d96dbb0262ac3b025e61336f8.tar.gz
dillo2: fix compilation problem with patch from Marek Vasut. Clean white space. Closes 2032.
-rw-r--r--packages/dillo/dillo2-0.6.6/dillo2-gcc4.patch27
-rw-r--r--packages/dillo/dillo2_0.6.6.bb9
2 files changed, 32 insertions, 4 deletions
diff --git a/packages/dillo/dillo2-0.6.6/dillo2-gcc4.patch b/packages/dillo/dillo2-0.6.6/dillo2-gcc4.patch
new file mode 100644
index 0000000000..b8e01aaca5
--- /dev/null
+++ b/packages/dillo/dillo2-0.6.6/dillo2-gcc4.patch
@@ -0,0 +1,27 @@
+diff -Naur dillo-0.6.6-orig/src/dw_table.c dillo-0.6.6/src/dw_table.c
+--- dillo-0.6.6-orig/src/dw_table.c 2007-03-22 22:46:10.000000000 +0100
++++ dillo-0.6.6/src/dw_table.c 2007-03-22 22:48:57.000000000 +0100
+@@ -1177,7 +1177,10 @@
+ sub_extr_width = rest_w * cols_per_sub / rest_n;
+ rest_w -= sub_extr_width;
+ rest_n -= cols_per_sub;
+- EXTR_VALUE (sub_extremes[i]) = sub_extr_width;
++ if(max)
++ sub_extremes[i].max_width = sub_extr_width;
++ else
++ sub_extremes[i].min_width = sub_extr_width;
+ }
+ }
+ } else {
+@@ -1196,7 +1199,10 @@
+ delta = rest_w * EXTR_VALUE (sub_extremes[i]) / rest_n;
+ rest_w -= delta;
+ rest_n -= EXTR_VALUE (sub_extremes[i]);
+- EXTR_VALUE (sub_extremes[i]) += delta;
++ if(max)
++ sub_extremes[i].max_width += delta;
++ else
++ sub_extremes[i].min_width += delta;
+ }
+ DEBUG_MSG (DEBUG_WIDTH_LEVEL + 2, "%d\n",
+ EXTR_VALUE (sub_extremes[i]));
diff --git a/packages/dillo/dillo2_0.6.6.bb b/packages/dillo/dillo2_0.6.6.bb
index f6052e860d..0eef5d9fd8 100644
--- a/packages/dillo/dillo2_0.6.6.bb
+++ b/packages/dillo/dillo2_0.6.6.bb
@@ -4,11 +4,12 @@ LICENSE = "GPL"
DEPENDS = "gtk+"
RDEPENDS = "gdk-pixbuf-loader-xpm"
SRC_URI="http://www.dillo.org/download/dillo-${PV}.tar.gz \
+ file://dillo2-gcc4.patch;patch=1;pnum=1 \
file://gtk2.patch;patch=1;pnum=1 \
- file://fix_about_syntax.patch;patch=1;pnum=1 \
- file://dillo.desktop \
- file://dillo.png \
- file://dillorc"
+ file://fix_about_syntax.patch;patch=1;pnum=1 \
+ file://dillo.desktop \
+ file://dillo.png \
+ file://dillorc"
PRIORITY = "optional"