aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2007-09-07 21:11:21 +0000
committerStefan Schmidt <stefan@datenfreihafen.org>2007-09-07 21:11:21 +0000
commit6df7b6c8ef449b4d70ff6fce2871ba1bc48ad248 (patch)
tree4e6b3b23cb7ed3b61d258f8b217a1059fd2ac245
parenta8543e0eb9b23051fb42d4f67928bcb1245becbf (diff)
downloadopenembedded-6df7b6c8ef449b4d70ff6fce2871ba1bc48ad248.tar.gz
opentapi: Remove as superseeded by ezxd
-rw-r--r--conf/distro/include/sane-srcrevs.inc1
-rw-r--r--conf/machine/include/motorola-ezx-base.inc4
-rw-r--r--packages/ezx/ezxd_svn.bb5
-rw-r--r--packages/ezx/opentapi/.mtn2git_empty0
-rw-r--r--packages/ezx/opentapi/opentapi.init84
-rw-r--r--packages/ezx/opentapi_svn.bb28
6 files changed, 3 insertions, 119 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index 27ce277965..de00bfb30a 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -68,7 +68,6 @@ SRCREV_pn-openmoko-theme-standard-qvga="2370"
SRCREV_pn-openmoko-today="2556"
SRCREV_pn-openmoko-today2="2919"
SRCREV_pn-openmoko-today2-folders="2680"
-SRCREV_pn-opentapi="2012"
SRCREV_pn-sphyrna="43"
SRCREV_pn-webkit-gtk="webcore"
SRCREV_pn-xoo="1623"
diff --git a/conf/machine/include/motorola-ezx-base.inc b/conf/machine/include/motorola-ezx-base.inc
index 52b9ccc65d..95496b3266 100644
--- a/conf/machine/include/motorola-ezx-base.inc
+++ b/conf/machine/include/motorola-ezx-base.inc
@@ -15,7 +15,7 @@ EXTRA_IMAGECMD_jffs2 = "--pad=14680064 --little-endian --eraseblock=0x20000 -n"
MACHINE_FEATURES = "kernel26 touchscreen apm alsa bluetooth usbgadget usbhost keyboard screen"
-# the EZX phones need a userspace daemon to stop the BP from shutting down the phone
+# the EZX phones need a userspace daemon to stop the BP from shutting down the phone
MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "ezxd"
MACHINE_DISPLAY_WIDTH_PIXELS = "240"
@@ -27,7 +27,7 @@ ROOT_FLASH_SIZE = "24"
EXTRA_IMAGEDEPENDS += "ezx-boot-usb-native"
-# Opentapi needs to be started very early so we need the mux devices in static /dev
+# Ezxd needs to be started very early so we need the mux devices in static /dev
IMAGE_DEVICE_TABLES = "files/device_table-minimal.txt \
files/device_table-ezx.txt"
diff --git a/packages/ezx/ezxd_svn.bb b/packages/ezx/ezxd_svn.bb
index 3a052174b2..9aed2a4465 100644
--- a/packages/ezx/ezxd_svn.bb
+++ b/packages/ezx/ezxd_svn.bb
@@ -15,9 +15,6 @@ inherit update-rc.d
INITSCRIPT_NAME = "ezxd"
INITSCRIPT_PARAMS = "start 00 S ."
-RREPLACES = "opentapi"
-
-
S = "${WORKDIR}/${PN}"
do_install() {
@@ -26,7 +23,7 @@ do_install() {
install -d ${D}${libdir}/ezxd
install -m 755 *.so ${D}${libdir}/ezxd
-
+
install -d ${D}${sysconfdir}/init.d
install -m 0600 ezxd.conf ${D}${sysconfdir}/
install -m 0755 ${WORKDIR}/ezxd.init ${D}${sysconfdir}/init.d/ezxd
diff --git a/packages/ezx/opentapi/.mtn2git_empty b/packages/ezx/opentapi/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/ezx/opentapi/.mtn2git_empty
+++ /dev/null
diff --git a/packages/ezx/opentapi/opentapi.init b/packages/ezx/opentapi/opentapi.init
deleted file mode 100644
index 0b41418e00..0000000000
--- a/packages/ezx/opentapi/opentapi.init
+++ /dev/null
@@ -1,84 +0,0 @@
-#! /bin/sh
-# -*- coding: utf-8 -*-
-# init.d script for opentapi
-
-set -e
-
-DAEMON=/usr/bin/opentapi
-NAME=opentapi
-PIDDIR=/var/run/opentapi
-PIDFILE=$PIDDIR/pid
-DESC="OpenTAPI server"
-
-test -x $DAEMON || exit 0
-
-# Source defaults file; edit that file to configure this script.
-ENABLED=1
-PARAMS=""
-if [ -e /etc/default/opentapi ]; then
- . /etc/default/opentapi
-fi
-
-test "$ENABLED" != "0" || exit 0
-
-start_it_up()
-{
- if [ ! -d $PIDDIR ]; then
- mkdir -p $PIDDIR
- fi
- if [ -e $PIDFILE ]; then
- PIDDIR=/proc/$(cat $PIDFILE)
- if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
- echo "$DESC already started; not starting."
- else
- echo "Removing stale PID file $PIDFILE."
- rm -f $PIDFILE
- fi
- fi
-
- echo -n "Starting $DESC: "
- start-stop-daemon --start --background --quiet --pidfile $PIDFILE \
- --exec $DAEMON -- --system $PARAMS
- # We need to sleep here because opening the mux devices takes some time
- sleep 15
- echo "$NAME."
- if [ -d $EVENTDIR ]; then
- run-parts --arg=start $EVENTDIR
- fi
-}
-
-shut_it_down()
-{
- if [ -d $EVENTDIR ]; then
- run-parts --reverse --arg=stop $EVENTDIR
- fi
- echo -n "Stopping $DESC: "
- start-stop-daemon --stop --quiet --pidfile $PIDFILE
-
- # We no longer include these arguments so that start-stop-daemon
- # can do its job even given that we may have been upgraded.
- # We rely on the pidfile being sanely managed
- # --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- rm -f $PIDFILE
-}
-
-case "$1" in
- start)
- start_it_up
- ;;
- stop)
- shut_it_down
- ;;
- restart|force-reload)
- shut_it_down
- sleep 1
- start_it_up
- ;;
- *)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/ezx/opentapi_svn.bb b/packages/ezx/opentapi_svn.bb
deleted file mode 100644
index 7426dfe853..0000000000
--- a/packages/ezx/opentapi_svn.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-DESCRIPTION = "Open implementation of motorola's tapisrv"
-LICENSE = "GPLv2"
-SECTION = "devel"
-AUTHOR = "Daniel Willmann"
-
-PV = "0.0+svnr${SRCREV}"
-PR = "r3"
-
-SRC_URI = "svn://svn.openezx.org/trunk/src/userspace/;module=opentapi;proto=http \
- file://opentapi.init \
- "
-
-inherit update-rc.d
-
-INITSCRIPT_NAME = "opentapi"
-INITSCRIPT_PARAMS = "start 00 S ."
-
-
-S = "${WORKDIR}/${PN}"
-
-do_install() {
- install -d ${D}${bindir}
- install -m 755 opentapi ${D}${bindir}
-
- install -d ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/opentapi.init ${D}${sysconfdir}/init.d/opentapi
-}
-