aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-11-09 14:04:41 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-11-09 14:04:41 +0000
commit3ef9099e3d8778f6a5b45fdaf59b5aa2b708bdf5 (patch)
tree3f9026e9adad2d606caf7885baed27e17da592e7
parent96918636f93b1e4dd87a9a0893793e4fc77be262 (diff)
downloadopenembedded-3ef9099e3d8778f6a5b45fdaf59b5aa2b708bdf5.tar.gz
hal_0.5.7.bb : fix for dbus 1.0 API changes
-rw-r--r--packages/hal/files/.mtn2git_empty0
-rw-r--r--packages/hal/files/dbus-fix-api.patch26
-rw-r--r--packages/hal/hal_0.5.7.bb3
3 files changed, 28 insertions, 1 deletions
diff --git a/packages/hal/files/.mtn2git_empty b/packages/hal/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hal/files/.mtn2git_empty
diff --git a/packages/hal/files/dbus-fix-api.patch b/packages/hal/files/dbus-fix-api.patch
new file mode 100644
index 0000000000..1f025870bc
--- /dev/null
+++ b/packages/hal/files/dbus-fix-api.patch
@@ -0,0 +1,26 @@
+Index: hal-0.5.7/tools/lshal.c
+===================================================================
+--- hal-0.5.7.orig/tools/lshal.c 2006-02-13 14:35:31.000000000 +0000
++++ hal-0.5.7/tools/lshal.c 2006-11-09 13:48:07.000000000 +0000
+@@ -701,7 +701,7 @@
+ libhal_ctx_shutdown (hal_ctx, &error);
+ libhal_ctx_free (hal_ctx);
+
+- dbus_connection_disconnect (conn);
++ dbus_connection_close (conn);
+ dbus_connection_unref (conn);
+
+ if (show_device)
+Index: hal-0.5.7/tools/hal-device.c
+===================================================================
+--- hal-0.5.7.orig/tools/hal-device.c 2006-11-09 13:49:44.000000000 +0000
++++ hal-0.5.7/tools/hal-device.c 2006-11-09 13:50:00.000000000 +0000
+@@ -155,7 +155,7 @@
+
+ libhal_ctx_shutdown(hal_ctx, &error);
+ libhal_ctx_free(hal_ctx);
+- dbus_connection_disconnect(conn);
++ dbus_connection_close(conn);
+ dbus_connection_unref(conn);
+ dbus_error_free(&error);
+
diff --git a/packages/hal/hal_0.5.7.bb b/packages/hal/hal_0.5.7.bb
index 5476e2ec22..6139203f10 100644
--- a/packages/hal/hal_0.5.7.bb
+++ b/packages/hal/hal_0.5.7.bb
@@ -8,7 +8,8 @@ HOMEPAGE = "http://freedesktop.org/Software/hal"
LICENSE = "GPL LGPL AFL"
PR = "r0"
-SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz"
+SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
+ file://dbus-fix-api.patch;patch=1"
S = "${WORKDIR}/hal-${PV}"
inherit autotools pkgconfig