summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/nettle/nettle
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/nettle/nettle')
-rw-r--r--meta/recipes-support/nettle/nettle/Add-target-to-only-build-tests-not-run-them.patch21
-rw-r--r--meta/recipes-support/nettle/nettle/check-header-files-of-openssl-only-if-enable_.patch26
-rw-r--r--meta/recipes-support/nettle/nettle/dlopen-test.patch29
-rw-r--r--meta/recipes-support/nettle/nettle/run-ptest40
4 files changed, 54 insertions, 62 deletions
diff --git a/meta/recipes-support/nettle/nettle/Add-target-to-only-build-tests-not-run-them.patch b/meta/recipes-support/nettle/nettle/Add-target-to-only-build-tests-not-run-them.patch
index e3f5c6de7d..345fc43ebe 100644
--- a/meta/recipes-support/nettle/nettle/Add-target-to-only-build-tests-not-run-them.patch
+++ b/meta/recipes-support/nettle/nettle/Add-target-to-only-build-tests-not-run-them.patch
@@ -1,4 +1,7 @@
-Add target to only build tests (not run them)
+From e9fcb2177fda228ac065d189240e2d992e86e5bf Mon Sep 17 00:00:00 2001
+From: Trevor Gamblin <tgamblin@baylibre.com>
+Date: Fri, 2 Aug 2024 09:48:43 -0400
+Subject: [PATCH] Makefile.in: Add target to only build tests (not run them)
Not sending upstream as this is only a start of a solution to
installable tests: It's useful for us already as is.
@@ -8,16 +11,20 @@ Upstream-Status: Inappropriate [not a complete solution]
Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
Refactored for 3.4
Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+Refactor for 3.10, including turning it into an mbox for easier use.
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
Makefile.in | 3 +++
testsuite/Makefile.in | 2 ++
2 files changed, 5 insertions(+)
diff --git a/Makefile.in b/Makefile.in
-index e5ccfc7..15c9275 100644
+index 2bf7f1e8..403a868a 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -52,6 +52,9 @@ clean distclean mostlyclean maintainer-clean tags:
+@@ -53,6 +53,9 @@ clean distclean mostlyclean maintainer-clean tags:
echo "Making $@ in $$d" ; (cd $$d && $(MAKE) $@); done
$(MAKE) $@-here
@@ -28,18 +35,18 @@ index e5ccfc7..15c9275 100644
true
diff --git a/testsuite/Makefile.in b/testsuite/Makefile.in
-index 3f5e5f6..8fd68a3 100644
+index 0699fa0d..8ac9983c 100644
--- a/testsuite/Makefile.in
+++ b/testsuite/Makefile.in
-@@ -122,6 +122,8 @@ $(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) ../nettle-internal.$(OBJEXT) \
+@@ -137,6 +137,8 @@ $(TARGETS) $(EXTRA_TARGETS): testutils.$(OBJEXT) ../non-nettle.$(OBJEXT) \
# data.
VALGRIND = valgrind --error-exitcode=1 --leak-check=full --show-reachable=yes @IF_ASM@ --partial-loads-ok=yes
+buildtest: $(TS_ALL)
+
- check: $(TS_ALL)
+ check: $(TS_ALL) $(TS_ALL:sc-%=%)
TEST_SHLIB_DIR="$(TEST_SHLIB_DIR)" \
srcdir="$(srcdir)" \
--
-2.17.1
+2.39.2
diff --git a/meta/recipes-support/nettle/nettle/check-header-files-of-openssl-only-if-enable_.patch b/meta/recipes-support/nettle/nettle/check-header-files-of-openssl-only-if-enable_.patch
index d5f266681e..49d633b5f7 100644
--- a/meta/recipes-support/nettle/nettle/check-header-files-of-openssl-only-if-enable_.patch
+++ b/meta/recipes-support/nettle/nettle/check-header-files-of-openssl-only-if-enable_.patch
@@ -1,4 +1,4 @@
-From ffee6b5f6204a0210f717968ec6ce514d70acca1 Mon Sep 17 00:00:00 2001
+From 5f7cdd2b878298577accade43a38e1a0951d17b4 Mon Sep 17 00:00:00 2001
From: Haiqing Bai <Haiqing.Bai@windriver.com>
Date: Fri, 9 Dec 2016 15:23:17 +0800
Subject: [PATCH] nettle: check header files of openssl only if
@@ -15,22 +15,32 @@ refactored for 3.4. pending not in as of 3.4
Signed-off-by: Armin Kuster <akuster@mvista.com>
-Index: nettle-3.4/configure.ac
-===================================================================
---- nettle-3.4.orig/configure.ac
-+++ nettle-3.4/configure.ac
-@@ -185,9 +185,11 @@ AC_HEADER_TIME
+Refactor for 3.10.
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+---
+ configure.ac | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4f27e663..673c1492 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -197,9 +197,11 @@ AC_TYPE_SIZE_T
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(size_t)
--AC_CHECK_HEADERS([openssl/evp.h openssl/ecdsa.h],,
+-AC_CHECK_HEADERS([openssl/evp.h openssl/ec.h openssl/rsa.h],,
-[enable_openssl=no
- break])
+if test "x$enable_openssl" = "xyes"; then
-+ AC_CHECK_HEADERS([openssl/evp.h openssl/ecdsa.h],,
++ AC_CHECK_HEADERS([openssl/evp.h openssl/ec.h openssl/rsa.h],,
+ [enable_openssl=no
+ break])
+fi
# For use by the testsuite
AC_CHECK_HEADERS([valgrind/memcheck.h])
+--
+2.39.2
+
diff --git a/meta/recipes-support/nettle/nettle/dlopen-test.patch b/meta/recipes-support/nettle/nettle/dlopen-test.patch
deleted file mode 100644
index ab9b91f88b..0000000000
--- a/meta/recipes-support/nettle/nettle/dlopen-test.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Remove the relative path for libnettle.so so the test
-program can find it.
-Relative paths are not suitable, as the folder strucure for ptest
-is different from the one expected by the nettle testsuite.
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
-Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
----
- testsuite/dlopen-test.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/testsuite/dlopen-test.c b/testsuite/dlopen-test.c
-index 4265bf7..1a25d17 100644
---- a/testsuite/dlopen-test.c
-+++ b/testsuite/dlopen-test.c
-@@ -15,7 +15,7 @@ int
- main (int argc UNUSED, char **argv UNUSED)
- {
- #if HAVE_LIBDL
-- void *handle = dlopen ("../libnettle." SO_EXT, RTLD_NOW);
-+ void *handle = dlopen ("libnettle.so", RTLD_NOW);
- int (*get_version)(void);
- if (!handle)
- {
---
-2.17.1
-
diff --git a/meta/recipes-support/nettle/nettle/run-ptest b/meta/recipes-support/nettle/nettle/run-ptest
index b90bed66d2..61a43c78f1 100644
--- a/meta/recipes-support/nettle/nettle/run-ptest
+++ b/meta/recipes-support/nettle/nettle/run-ptest
@@ -6,31 +6,35 @@ failed=0
all=0
for f in *-test; do
- if [ "$f" = "sha1-huge-test" ] ; then
- echo "SKIP: $f (skipped for ludicrous run time)"
- continue
- fi
-
- "./$f"
- case "$?" in
- 0)
- echo "PASS: $f"
- all=$((all + 1))
+ case "$f" in
+ "sha1-huge-test")
+ echo "SKIP: $f (long run time)"
;;
- 77)
- echo "SKIP: $f"
+ "symbols-test")
+ echo "SKIP: $f (needs static libraries)"
;;
*)
- echo "FAIL: $f"
- failed=$((failed + 1))
- all=$((all + 1))
+ "./$f"
+ case "$?" in
+ 0)
+ echo "PASS: $f"
+ all=$((all + 1))
+ ;;
+ 77)
+ echo "SKIP: $f"
+ ;;
+ *)
+ echo "FAIL: $f"
+ failed=$((failed + 1))
+ all=$((all + 1))
+ ;;
+ esac
;;
esac
done
if [ "$failed" -eq 0 ] ; then
- echo "All $all tests passed"
+ echo "All $all tests passed"
else
- echo "$failed of $all tests failed"
+ echo "$failed of $all tests failed"
fi
-