summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl/run-ptest
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl/run-ptest')
-rw-r--r--meta/recipes-support/curl/curl/run-ptest21
1 files changed, 17 insertions, 4 deletions
diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 614e822922..597cf92dbb 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,19 @@
#!/bin/sh
+
cd tests
-./runtests.pl -a -n -s | sed \
- -e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
- -e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
- -e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'
+
+# Run all tests, don't stop on first failure
+# Don't use valgrind if it is found
+# Use automake-style output
+# Run four tests in parallel
+# Print log output on failure
+
+# Don't run the flaky or timing dependent tests
+# Until https://github.com/curl/curl/issues/13350 is resolved, don't run FTP tests
+# We don't enable --libcurl
+# Don't assume curl-config exists
+# We don't have the source tree
+./runtests.pl \
+ -a -c curl -vc curl -n -am -j4 -p \
+ !flaky !timing-dependent !FTP \
+ !--libcurl !curl-config !source\ analysis !checksrc !documentation