summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/boost-build-native_4.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/boost/boost-build-native_4.4.1.bb')
-rw-r--r--meta/recipes-support/boost/boost-build-native_4.4.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/boost-build-native_4.4.1.bb b/meta/recipes-support/boost/boost-build-native_4.4.1.bb
new file mode 100644
index 0000000000..ad675ce731
--- /dev/null
+++ b/meta/recipes-support/boost/boost-build-native_4.4.1.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Boost.Build"
+DESCRIPTION = "B2 makes it easy to build C++ projects, everywhere."
+HOMEPAGE = "https://github.com/boostorg/build"
+SECTION = "devel"
+
+LICENSE = "BSL-1.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
+
+SRC_URI = "git://github.com/boostorg/build;protocol=https"
+SRCREV = "76da80f33187a3d9e5336157cdfae12ce82e37eb"
+
+UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(\d+(\.\d+){2,}))"
+
+inherit native
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ ./bootstrap.sh
+}
+
+do_install() {
+ ./b2 install --prefix=${prefix} staging-prefix=${D}${prefix}
+}
+
+# The build is either release mode (pre-stripped) or debug (-O0).
+INSANE_SKIP_${PN} = "already-stripped"