summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb')
-rw-r--r--meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb b/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb
index 0c5ed5e55e..2e463cd7b3 100644
--- a/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb
+++ b/meta/recipes-sato/pcmanfm/pcmanfm_1.3.2.bb
@@ -27,12 +27,14 @@ inherit autotools pkgconfig features_check mime-xdg
REQUIRED_DISTRO_FEATURES = "x11"
EXTRA_OECONF = "--with-gtk=3"
+# GCC 14 finds extra incompatible pointer type warnings which are treated as errors
+CFLAGS += "-Wno-error=incompatible-pointer-types"
do_install:append () {
install -d ${D}/${datadir}
install -d ${D}/${datadir}/pixmaps/
- install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
+ install -m 0644 ${UNPACKDIR}/*.png ${D}/${datadir}/pixmaps
}
FILES:${PN} += "${libdir}/pcmanfm"