summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb')
-rw-r--r--meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb40
1 files changed, 33 insertions, 7 deletions
diff --git a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
index f38e0d2800..b31eabad11 100644
--- a/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
+++ b/meta/recipes-sato/packagegroups/packagegroup-core-x11-sato.bb
@@ -12,25 +12,51 @@ inherit packagegroup
PACKAGE_ARCH = "${MACHINE_ARCH}"
+PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
+
+RDEPENDS_${PN} = "\
+ ${PN}-base \
+ ${PN}-apps \
+ ${PN}-games \
+ "
+
NETWORK_MANAGER ?= "connman-gnome"
NETWORK_MANAGER_libc-uclibc = ""
-WEB ?= ""
-#WEB = "web-webkit"
-
-RDEPENDS_packagegroup-core-x11-sato = "\
+RDEPENDS_${PN}-base = "\
matchbox-desktop \
matchbox-session-sato \
matchbox-keyboard \
+ matchbox-keyboard-applet \
+ matchbox-keyboard-im \
matchbox-stroke \
matchbox-config-gtk \
xcursor-transparent-theme \
sato-icon-theme \
settings-daemon \
gtk-sato-engine \
- gthumb \
- x11vnc \
libsdl \
+ ${NETWORK_MANAGER} \
+ "
+
+# pcmanfm doesn't work on mips
+FILEMANAGER ?= "pcmanfm"
+FILEMANAGER_mips ?= ""
+
+WEB ?= ""
+#WEB = "web-webkit"
+
+RDEPENDS_${PN}-apps = "\
+ gthumb \
+ leafpad \
gaku \
+ x11vnc \
+ matchbox-terminal \
+ sato-screenshot \
+ ${FILEMANAGER} \
${WEB} \
- ${NETWORK_MANAGER}"
+ "
+
+RDEPENDS_${PN}-games = "\
+ oh-puzzles \
+ "