summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/watchdog/watchdog-config.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/watchdog/watchdog-config.bb')
-rw-r--r--meta/recipes-extended/watchdog/watchdog-config.bb7
1 files changed, 5 insertions, 2 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog-config.bb b/meta/recipes-extended/watchdog/watchdog-config.bb
index f138952128..17151ced5e 100644
--- a/meta/recipes-extended/watchdog/watchdog-config.bb
+++ b/meta/recipes-extended/watchdog/watchdog-config.bb
@@ -13,12 +13,15 @@ SRC_URI = " \
file://watchdog.conf \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
# The default value is 60 seconds when null.
WATCHDOG_TIMEOUT ??= ""
do_install() {
- install -Dm 0644 ${WORKDIR}/watchdog.default ${D}${sysconfdir}/default/watchdog
- install -Dm 0644 ${WORKDIR}/watchdog.conf ${D}${sysconfdir}/watchdog.conf
+ install -Dm 0644 ${UNPACKDIR}/watchdog.default ${D}${sysconfdir}/default/watchdog
+ install -Dm 0644 ${UNPACKDIR}/watchdog.conf ${D}${sysconfdir}/watchdog.conf
if [ -n "${WATCHDOG_TIMEOUT}" ]; then
echo "watchdog-timeout = ${WATCHDOG_TIMEOUT}" >> ${D}/etc/watchdog.conf