summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust/rust_1.54.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rust/rust_1.54.0.bb')
-rw-r--r--meta/recipes-devtools/rust/rust_1.54.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.54.0.bb b/meta/recipes-devtools/rust/rust_1.54.0.bb
index ee60c3e6f1..e7d8d70c26 100644
--- a/meta/recipes-devtools/rust/rust_1.54.0.bb
+++ b/meta/recipes-devtools/rust/rust_1.54.0.bb
@@ -11,3 +11,10 @@ do_compile () {
rust_do_install() {
rust_runx install
}
+
+python () {
+ pn = d.getVar('PN')
+
+ if not pn.endswith("-native"):
+ raise bb.parse.SkipRecipe("Rust recipe doesn't work for target builds at this time. Fixes welcome.")
+}