summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake')
-rw-r--r--meta/recipes-devtools/automake/automake.inc4
-rw-r--r--meta/recipes-devtools/automake/automake/0001-automake-Add-default-libtool_tag-to-cppasm.patch12
-rw-r--r--meta/recipes-devtools/automake/automake/0002-automake-Update-for-python.m4-to-respect-libdir.patch91
-rw-r--r--meta/recipes-devtools/automake/automake/0003-build-fix-race-in-parallel-builds.patch (renamed from meta/recipes-devtools/automake/automake/0001-build-fix-race-in-parallel-builds.patch)12
-rw-r--r--meta/recipes-devtools/automake/automake/0004-Add-a-new-distro-feature-ptest.patch (renamed from meta/recipes-devtools/automake/automake/buildtest.patch)14
-rw-r--r--meta/recipes-devtools/automake/automake/0005-Set-relative-to-top_builddir-path-in-Makefile-to-acc.patch (renamed from meta/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch)18
-rw-r--r--meta/recipes-devtools/automake/automake/0006-automake-Remove-delays-in-configure-scripts-using-au.patch77
-rw-r--r--meta/recipes-devtools/automake/automake/automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch60
-rw-r--r--meta/recipes-devtools/automake/automake/performance.patch82
-rw-r--r--meta/recipes-devtools/automake/automake/python-libdir.patch88
-rw-r--r--meta/recipes-devtools/automake/automake_1.16.1.bb44
-rw-r--r--meta/recipes-devtools/automake/automake_1.17.bb37
12 files changed, 238 insertions, 301 deletions
diff --git a/meta/recipes-devtools/automake/automake.inc b/meta/recipes-devtools/automake/automake.inc
index 87cedc9838..9946c73c71 100644
--- a/meta/recipes-devtools/automake/automake.inc
+++ b/meta/recipes-devtools/automake/automake.inc
@@ -1,7 +1,7 @@
SUMMARY = "A GNU tool for automatically generating Makefiles"
DESCRIPTION = "Automake is a tool for automatically generating `Makefile.in' files compliant with the GNU Coding \
Standards. Automake requires the use of Autoconf."
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
HOMEPAGE = "http://www.gnu.org/software/automake/"
SECTION = "devel"
@@ -18,4 +18,4 @@ do_configure() {
export AUTOMAKE = "${@bb.utils.which('automake', d.getVar('PATH'))}"
-FILES_${PN} += "${datadir}/automake* ${datadir}/aclocal*"
+FILES:${PN} += "${datadir}/automake* ${datadir}/aclocal*"
diff --git a/meta/recipes-devtools/automake/automake/0001-automake-Add-default-libtool_tag-to-cppasm.patch b/meta/recipes-devtools/automake/automake/0001-automake-Add-default-libtool_tag-to-cppasm.patch
index deb1d03503..9608b5db44 100644
--- a/meta/recipes-devtools/automake/automake/0001-automake-Add-default-libtool_tag-to-cppasm.patch
+++ b/meta/recipes-devtools/automake/automake/0001-automake-Add-default-libtool_tag-to-cppasm.patch
@@ -1,23 +1,22 @@
-From b3c6e1971786cd93a2e3017c92bfbfe96baaf2f7 Mon Sep 17 00:00:00 2001
+From 2884ad2aa8b51cbba25a376935151a242f488e30 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 26 Jul 2017 11:19:56 -0700
-Subject: [PATCH] automake: Add default libtool_tag to cppasm.
+Subject: [PATCH 1/6] automake: Add default libtool_tag to cppasm.
* bin/automake.in (register_language): Define default libtool tag to be CC
since CPPASCOMPILE is using CC to call assembler
Upstream-Status: Submitted
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
---
bin/automake.in | 1 +
1 file changed, 1 insertion(+)
diff --git a/bin/automake.in b/bin/automake.in
-index 3a66965..08ba09a 100644
+index a17f452..18626de 100644
--- a/bin/automake.in
+++ b/bin/automake.in
-@@ -898,6 +898,7 @@ register_language ('name' => 'cppasm',
+@@ -897,6 +897,7 @@ register_language ('name' => 'cppasm',
'libtool_tag' => 'CC',
'compile_flag' => '-c',
'output_flag' => '-o',
@@ -25,3 +24,6 @@ index 3a66965..08ba09a 100644
'extensions' => ['.S', '.sx']);
# Fortran 77
+--
+2.39.2
+
diff --git a/meta/recipes-devtools/automake/automake/0002-automake-Update-for-python.m4-to-respect-libdir.patch b/meta/recipes-devtools/automake/automake/0002-automake-Update-for-python.m4-to-respect-libdir.patch
new file mode 100644
index 0000000000..308a7d075d
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake/0002-automake-Update-for-python.m4-to-respect-libdir.patch
@@ -0,0 +1,91 @@
+From 05194070775b597829abfa0d9a5f96d19cc064b8 Mon Sep 17 00:00:00 2001
+From: Kumar Gala <galak@kernel.crashing.org>
+Date: Thu, 11 Aug 2011 01:26:33 -0500
+Subject: [PATCH 2/6] automake: Update for python.m4 to respect libdir
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
+
+Updated for automake-1.12.6
+
+Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ m4/python.m4 | 32 ++++++--------------------------
+ 1 file changed, 6 insertions(+), 26 deletions(-)
+
+diff --git a/m4/python.m4 b/m4/python.m4
+index 0b1db26..07db0eb 100644
+--- a/m4/python.m4
++++ b/m4/python.m4
+@@ -99,6 +99,8 @@ AC_DEFUN([AM_PATH_PYTHON],
+ [am_cv_python_version=`$PYTHON -c "import sys; print ('%u.%u' % sys.version_info[[:2]])"`])
+ AC_SUBST([PYTHON_VERSION], [$am_cv_python_version])
+
++ AC_SUBST([PYTHON_LIB_PREFIX], ['${libdir}'])
++
+ dnl At times, e.g., when building shared libraries, you may want
+ dnl to know which OS platform Python thinks this is.
+ dnl
+@@ -268,18 +270,7 @@ except ImportError:
+ else
+ am_py_prefix=$am_cv_python_prefix
+ fi
+- am_cv_python_pythondir=`$PYTHON -c "
+-$am_python_setup_sysconfig
+-if can_use_sysconfig:
+- try:
+- $am_python_setup_scheme
+- sitedir = sysconfig.get_path('purelib', scheme, vars={'base':'$am_py_prefix'})
+- except:
+- sitedir = sysconfig.get_path('purelib', vars={'base':'$am_py_prefix'})
+-else:
+- from distutils import sysconfig
+- sitedir = sysconfig.get_python_lib(0, 0, prefix='$am_py_prefix')
+-sys.stdout.write(sitedir)"`
++ am_cv_python_pythondir=`echo "$PYTHON_LIB_PREFIX/python$PYTHON_VERSION/site-packages"`
+ #
+ case $am_cv_python_pythondir in
+ $am_py_prefix*)
+@@ -289,7 +280,7 @@ sys.stdout.write(sitedir)"`
+ *)
+ case $am_py_prefix in
+ /usr|/System*) ;;
+- *) am_cv_python_pythondir="\${PYTHON_PREFIX}/lib/python$PYTHON_VERSION/site-packages"
++ *) am_cv_python_pythondir=$PYTHON_LIB_PREFIX/python$PYTHON_VERSION/site-packages
+ ;;
+ esac
+ ;;
+@@ -315,18 +306,7 @@ sys.stdout.write(sitedir)"`
+ else
+ am_py_exec_prefix=$am_cv_python_exec_prefix
+ fi
+- am_cv_python_pyexecdir=`$PYTHON -c "
+-$am_python_setup_sysconfig
+-if can_use_sysconfig:
+- try:
+- $am_python_setup_scheme
+- sitedir = sysconfig.get_path('platlib', scheme, vars={'platbase':'$am_py_exec_prefix'})
+- except:
+- sitedir = sysconfig.get_path('platlib', vars={'platbase':'$am_py_exec_prefix'})
+-else:
+- from distutils import sysconfig
+- sitedir = sysconfig.get_python_lib(1, 0, prefix='$am_py_exec_prefix')
+-sys.stdout.write(sitedir)"`
++ am_cv_python_pyexecdir=`echo "$PYTHON_LIB_PREFIX/python$PYTHON_VERSION/site-packages"`
+ #
+ case $am_cv_python_pyexecdir in
+ $am_py_exec_prefix*)
+@@ -336,7 +316,7 @@ sys.stdout.write(sitedir)"`
+ *)
+ case $am_py_exec_prefix in
+ /usr|/System*) ;;
+- *) am_cv_python_pyexecdir="\${PYTHON_EXEC_PREFIX}/lib/python$PYTHON_VERSION/site-packages"
++ *) am_cv_python_pyexecdir=$PYTHON_LIB_PREFIX/python$PYTHON_VERSION/site-packages
+ ;;
+ esac
+ ;;
+--
+2.39.2
+
diff --git a/meta/recipes-devtools/automake/automake/0001-build-fix-race-in-parallel-builds.patch b/meta/recipes-devtools/automake/automake/0003-build-fix-race-in-parallel-builds.patch
index 591fce1bf1..a4039c3bba 100644
--- a/meta/recipes-devtools/automake/automake/0001-build-fix-race-in-parallel-builds.patch
+++ b/meta/recipes-devtools/automake/automake/0003-build-fix-race-in-parallel-builds.patch
@@ -1,7 +1,7 @@
-From 592eb55b248a765abfc796fccb68baa3d53745ac Mon Sep 17 00:00:00 2001
+From b952d7064c9cee23857fbc7cb9d761542b98d59a Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Thu, 26 Jul 2018 00:58:12 -0700
-Subject: [PATCH] build: fix race in parallel builds
+Subject: [PATCH 3/6] build: fix race in parallel builds
The automake-$(APIVERSION) is a hardlink of automake, if it is
created later than update_mans executing, there is a failure
@@ -31,10 +31,10 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile.in b/Makefile.in
-index c3e934c..7cddb8d 100644
+index a919544..c0f8c0d 100644
--- a/Makefile.in
+++ b/Makefile.in
-@@ -691,8 +691,8 @@ bin_SCRIPTS = bin/automake bin/aclocal
+@@ -723,8 +723,8 @@ bin_SCRIPTS = bin/automake bin/aclocal
# Used by maintainer checks and such.
automake_in = $(srcdir)/bin/automake.in
aclocal_in = $(srcdir)/bin/aclocal.in
@@ -46,7 +46,7 @@ index c3e934c..7cddb8d 100644
info_TEXINFOS = doc/automake.texi doc/automake-history.texi
doc_automake_TEXINFOS = doc/fdl.texi
diff --git a/bin/local.mk b/bin/local.mk
-index 97b38db..058ca99 100644
+index 4232448..8f043b0 100644
--- a/bin/local.mk
+++ b/bin/local.mk
@@ -31,8 +31,8 @@ CLEANFILES += \
@@ -61,5 +61,5 @@ index 97b38db..058ca99 100644
AUTOMAKESOURCES = $(automake_in) $(aclocal_in)
TAGS_FILES += $(AUTOMAKESOURCES)
--
-2.7.4
+2.39.2
diff --git a/meta/recipes-devtools/automake/automake/buildtest.patch b/meta/recipes-devtools/automake/automake/0004-Add-a-new-distro-feature-ptest.patch
index b88b9e8693..91c7f1c2cc 100644
--- a/meta/recipes-devtools/automake/automake/buildtest.patch
+++ b/meta/recipes-devtools/automake/automake/0004-Add-a-new-distro-feature-ptest.patch
@@ -1,7 +1,7 @@
-From a860b28069785aa5bf2fa9b671287de9af5004ff Mon Sep 17 00:00:00 2001
+From 839dca38cf24e70c7f0e20015d55aa8e543dd403 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bj=C3=B6rn=20Stenberg?= <bjst@enea.com>
Date: Wed, 19 Dec 2012 17:18:27 +0100
-Subject: [PATCH] Add a new distro feature "ptest".
+Subject: [PATCH 4/6] Add a new distro feature "ptest".
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
@@ -11,13 +11,12 @@ be run separately.
Signed-off-by: Björn Stenberg <bjst@enea.com>
Upstream-Status: Pending
-
---
lib/am/check.am | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)
diff --git a/lib/am/check.am b/lib/am/check.am
-index e0db651..de137fa 100644
+index e51a771..070e2da 100644
--- a/lib/am/check.am
+++ b/lib/am/check.am
@@ -41,7 +41,7 @@ am__tty_colors = { \
@@ -29,14 +28,14 @@ index e0db651..de137fa 100644
if !%?SERIAL_TESTS%
-@@ -466,7 +466,14 @@ else %?SERIAL_TESTS%
+@@ -520,7 +520,14 @@ else %?SERIAL_TESTS%
## Obsolescent serial testsuite driver.
-check-TESTS: $(TESTS)
+AM_RECURSIVE_TARGETS += buildtest runtest
+
-+buildtest-TESTS: $(TESTS)
++buildtest-TESTS: $(TESTS) $(check_PROGRAMS)
+
+check-TESTS: buildtest-TESTS
+ $(MAKE) $(AM_MAKEFLAGS) runtest-TESTS
@@ -45,3 +44,6 @@ index e0db651..de137fa 100644
@failed=0; all=0; xfail=0; xpass=0; skip=0; \
srcdir=$(srcdir); export srcdir; \
## Make sure Solaris VPATH-expands all members of this list, even
+--
+2.39.2
+
diff --git a/meta/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch b/meta/recipes-devtools/automake/automake/0005-Set-relative-to-top_builddir-path-in-Makefile-to-acc.patch
index 1f71722334..a5bad068a4 100644
--- a/meta/recipes-devtools/automake/automake/new_rt_path_for_test-driver.patch
+++ b/meta/recipes-devtools/automake/automake/0005-Set-relative-to-top_builddir-path-in-Makefile-to-acc.patch
@@ -1,22 +1,21 @@
-From f78dfa39139d528c94d72f27994f337f2fd3b6bd Mon Sep 17 00:00:00 2001
+From 4f576c10613b43cbbfcdf5a451d893faecd6fea9 Mon Sep 17 00:00:00 2001
From: Adrian Calianu <adrian.calianu@enea.com>
Date: Thu, 25 Feb 2016 16:08:04 +0100
-Subject: [PATCH] Set relative to top_builddir path in Makefile to access
+Subject: [PATCH 5/6] Set relative to top_builddir path in Makefile to access
test-driver
Signed-off-by: Adrian Calianu <adrian.calianu@enea.com>
-Upstream-Status: Pending
+Upstream-Status: Inappropriate [specific to oe-core target ptest installation]
Bug-Report: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=19042
-
---
bin/automake.in | 9 ++++++++-
1 file changed, 8 insertions(+), 1 deletion(-)
diff --git a/bin/automake.in b/bin/automake.in
-index a52a489..8377d20 100644
+index 18626de..3aa8706 100644
--- a/bin/automake.in
+++ b/bin/automake.in
-@@ -324,6 +324,9 @@ my $config_aux_dir_set_in_configure_ac = 0;
+@@ -325,6 +325,9 @@ my $config_aux_dir_set_in_configure_ac = 0;
# $AM_CONFIG_AUX_DIR is prefixed with $(top_srcdir), so it can be used
# in Makefiles.
my $am_config_aux_dir = '';
@@ -26,7 +25,7 @@ index a52a489..8377d20 100644
# Directory to search for AC_LIBSOURCE files, as set by AC_CONFIG_LIBOBJ_DIR
# in configure.ac.
-@@ -4854,7 +4857,7 @@ sub handle_per_suffix_test
+@@ -4917,7 +4920,7 @@ sub handle_per_suffix_test
{
require_conf_file ("parallel-tests", FOREIGN, 'test-driver');
define_variable ("${pfx}LOG_DRIVER",
@@ -35,7 +34,7 @@ index a52a489..8377d20 100644
INTERNAL);
}
my $driver = '$(' . $pfx . 'LOG_DRIVER)';
-@@ -7440,6 +7443,10 @@ sub locate_aux_dir ()
+@@ -7554,6 +7557,10 @@ sub locate_aux_dir ()
$am_config_aux_dir =
'$(top_srcdir)' . ($config_aux_dir eq '.' ? "" : "/$config_aux_dir");
$am_config_aux_dir =~ s,/*$,,;
@@ -46,3 +45,6 @@ index a52a489..8377d20 100644
}
+--
+2.39.2
+
diff --git a/meta/recipes-devtools/automake/automake/0006-automake-Remove-delays-in-configure-scripts-using-au.patch b/meta/recipes-devtools/automake/automake/0006-automake-Remove-delays-in-configure-scripts-using-au.patch
new file mode 100644
index 0000000000..e5e39169b6
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake/0006-automake-Remove-delays-in-configure-scripts-using-au.patch
@@ -0,0 +1,77 @@
+From b43c0ccd1d98a43c0ddcade40fa288e98d381420 Mon Sep 17 00:00:00 2001
+From: Richard Purdie <richard.purdie@linuxfoundation.org>
+Date: Mon, 7 Dec 2015 18:28:05 +0000
+Subject: [PATCH 6/6] automake: Remove delays in configure scripts using
+ automake
+
+By default automake puts "sleep 1" into the start of configure scripts
+which adds pointless delays to them. Rather than do this, lets just assume
+our systems are sane.
+
+RP
+2015/12/7
+Upstream-Status: Inappropriate
+---
+ m4/sanity.m4 | 48 +-----------------------------------------------
+ 1 file changed, 1 insertion(+), 47 deletions(-)
+
+diff --git a/m4/sanity.m4 b/m4/sanity.m4
+index c7f32da..f25625a 100644
+--- a/m4/sanity.m4
++++ b/m4/sanity.m4
+@@ -176,51 +176,5 @@ case $srcdir in
+ AC_MSG_ERROR([unsafe srcdir value: '$srcdir']);;
+ esac
+
+-# Do 'set' in a subshell so we don't clobber the current shell's
+-# arguments. Must try -L first in case configure is actually a
+-# symlink; some systems play weird games with the mod time of symlinks
+-# (eg FreeBSD returns the mod time of the symlink's containing
+-# directory).
+-am_build_env_is_sane=no
+-am_has_slept=no
+-rm -f conftest.file
+-for am_try in 1 2; do
+- echo "timestamp, slept: $am_has_slept" > conftest.file
+- if (
+- set X `ls -Lt "$srcdir/configure" conftest.file 2> /dev/null`
+- if test "$[]*" = "X"; then
+- # -L didn't work.
+- set X `ls -t "$srcdir/configure" conftest.file`
+- fi
+- test "$[]2" = conftest.file
+- ); then
+- am_build_env_is_sane=yes
+- break
+- fi
+- # Just in case.
+- sleep "$am_cv_filesystem_timestamp_resolution"
+- am_has_slept=yes
+-done
+-
+-AC_MSG_RESULT([$am_build_env_is_sane])
+-if test "$am_build_env_is_sane" = no; then
+- AC_MSG_ERROR([newly created file is older than distributed files!
+-Check your system clock])
+-fi
+-
+-# If we didn't sleep, we still need to ensure time stamps of config.status and
+-# generated files are strictly newer.
+-am_sleep_pid=
+-AS_IF([test -e conftest.file || grep 'slept: no' conftest.file >/dev/null 2>&1],, [dnl
+- ( sleep "$am_cv_filesystem_timestamp_resolution" ) &
+- am_sleep_pid=$!
+-])
+-AC_CONFIG_COMMANDS_PRE(
+- [AC_MSG_CHECKING([that generated files are newer than configure])
+- if test -n "$am_sleep_pid"; then
+- # Hide warnings about reused PIDs.
+- wait $am_sleep_pid 2>/dev/null
+- fi
+- AC_MSG_RESULT([done])])
+-rm -f conftest.file
++AC_MSG_RESULT([yes])
+ ])
+--
+2.39.2
+
diff --git a/meta/recipes-devtools/automake/automake/automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch b/meta/recipes-devtools/automake/automake/automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch
deleted file mode 100644
index 1592c02cb9..0000000000
--- a/meta/recipes-devtools/automake/automake/automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-From 081385f4d4bba367afad3bff1fa034f5263305e6 Mon Sep 17 00:00:00 2001
-From: Serhii Popovych <spopovyc@cisco.com>
-Date: Wed, 10 Feb 2016 17:07:32 +0000
-Subject: [PATCH] perl: Replace -w option in shebangs with modern "use
- warnings" In some builds we might provide ac_cv_path_PERL as /usr/bin/env
- perl to use newer version of the perl from users PATH rather than older from
- standard system path.
-
-However using /usr/bin/env perl -w from shebang line isn't
-possible because it translates to something like
-/usr/bin/env -w perl and env complains about illegal option.
-
-To address this we can remove -w option from perl shebang
-line and add "use warnings" statement.
-
-Upstream-Status: Pending
-Signed-off-by: Serhii Popovych <spopovyc@cisco.com>
-Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
-
----
- bin/aclocal.in | 3 ++-
- bin/automake.in | 3 ++-
- 2 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/bin/aclocal.in b/bin/aclocal.in
-index b3715d9..461d453 100644
---- a/bin/aclocal.in
-+++ b/bin/aclocal.in
-@@ -1,4 +1,4 @@
--#!@PERL@ -w
-+#!@PERL@
- # -*- perl -*-
- # @configure_input@
-
-@@ -32,6 +32,7 @@ BEGIN
- }
-
- use strict;
-+use warnings;
-
- use Automake::Config;
- use Automake::General;
-diff --git a/bin/automake.in b/bin/automake.in
-index 8377d20..3a66965 100644
---- a/bin/automake.in
-+++ b/bin/automake.in
-@@ -1,4 +1,4 @@
--#!@PERL@ -w
-+#!@PERL@
- # -*- perl -*-
- # @configure_input@
-
-@@ -28,6 +28,7 @@ eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
- package Automake;
-
- use strict;
-+use warnings;
-
- BEGIN
- {
diff --git a/meta/recipes-devtools/automake/automake/performance.patch b/meta/recipes-devtools/automake/automake/performance.patch
deleted file mode 100644
index a8ba6592fa..0000000000
--- a/meta/recipes-devtools/automake/automake/performance.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From cd47c328cb53546891bb3dc7c9b2c54ed01cc6d1 Mon Sep 17 00:00:00 2001
-From: Richard Purdie <richard.purdie@linuxfoundation.org>
-Date: Mon, 7 Dec 2015 18:28:05 +0000
-Subject: [PATCH] automake: Remove delays in configure scripts using automake
-
-By default automake puts "sleep 1" into the start of configure scripts
-which adds pointless delays to them. Rather than do this, lets just assume
-our systems are sane.
-
-RP
-2015/12/7
-Upstream-Status: Inappropriate
-
----
- m4/sanity.m4 | 55 -------------------------------------------------------
- 1 file changed, 55 deletions(-)
-
-diff --git a/m4/sanity.m4 b/m4/sanity.m4
-index eaac218..bfdfe88 100644
---- a/m4/sanity.m4
-+++ b/m4/sanity.m4
-@@ -23,60 +23,5 @@ case $srcdir in
- AC_MSG_ERROR([unsafe srcdir value: '$srcdir']);;
- esac
-
--# Do 'set' in a subshell so we don't clobber the current shell's
--# arguments. Must try -L first in case configure is actually a
--# symlink; some systems play weird games with the mod time of symlinks
--# (eg FreeBSD returns the mod time of the symlink's containing
--# directory).
--if (
-- am_has_slept=no
-- for am_try in 1 2; do
-- echo "timestamp, slept: $am_has_slept" > conftest.file
-- set X `ls -Lt "$srcdir/configure" conftest.file 2> /dev/null`
-- if test "$[*]" = "X"; then
-- # -L didn't work.
-- set X `ls -t "$srcdir/configure" conftest.file`
-- fi
-- if test "$[*]" != "X $srcdir/configure conftest.file" \
-- && test "$[*]" != "X conftest.file $srcdir/configure"; then
--
-- # If neither matched, then we have a broken ls. This can happen
-- # if, for instance, CONFIG_SHELL is bash and it inherits a
-- # broken ls alias from the environment. This has actually
-- # happened. Such a system could not be considered "sane".
-- AC_MSG_ERROR([ls -t appears to fail. Make sure there is not a broken
-- alias in your environment])
-- fi
-- if test "$[2]" = conftest.file || test $am_try -eq 2; then
-- break
-- fi
-- # Just in case.
-- sleep 1
-- am_has_slept=yes
-- done
-- test "$[2]" = conftest.file
-- )
--then
-- # Ok.
-- :
--else
-- AC_MSG_ERROR([newly created file is older than distributed files!
--Check your system clock])
--fi
- AC_MSG_RESULT([yes])
--# If we didn't sleep, we still need to ensure time stamps of config.status and
--# generated files are strictly newer.
--am_sleep_pid=
--if grep 'slept: no' conftest.file >/dev/null 2>&1; then
-- ( sleep 1 ) &
-- am_sleep_pid=$!
--fi
--AC_CONFIG_COMMANDS_PRE(
-- [AC_MSG_CHECKING([that generated files are newer than configure])
-- if test -n "$am_sleep_pid"; then
-- # Hide warnings about reused PIDs.
-- wait $am_sleep_pid 2>/dev/null
-- fi
-- AC_MSG_RESULT([done])])
--rm -f conftest.file
- ])
diff --git a/meta/recipes-devtools/automake/automake/python-libdir.patch b/meta/recipes-devtools/automake/automake/python-libdir.patch
deleted file mode 100644
index ee1f725f76..0000000000
--- a/meta/recipes-devtools/automake/automake/python-libdir.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From a80dacd5124d0713cf2c986b28d736e78dc6b0ca Mon Sep 17 00:00:00 2001
-From: Kumar Gala <galak@kernel.crashing.org>
-Date: Thu, 11 Aug 2011 01:26:33 -0500
-Subject: [PATCH] automake: Update for python.m4 to respect libdir
-
-Upstream-Status: Inappropriate [embedded specific]
-
-Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
-
-Updated for automake-1.12.6
-
-Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
-
----
- m4/python.m4 | 27 +++++++--------------------
- 1 file changed, 7 insertions(+), 20 deletions(-)
-
-diff --git a/m4/python.m4 b/m4/python.m4
-index 63c0a0e..7bbd2d2 100644
---- a/m4/python.m4
-+++ b/m4/python.m4
-@@ -94,12 +94,13 @@ AC_DEFUN([AM_PATH_PYTHON],
- [am_cv_python_version=`$PYTHON -c "import sys; sys.stdout.write(sys.version[[:3]])"`])
- AC_SUBST([PYTHON_VERSION], [$am_cv_python_version])
-
-- dnl Use the values of $prefix and $exec_prefix for the corresponding
-- dnl values of PYTHON_PREFIX and PYTHON_EXEC_PREFIX. These are made
-+ dnl Use the values of $prefix, $libdir and $exec_prefix for the corresponding
-+ dnl values of PYTHON_PREFIX PYTHON_LIB_PREFIX, and PYTHON_EXEC_PREFIX. These are made
- dnl distinct variables so they can be overridden if need be. However,
- dnl general consensus is that you shouldn't need this ability.
-
- AC_SUBST([PYTHON_PREFIX], ['${prefix}'])
-+ AC_SUBST([PYTHON_LIB_PREFIX], ['${libdir}'])
- AC_SUBST([PYTHON_EXEC_PREFIX], ['${exec_prefix}'])
-
- dnl At times (like when building shared libraries) you may want
-@@ -144,14 +145,7 @@ except ImportError:
- else
- am_py_prefix=$prefix
- fi
-- am_cv_python_pythondir=`$PYTHON -c "
--$am_python_setup_sysconfig
--if can_use_sysconfig:
-- sitedir = sysconfig.get_path('purelib', vars={'base':'$am_py_prefix'})
--else:
-- from distutils import sysconfig
-- sitedir = sysconfig.get_python_lib(0, 0, prefix='$am_py_prefix')
--sys.stdout.write(sitedir)"`
-+ am_cv_python_pythondir=`echo "$PYTHON_LIB_PREFIX/python$PYTHON_VERSION/site-packages"`
- case $am_cv_python_pythondir in
- $am_py_prefix*)
- am__strip_prefix=`echo "$am_py_prefix" | sed 's|.|.|g'`
-@@ -161,7 +155,7 @@ sys.stdout.write(sitedir)"`
- case $am_py_prefix in
- /usr|/System*) ;;
- *)
-- am_cv_python_pythondir=$PYTHON_PREFIX/lib/python$PYTHON_VERSION/site-packages
-+ am_cv_python_pythondir=$PYTHON_LIB_PREFIX/python$PYTHON_VERSION/site-packages
- ;;
- esac
- ;;
-@@ -186,14 +180,7 @@ sys.stdout.write(sitedir)"`
- else
- am_py_exec_prefix=$exec_prefix
- fi
-- am_cv_python_pyexecdir=`$PYTHON -c "
--$am_python_setup_sysconfig
--if can_use_sysconfig:
-- sitedir = sysconfig.get_path('platlib', vars={'platbase':'$am_py_prefix'})
--else:
-- from distutils import sysconfig
-- sitedir = sysconfig.get_python_lib(1, 0, prefix='$am_py_prefix')
--sys.stdout.write(sitedir)"`
-+ am_cv_python_pyexecdir=`echo "$PYTHON_LIB_PREFIX/python$PYTHON_VERSION/site-packages"`
- case $am_cv_python_pyexecdir in
- $am_py_exec_prefix*)
- am__strip_prefix=`echo "$am_py_exec_prefix" | sed 's|.|.|g'`
-@@ -203,7 +190,7 @@ sys.stdout.write(sitedir)"`
- case $am_py_exec_prefix in
- /usr|/System*) ;;
- *)
-- am_cv_python_pyexecdir=$PYTHON_EXEC_PREFIX/lib/python$PYTHON_VERSION/site-packages
-+ am_cv_python_pyexecdir=$PYTHON_LIB_PREFIX/python$PYTHON_VERSION/site-packages
- ;;
- esac
- ;;
diff --git a/meta/recipes-devtools/automake/automake_1.16.1.bb b/meta/recipes-devtools/automake/automake_1.16.1.bb
deleted file mode 100644
index d82eed3c60..0000000000
--- a/meta/recipes-devtools/automake/automake_1.16.1.bb
+++ /dev/null
@@ -1,44 +0,0 @@
-require automake.inc
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-DEPENDS_class-native = "autoconf-native"
-
-NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
-
-RDEPENDS_${PN} += "\
- autoconf \
- perl \
- perl-module-bytes \
- perl-module-data-dumper \
- perl-module-strict \
- perl-module-text-parsewords \
- perl-module-thread-queue \
- perl-module-threads \
- perl-module-vars "
-
-RDEPENDS_${PN}_class-native = "autoconf-native hostperl-runtime-native"
-RDEPENDS_${PN}_class-nativesdk = "nativesdk-autoconf"
-
-SRC_URI += "file://python-libdir.patch \
- file://buildtest.patch \
- file://performance.patch \
- file://new_rt_path_for_test-driver.patch \
- file://automake-replace-w-option-in-shebangs-with-modern-use-warnings.patch \
- file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \
- file://0001-build-fix-race-in-parallel-builds.patch \
- "
-
-SRC_URI[md5sum] = "83cc2463a4080efd46a72ba2c9f6b8f5"
-SRC_URI[sha256sum] = "608a97523f97db32f1f5d5615c98ca69326ced2054c9f82e65bade7fc4c9dea8"
-
-PERL = "${USRBINPATH}/perl"
-PERL_class-native = "${USRBINPATH}/env perl"
-PERL_class-nativesdk = "${USRBINPATH}/env perl"
-
-CACHED_CONFIGUREVARS += "ac_cv_path_PERL='${PERL}'"
-
-do_install_append () {
- install -d ${D}${datadir}
-}
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-devtools/automake/automake_1.17.bb b/meta/recipes-devtools/automake/automake_1.17.bb
new file mode 100644
index 0000000000..27d8dfe182
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.17.bb
@@ -0,0 +1,37 @@
+require automake.inc
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+DEPENDS:class-native = "autoconf-native"
+
+NAMEVER = "${@oe.utils.trim_version("${PV}", 2)}"
+
+RDEPENDS:${PN} += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-data-dumper \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-thread-queue \
+ perl-module-threads \
+ perl-module-vars "
+
+RDEPENDS:${PN}:class-native = "autoconf-native hostperl-runtime-native"
+
+SRC_URI += "\
+ file://0001-automake-Add-default-libtool_tag-to-cppasm.patch \
+ file://0002-automake-Update-for-python.m4-to-respect-libdir.patch \
+ file://0003-build-fix-race-in-parallel-builds.patch \
+ file://0004-Add-a-new-distro-feature-ptest.patch \
+ file://0005-Set-relative-to-top_builddir-path-in-Makefile-to-acc.patch \
+ file://0006-automake-Remove-delays-in-configure-scripts-using-au.patch \
+ "
+
+SRC_URI[sha256sum] = "397767d4db3018dd4440825b60c64258b636eaf6bf99ac8b0897f06c89310acd"
+
+do_install:append () {
+ install -d ${D}${datadir}
+ sed -i -e 's@^#!.*perl$@#!/usr/bin/env perl@' ${D}/${bindir}/*
+}
+
+BBCLASSEXTEND = "native nativesdk"