summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-12-16 21:41:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-12-17 19:04:40 +0000
commit69b679380616a94a631681caa05d9bf7610f9372 (patch)
tree1d9beaf29a5a8041d04bf1db070fc2710801eec2 /scripts
parent1c2f9d8f18ef8154573142638ca10a8f88e43419 (diff)
downloadopenembedded-core-69b679380616a94a631681caa05d9bf7610f9372.tar.gz
recipetool: add python_maturin support
Add the new python_maturin PEP-517 backend Add selftest for 'pydantic-core' pypi package. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/recipetool/create_buildsys_python.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/scripts/lib/recipetool/create_buildsys_python.py b/scripts/lib/recipetool/create_buildsys_python.py
index a2af41fdda..60c5903450 100644
--- a/scripts/lib/recipetool/create_buildsys_python.py
+++ b/scripts/lib/recipetool/create_buildsys_python.py
@@ -735,6 +735,7 @@ class PythonPyprojectTomlRecipeHandler(PythonRecipeHandler):
"poetry.core.masonry.api": "python_poetry_core",
"flit_core.buildapi": "python_flit_core",
"hatchling.build": "python_hatchling",
+ "maturin": "python_maturin",
}
# setuptools.build_meta and flit declare project metadata into the "project" section of pyproject.toml