summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-09-07 22:32:41 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-11 16:04:11 +0100
commite9e22c74d0544271f3e43c67fbf95f2e68400da0 (patch)
treea1eb7f018b1b74f9011c5475c9de26af8cdf2723 /meta
parent03d37854b1dacbecd2c522821c59ef01d9bd305c (diff)
downloadopenembedded-core-e9e22c74d0544271f3e43c67fbf95f2e68400da0.tar.gz
perl: Add packageconfig for setlocale functionality differences
setlocale behavior with 'missing' locales is different when using musl [1] which confuses perl locale tests and perl thinks it has locale on system while there are none. Therefore pass correct property on musl regarding setlocale behaviour [1] https://musl.openwall.narkive.com/kO1vpTWJ/setlocale-behavior-with-missing-locales Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl_5.38.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.38.0.bb b/meta/recipes-devtools/perl/perl_5.38.0.bb
index 2103a39dfa..a8623b6e84 100644
--- a/meta/recipes-devtools/perl/perl_5.38.0.bb
+++ b/meta/recipes-devtools/perl/perl_5.38.0.bb
@@ -38,8 +38,10 @@ DEPENDS += "make-native"
PERL_LIB_VER = "${@'.'.join(d.getVar('PV').split('.')[0:2])}.0"
PACKAGECONFIG ??= "gdbm"
+PACKAGECONFIG:append:libc-musl = " anylocale"
PACKAGECONFIG[bdb] = ",-Ui_db,db"
PACKAGECONFIG[gdbm] = ",-Ui_gdbm,gdbm"
+PACKAGECONFIG[anylocale] = "-Dd_setlocale_accepts_any_locale_name=define,,"
# Don't generate comments in enc2xs output files. They are not reproducible
export ENC2XS_NO_COMMENTS = "1"