summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSundeep KOKKONDA <sundeep.kokkonda@gmail.com>2023-03-08 22:59:09 +0530
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-11 00:08:38 +0000
commitbb781f452299cfa6ec7fffd215b0af3149178f32 (patch)
tree00f5bd1796d6c35bd6b469de5265f93bedef269a /meta
parent0ded85c2e4d0888e459bc98d1c8e55429f542dba (diff)
downloadopenembedded-core-bb781f452299cfa6ec7fffd215b0af3149178f32.tar.gz
rust: added missing runtime dependencies to run rust on target
[YOCTO #14975] rust files are not linking on target due to missing dependencies and observed below error. error: linker `x86_64-poky-linux-gcc` not found Added the required dependencies to run rust on target machine. Signed-off-by: Sundeep KOKKONDA <sundeep.kokkonda@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/rust/rust_1.67.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.67.1.bb b/meta/recipes-devtools/rust/rust_1.67.1.bb
index 2118faec8f..f4c6d9511d 100644
--- a/meta/recipes-devtools/rust/rust_1.67.1.bb
+++ b/meta/recipes-devtools/rust/rust_1.67.1.bb
@@ -13,6 +13,8 @@ DEPENDS:append:class-nativesdk = " nativesdk-rust-llvm"
DEPENDS += "rust-llvm (=${PV})"
+RDEPENDS:${PN}:append:class-target = " gcc g++ binutils"
+
# Otherwise we'll depend on what we provide
INHIBIT_DEFAULT_RUST_DEPS:class-native = "1"
# We don't need to depend on gcc-native because yocto assumes it exists