summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorDongxiao Xu <dongxiao.xu@intel.com>2010-10-11 15:48:03 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-11 12:22:39 +0100
commit771fb55d6b13a92e1b30fbc95fdb1c34ddec7ebe (patch)
treebb56ac6af6569bf2d220c882bc6f460b81c205e6 /meta
parentded2919f1929e31f0ebebbde6d273d3aaeed8325 (diff)
downloadopenembedded-core-771fb55d6b13a92e1b30fbc95fdb1c34ddec7ebe.tar.gz
connman: Do not take over ethernet interface if target is boot by nfs
Detect if target system is booting by nfs, connman will not take over the ethernet interface. This fixes [BUGID #364] Signed-off-by: Dongxiao Xu <dongxiao.xu@intel.com>
Diffstat (limited to 'meta')
-rwxr-xr-xmeta/recipes-connectivity/connman/connman-0.56/connman22
-rw-r--r--meta/recipes-connectivity/connman/connman_0.56.bb2
2 files changed, 22 insertions, 2 deletions
diff --git a/meta/recipes-connectivity/connman/connman-0.56/connman b/meta/recipes-connectivity/connman/connman-0.56/connman
index f8154f68f9..f01bf371c2 100755
--- a/meta/recipes-connectivity/connman/connman-0.56/connman
+++ b/meta/recipes-connectivity/connman/connman-0.56/connman
@@ -10,8 +10,28 @@ fi
set -e
+nfsroot=0
+
+exec 9<&0 < /proc/mounts
+while read dev mtpt fstype rest; do
+ if test $mtpt = "/" ; then
+ case $fstype in
+ nfs | nfs4)
+ nfsroot=1
+ break
+ ;;
+ *)
+ ;;
+ esac
+ fi
+done
+
do_start() {
- $DAEMON
+ EXTRA_PARAM=""
+ if test $nfsroot -eq 1 ; then
+ EXTRA_PARAM="-P ethernet"
+ fi
+ $DAEMON $EXTRA_PARAM
}
do_stop() {
diff --git a/meta/recipes-connectivity/connman/connman_0.56.bb b/meta/recipes-connectivity/connman/connman_0.56.bb
index 69dad66d58..665da32f03 100644
--- a/meta/recipes-connectivity/connman/connman_0.56.bb
+++ b/meta/recipes-connectivity/connman/connman_0.56.bb
@@ -1,5 +1,5 @@
require connman.inc
-PR = "r1"
+PR = "r2"
EXTRA_OECONF += "\
ac_cv_path_WPASUPPLICANT=/usr/sbin/wpa_supplicant \