summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openedhand.com>2007-11-13 13:13:37 +0000
committerMarcin Juszkiewicz <hrw@openedhand.com>2007-11-13 13:13:37 +0000
commit5e1159bcf2e9273226d7b5b1113c551e35edc0d3 (patch)
treeb5a5d2079c198cf2c189df9ee2e3ab44bf0f4e58 /meta
parent8075bb569d908755dfa2fa9739387c34b5c51ef1 (diff)
downloadopenembedded-core-5e1159bcf2e9273226d7b5b1113c551e35edc0d3.tar.gz
libtool: do not add when linking libraries
git-svn-id: https://svn.o-hand.com/repos/poky/trunk@3136 311d38ba-8fff-0310-9ca6-ca027cbcb966
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/libtool/libtool-1.5.10/nousrlib.patch33
-rw-r--r--meta/packages/libtool/libtool-cross_1.5.10.bb6
-rw-r--r--meta/packages/libtool/libtool-native_1.5.10.bb6
3 files changed, 41 insertions, 4 deletions
diff --git a/meta/packages/libtool/libtool-1.5.10/nousrlib.patch b/meta/packages/libtool/libtool-1.5.10/nousrlib.patch
new file mode 100644
index 0000000000..1486337be5
--- /dev/null
+++ b/meta/packages/libtool/libtool-1.5.10/nousrlib.patch
@@ -0,0 +1,33 @@
+--- libtool-1.5.10.orig/ltmain.in
++++ libtool-1.5.10/ltmain.in
+@@ -2637,8 +2637,6 @@
+ add="$libdir/$linklib"
+ fi
+ else
+- # We cannot seem to hardcode it, guess we'll fake it.
+- add_dir="-L$libdir"
+ # Try looking first in the location we're being installed to.
+ if test -n "$inst_prefix_dir"; then
+ case "$libdir" in
+--- libtool-1.5.10.orig/libltdl/ltmain.sh
++++ libtool-1.5.10/libltdl/ltmain.sh
+@@ -2630,8 +2630,6 @@
+ add="$libdir/$linklib"
+ fi
+ else
+- # We cannot seem to hardcode it, guess we'll fake it.
+- add_dir="-L$libdir"
+ # Try looking first in the location we're being installed to.
+ if test -n "$inst_prefix_dir"; then
+ case "$libdir" in
+--- libtool-1.5.10.orig/ltmain.sh
++++ libtool-1.5.10/ltmain.sh
+@@ -2630,8 +2630,6 @@
+ add="$libdir/$linklib"
+ fi
+ else
+- # We cannot seem to hardcode it, guess we'll fake it.
+- add_dir="-L$libdir"
+ # Try looking first in the location we're being installed to.
+ if test -n "$inst_prefix_dir"; then
+ case "$libdir" in
diff --git a/meta/packages/libtool/libtool-cross_1.5.10.bb b/meta/packages/libtool/libtool-cross_1.5.10.bb
index 4c1b7c2e1f..0d597b6035 100644
--- a/meta/packages/libtool/libtool-cross_1.5.10.bb
+++ b/meta/packages/libtool/libtool-cross_1.5.10.bb
@@ -1,14 +1,16 @@
SECTION = "devel"
require libtool_${PV}.bb
-PR = "r6"
+PR = "r7"
PACKAGES = ""
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
SRC_URI_append = " file://libdir-la.patch;patch=1 \
file://prefix.patch;patch=1 \
file://tag.patch;patch=1 \
file://tag1.patch;patch=1 \
- file://install-path-check.patch;patch=1"
+ file://install-path-check.patch;patch=1 \
+ file://nousrlib.patch;patch=1"
+
S = "${WORKDIR}/libtool-${PV}"
prefix = "${STAGING_DIR_NATIVE}${layout_prefix}"
diff --git a/meta/packages/libtool/libtool-native_1.5.10.bb b/meta/packages/libtool/libtool-native_1.5.10.bb
index 6d8b1a1d7c..0c10fd695e 100644
--- a/meta/packages/libtool/libtool-native_1.5.10.bb
+++ b/meta/packages/libtool/libtool-native_1.5.10.bb
@@ -1,13 +1,15 @@
SECTION = "devel"
require libtool_${PV}.bb
-PR = "r5"
+PR = "r6"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libtool-${PV}"
SRC_URI_append = " file://libdir-la.patch;patch=1 \
file://prefix.patch;patch=1 \
file://tag.patch;patch=1 \
file://tag1.patch;patch=1 \
- file://install-path-check.patch;patch=1"
+ file://install-path-check.patch;patch=1 \
+ file://nousrlib.patch;patch=1"
+
S = "${WORKDIR}/libtool-${PV}"
inherit native