summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTomasz Dziendzielski <tomasz.dziendzielski@gmail.com>2021-01-24 10:55:46 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-27 10:16:13 +0000
commit217a8974765693192cbead51ebd9845a383ef7cc (patch)
tree56086643eecb217ec3534abab60e5503aa20f4ba /meta
parent044c90d152bfd1b2a23272df39327ba4cd862dff (diff)
downloadopenembedded-core-217a8974765693192cbead51ebd9845a383ef7cc.tar.gz
meta: Fix native inheritance order in recipes
Classes native/nativesdk should be inherited last to prevent unexpected behaviour. See [YOCTO #5729] for details. Signed-off-by: Tomasz Dziendzielski <tomasz.dziendzielski@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.32.bb2
-rw-r--r--meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb2
-rw-r--r--meta/recipes-devtools/qemu/qemu-native.inc4
3 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.32.bb b/meta/recipes-core/glibc/cross-localedef-native_2.32.bb
index 5a0abbb70f..ec59c6ba10 100644
--- a/meta/recipes-core/glibc/cross-localedef-native_2.32.bb
+++ b/meta/recipes-core/glibc/cross-localedef-native_2.32.bb
@@ -14,8 +14,8 @@ require glibc-version.inc
#
AUTOTOOLS_SCRIPT_PATH = "${S}/localedef"
-inherit native
inherit autotools
+inherit native
FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
diff --git a/meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb b/meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb
index 7fdc4c86d9..8778cab124 100644
--- a/meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb
+++ b/meta/recipes-devtools/meson/nativesdk-meson_0.56.2.bb
@@ -1,7 +1,7 @@
include meson.inc
-inherit nativesdk
inherit siteinfo
+inherit nativesdk
SRC_URI += "file://meson-setup.py \
file://meson-wrapper"
diff --git a/meta/recipes-devtools/qemu/qemu-native.inc b/meta/recipes-devtools/qemu/qemu-native.inc
index aa5c9b9a72..54e49d8bc6 100644
--- a/meta/recipes-devtools/qemu/qemu-native.inc
+++ b/meta/recipes-devtools/qemu/qemu-native.inc
@@ -1,7 +1,7 @@
-inherit native
-
require qemu.inc
+inherit native
+
EXTRA_OEMAKE_append = " LD='${LD}' AR='${AR}' OBJCOPY='${OBJCOPY}' LDFLAGS='${LDFLAGS}'"
LDFLAGS_append = " -fuse-ld=bfd"