summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-11-03 07:54:10 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-07 14:32:39 +0000
commit15ca091ae01ae298c013e8cf82ee6af382259ed8 (patch)
tree597ae9e8a8cd334c42a649188148a79a152f4a83 /meta
parent7da5dd3b43718b876645602b1a23c739cbe8016d (diff)
downloadopenembedded-core-15ca091ae01ae298c013e8cf82ee6af382259ed8.tar.gz
python3-typing-extensions: upgrade 4.3.0 -> 4.4.0
* Add SUMMARY, DESCRIPTION, BUGTRACKER and SECTION * Update HOMEPAGE to agree with PyPi https://github.com/python/typing_extensions/blob/main/CHANGELOG.md#release-440-october-6-2022 Release 4.4.0 (October 6, 2022) * Add typing_extensions.Any a backport of python 3.11's Any class which is subclassable at runtime. (backport from python/cpython#31841, by Shantanu and Jelle Zijlstra). Patch by James Hilton-Balfe (@Gobot1234). * Add initial support for TypeVarLike default parameter, PEP 696. Patch by Marc Mueller (@cdce8p). * Runtime support for PEP 698, adding typing_extensions.override. Patch by Jelle Zijlstra. * Add the infer_variance parameter to TypeVar, as specified in PEP 695. Patch by Jelle Zijlstra. License-Update: update copyright years; align with CPython LICENSE See https://github.com/python/typing_extensions/pull/63 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-typing-extensions_4.3.0.bb14
-rw-r--r--meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb24
2 files changed, 24 insertions, 14 deletions
diff --git a/meta/recipes-devtools/python/python3-typing-extensions_4.3.0.bb b/meta/recipes-devtools/python/python3-typing-extensions_4.3.0.bb
deleted file mode 100644
index 9638491eb4..0000000000
--- a/meta/recipes-devtools/python/python3-typing-extensions_4.3.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-HOMEPAGE = "https://github.com/python/typing"
-LICENSE = "PSF-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=64fc2b30b67d0a8423c250e0386ed72f"
-
-# The name on PyPi is slightly different.
-PYPI_PACKAGE = "typing_extensions"
-
-SRC_URI[sha256sum] = "e6d2677a32f47fc7eb2795db1dd15c1f34eff616bcaf2cfb5e997f854fa1c4a6"
-
-inherit pypi python_flit_core
-
-BBCLASSEXTEND = "native nativesdk"
-
-UPSTREAM_CHECK_REGEX = "/typing-extensions/(?P<pver>(\d+[\.\-_]*)+)/"
diff --git a/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb b/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb
new file mode 100644
index 0000000000..27ec7560ea
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-typing-extensions_4.4.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Backported and Experimental Type Hints for Python 3.7+"
+DESCRIPTION = "The typing_extensions module serves two related purposes:\
+\
+* Enable use of new type system features on older Python versions. For \
+ example, typing.TypeGuard is new in Python 3.10, but typing_extensions \
+ allows users on previous Python versions to use it too.\
+* Enable experimentation with new type system PEPs before they are accepted \
+ and added to the typing module."
+HOMEPAGE = "https://github.com/python/typing_extensions"
+BUGTRACKER = "https://github.com/python/typing_extensions/issues"
+SECTIONS = "libs"
+LICENSE = "PSF-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f16b323917992e0f8a6f0071bc9913e2"
+
+# The name on PyPi is slightly different.
+PYPI_PACKAGE = "typing_extensions"
+
+SRC_URI[sha256sum] = "1511434bb92bf8dd198c12b1cc812e800d4181cfcb867674e0f8279cc93087aa"
+
+inherit pypi python_flit_core
+
+UPSTREAM_CHECK_REGEX = "/typing-extensions/(?P<pver>(\d+[\.\-_]*)+)/"
+
+BBCLASSEXTEND = "native nativesdk"