summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-11 23:26:25 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-15 14:37:35 +0000
commit824c07d1cf2d1574dfe8f395af37479064782426 (patch)
tree5922d8e95a0e9e07c895424cb4442c5f4ef05af8 /meta/recipes-support
parent1e7ed44d87034446f1d07692c9378c3b0a8a9dd3 (diff)
downloadopenembedded-core-824c07d1cf2d1574dfe8f395af37479064782426.tar.gz
libunwind: Link with libucontext on musl
Functions like unw_getcontext in libunwind call getcontext() which are not part of musl C library like glibc, however there is a supplimental library providing these functions called libucontext, therefore link libunwind with a static version of this library to resolve such symbols, this inturn helps packages needing libunwind, who look for certain APIs in libunwind during configure e.g. heaptrack Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libunwind/libunwind.inc1
-rw-r--r--meta/recipes-support/libunwind/libunwind_1.5.0.bb1
2 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-support/libunwind/libunwind.inc b/meta/recipes-support/libunwind/libunwind.inc
index 76a1bf6246..17ba151933 100644
--- a/meta/recipes-support/libunwind/libunwind.inc
+++ b/meta/recipes-support/libunwind/libunwind.inc
@@ -4,6 +4,7 @@ HOMEPAGE = "http://www.nongnu.org/libunwind"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=2d80c8ed4062b8339b715f90fa68cc9f"
DEPENDS += "libatomic-ops"
+DEPENDS_append_libc-musl = " libucontext"
inherit autotools multilib_header
diff --git a/meta/recipes-support/libunwind/libunwind_1.5.0.bb b/meta/recipes-support/libunwind/libunwind_1.5.0.bb
index 887a35708e..6392cac5c9 100644
--- a/meta/recipes-support/libunwind/libunwind_1.5.0.bb
+++ b/meta/recipes-support/libunwind/libunwind_1.5.0.bb
@@ -25,3 +25,4 @@ COMPATIBLE_HOST_riscv32 = "null"
LDFLAGS += "-Wl,-z,relro,-z,now ${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
SECURITY_LDFLAGS_append_libc-musl = " -lssp_nonshared"
+CACHED_CONFIGUREVARS_append_libc-musl = " LDFLAGS='${LDFLAGS} -lucontext'"