summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2024-03-15 14:37:36 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-19 15:24:56 +0000
commit3c3601d50ae290e7e9797eadd20c05df99bbd040 (patch)
tree1885343d5595289f08efecbcaa7d0fa561900402 /meta/recipes-support
parent5ec2bc7ef663db4c04c85eee518297d442556481 (diff)
downloadopenembedded-core-3c3601d50ae290e7e9797eadd20c05df99bbd040.tar.gz
curl: improve run-ptest
There's no need to run the output of runtests.pl through a sed to get automake-style output, as you can pass -am to get this formatting. Don't run timing dependent tests, as the ptests can run on loaded systems. Add a dependency on the en_US locale because some of the tests require this. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/curl/curl/run-ptest13
-rw-r--r--meta/recipes-support/curl/curl_8.6.0.bb1
2 files changed, 10 insertions, 4 deletions
diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 8f9c20f34d..acd2892f80 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,11 @@
#!/bin/sh
+
cd tests
-{ ./runtests.pl -a -n -s -j4 !flaky || echo "FAIL: curl" ; } | sed \
- -e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
- -e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
- -e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'
+
+# Run all tests, don't stop on first failure
+# Don't use valgrind if it is found
+# Use automake-style output
+# Run four tests in parallel
+# Print log output on failure
+# Don't run the flaky or timing dependent tests
+./runtests.pl -a -n -am -j4 -p '!flaky !timing-dependent'
diff --git a/meta/recipes-support/curl/curl_8.6.0.bb b/meta/recipes-support/curl/curl_8.6.0.bb
index b01f4542a2..d4473d868e 100644
--- a/meta/recipes-support/curl/curl_8.6.0.bb
+++ b/meta/recipes-support/curl/curl_8.6.0.bb
@@ -125,6 +125,7 @@ RDEPENDS:${PN}-ptest += " \
perl-module-storable \
perl-module-time-hires \
"
+RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
PACKAGES =+ "lib${BPN}"