summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.4.3.bb
diff options
context:
space:
mode:
authorAnibal Limon <anibal@limonsoftware.com>2024-02-14 12:35:03 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-15 22:14:18 +0000
commit1d8a8487d300332c796a7555644bb370fc858f6f (patch)
tree52032c09d75047ef576d217f6701407f5ae8ce6f /meta/recipes-support/ptest-runner/ptest-runner_2.4.3.bb
parent1ce51580a23869a9c0f409446ff717d471fb60db (diff)
downloadopenembedded-core-1d8a8487d300332c796a7555644bb370fc858f6f.tar.gz
ptest-runner: Bump to 2.4.3 (92c1b97)
Pull small fixed related to secure builds, handling of rc in every ptest and better tests output when timeout. Changes, 92c1b97 Do not reset error counter before each test 7de7e2b utils: run_child fix security flags build 6a9fba2 utils.c: get_available_ptests fix security flags compilation 5b8ad9a tests: Ensure that timeouts still print ERROR d939217 SECURITY.md: Add file Signed-off-by: Anibal Limon <anibal@limonsoftware.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.4.3.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.4.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.4.3.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.4.3.bb
new file mode 100644
index 0000000000..e6668da01f
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.4.3.bb
@@ -0,0 +1,39 @@
+SUMMARY = "A C program to run all installed ptests"
+DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
+program which loops through all installed ptest test suites and \
+runs them in sequence."
+HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
+
+LICENSE = "GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+SRCREV = "92c1b97bfdb4a94acc1cabcaf97eef52dc29144c"
+PV .= "+git"
+
+SRC_URI = "git://git.yoctoproject.org/ptest-runner2;branch=master;protocol=https \
+"
+
+S = "${WORKDIR}/git"
+
+FILES:${PN} = "${bindir}/ptest-runner ${bindir}/ptest-runner-collect-system-data"
+
+EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
+ install -D -m 0755 ${S}/ptest-runner-collect-system-data ${D}${bindir}/ptest-runner-collect-system-data
+}
+
+RDEPENDS:${PN}:append:libc-glibc = " libgcc"
+
+# pstree is called by ptest-runner-collect-system-data
+RDEPENDS:${PN}:append = " pstree"
+
+# Create a non-root user that test suites can use easily
+inherit useradd
+USERADD_PACKAGES = "${PN}"
+USERADD_PARAM:${PN} = "--system --no-create-home --home / --user-group ptest"