summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/pinentry/pinentry_1.2.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex@linutronix.de>2021-09-08 20:01:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-11 18:31:04 +0100
commitdbb0e50375a5720d38c966fc4c5810eea1ec0203 (patch)
tree6c773dcc3409a6147b8a1d68438fbfc053546299 /meta/recipes-support/pinentry/pinentry_1.2.0.bb
parent8f268f981d53615d8ac9ee3ee64d840dc7051ced (diff)
downloadopenembedded-core-dbb0e50375a5720d38c966fc4c5810eea1ec0203.tar.gz
pinentry: update 1.1.1 -> 1.2.0
Rebase patches. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/pinentry/pinentry_1.2.0.bb')
-rw-r--r--meta/recipes-support/pinentry/pinentry_1.2.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-support/pinentry/pinentry_1.2.0.bb b/meta/recipes-support/pinentry/pinentry_1.2.0.bb
new file mode 100644
index 0000000000..504ba3b5cc
--- /dev/null
+++ b/meta/recipes-support/pinentry/pinentry_1.2.0.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
+DESCRIPTION = "\
+ Pinentry is a collection of simple PIN or passphrase entry dialogs which \
+ utilize the Assuan protocol as described by the aegypten project; see \
+ http://www.gnupg.org/aegypten/ for details."
+
+HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
+
+DEPENDS = "gettext-native libassuan libgpg-error"
+
+UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
+SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
+ file://libassuan_pkgconf.patch \
+ file://gpg-error_pkconf.patch \
+"
+
+SRC_URI[sha256sum] = "10072045a3e043d0581f91cd5676fcac7ffee957a16636adedaa4f583a616470"
+
+inherit autotools pkgconfig
+
+PACKAGECONFIG ??= "ncurses libcap"
+
+PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
+PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
+PACKAGECONFIG[qt] = "--enable-pinentry-qt, --disable-pinentry-qt, qtbase-native qtbase"
+PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
+
+PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"
+
+EXTRA_OECONF = " \
+ --disable-rpath \
+"
+
+BBCLASSEXTEND = "native nativesdk"