summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lz4/lz4_1.9.3.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-04 21:07:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-09 12:15:17 +0000
commita8ab527033e5220dc57766e5f7fd7ed316ab528c (patch)
tree5f35c1c4b3f26cf7aecabfe33406b0f1e9d680e9 /meta/recipes-support/lz4/lz4_1.9.3.bb
parentc740bc0eefd250d7ef6386dd8ae6cc593b982792 (diff)
downloadopenembedded-core-a8ab527033e5220dc57766e5f7fd7ed316ab528c.tar.gz
lz4: upgrade 1.9.2 -> 1.9.3
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/lz4/lz4_1.9.3.bb')
-rw-r--r--meta/recipes-support/lz4/lz4_1.9.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.9.3.bb b/meta/recipes-support/lz4/lz4_1.9.3.bb
new file mode 100644
index 0000000000..00f2dd32fe
--- /dev/null
+++ b/meta/recipes-support/lz4/lz4_1.9.3.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Extremely Fast Compression algorithm"
+DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
+
+LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
+LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc \
+ file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE;md5=d57c0d21cb917fb4e0af2454aa48b956 \
+ "
+
+PE = "1"
+
+SRCREV = "d44371841a2f1728a3f36839fd4b7e872d0927d3"
+
+SRC_URI = "git://github.com/lz4/lz4.git;branch=release \
+ file://run-ptest \
+ "
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
+
+S = "${WORKDIR}/git"
+
+# Fixed in r118, which is larger than the current version.
+CVE_CHECK_WHITELIST += "CVE-2014-4715"
+
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir} BUILD_STATIC=no"
+
+do_install() {
+ oe_runmake install
+}
+
+BBCLASSEXTEND = "native nativesdk"