summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-04 21:07:17 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-09 12:15:17 +0000
commit16c0d25df1fb2dc724c01bfe7be6ab42974ef0c9 (patch)
treed8d20d3f45efc7a65eb149633ec55e13720b33f4 /meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
parent69e3758a820a2283ec19f4fcf217a0065ef2ad96 (diff)
downloadopenembedded-core-16c0d25df1fb2dc724c01bfe7be6ab42974ef0c9.tar.gz
libcap: update 2.44 -> 2.45
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch')
-rw-r--r--meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch36
1 files changed, 25 insertions, 11 deletions
diff --git a/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch b/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
index d9fd48a9db..3c737b884e 100644
--- a/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
+++ b/meta/recipes-support/libcap/files/0001-tests-do-not-statically-link-a-test.patch
@@ -1,4 +1,4 @@
-From 03e925f0d68bc51e1acf1ac2014a9c2452c664bf Mon Sep 17 00:00:00 2001
+From c22c6c16362c7dbc8d6faea06edee5e07759c5fa Mon Sep 17 00:00:00 2001
From: Alexander Kanavin <alex.kanavin@gmail.com>
Date: Wed, 15 Jan 2020 17:16:28 +0100
Subject: [PATCH] tests: do not statically link a test
@@ -9,23 +9,37 @@ Upstream-Status: Inappropriate [oe-core specific]
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
---
+ progs/Makefile | 2 +-
tests/Makefile | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+diff --git a/progs/Makefile b/progs/Makefile
+index 1d7fc7a..37db8f7 100644
+--- a/progs/Makefile
++++ b/progs/Makefile
+@@ -42,7 +42,7 @@ endif
+ test: $(PROGS)
+
+ tcapsh-static: capsh.c $(DEPS)
+- $(CC) $(IPATH) $(CAPSH_SHELL) $(CFLAGS) -o $@ $< $(LIBCAPLIB) $(LDFLAGS) --static
++ $(CC) $(IPATH) $(CAPSH_SHELL) $(CFLAGS) -o $@ $< $(LIBCAPLIB) $(LDFLAGS)
+
+ sudotest: test tcapsh-static
+ sudo $(LDPATH) ./quicktest.sh
diff --git a/tests/Makefile b/tests/Makefile
-index d569650..f5ca377 100644
+index 3431df9..727fb86 100644
--- a/tests/Makefile
+++ b/tests/Makefile
-@@ -11,7 +11,7 @@ ifeq ($(DYNAMIC),yes)
- LDPATH = LD_LIBRARY_PATH=../libcap
- DEPSBUILD = all
+@@ -22,7 +22,7 @@ ifeq ($(PTHREADS),yes)
+ DEPS += ../libcap/libpsx.so
+ endif
else
-LDFLAGS += --static
-+LDFLAGS +=
- DEPSBUILD = libcap.a libpsx.a
- endif
-
-@@ -51,7 +51,7 @@ libcap_psx_launch_test: libcap_launch_test.c $(DEPS)
++LDFLAGS +=
+ DEPS=../libcap/libcap.a ../progs/tcapsh-static
+ ifeq ($(PTHREADS),yes)
+ DEPS += ../libcap/libpsx.a
+@@ -106,7 +106,7 @@ noexploit: exploit.o $(DEPS)
# This one runs in a chroot with no shared library files.
noop: noop.c