summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/dtc/python3-dtschema-wrapper_2021.10.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-11-23 16:23:43 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-26 16:58:55 +0000
commita8525391f8a519426c92f0e28895f426bfcb3f84 (patch)
treec310ecf4b21a70c4a4cae97b19ad71bc5932c710 /meta/recipes-kernel/dtc/python3-dtschema-wrapper_2021.10.bb
parentea71e50be2de5b7fc81f466ea5cd48c2f1e0ef6b (diff)
downloadopenembedded-core-a8525391f8a519426c92f0e28895f426bfcb3f84.tar.gz
kernel: introduce python3-dtschema-wrapper
The 5.16 kernel introduced mandatory schema checking on any dtb file built through the kernel. That funcionality is provided via python3-dt-schema. The dependencies to enable that functionality is not small, and may not always be desired (in particular on architectures that do not support dtbs, or in development cycles). It may also be useful for allowing a non-conformant dts to be compiled. This commit introduces a set of wrapper scripts that when added as a depenency to the kernel, can pass both the validation testing and validation steps of a dts. We use the wrapper by default, while more dts file are brought up to spec and the dt-validation matures upstream. To enable valiation, simply add 'dt-valiation' to the PACKAGECONFIG variable and the full dt-schema package will be selected and validation will occur. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'meta/recipes-kernel/dtc/python3-dtschema-wrapper_2021.10.bb')
-rw-r--r--meta/recipes-kernel/dtc/python3-dtschema-wrapper_2021.10.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-kernel/dtc/python3-dtschema-wrapper_2021.10.bb b/meta/recipes-kernel/dtc/python3-dtschema-wrapper_2021.10.bb
new file mode 100644
index 0000000000..c869274d09
--- /dev/null
+++ b/meta/recipes-kernel/dtc/python3-dtschema-wrapper_2021.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Wrapper for tooling for devicetree validation using YAML and jsonschema"
+HOMEPAGE = "https://yoctoproject.org"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI = "file://dt-doc-validate \
+ file://dt-mk-schema \
+ file://dt-validate"
+
+do_install() {
+ install -d ${D}${bindir}/
+ install -m 755 ${WORKDIR}/dt-doc-validate ${D}${bindir}/
+ install -m 755 ${WORKDIR}/dt-mk-schema ${D}${bindir}/
+ install -m 755 ${WORKDIR}/dt-validate ${D}${bindir}/
+}
+
+BBCLASSEXTEND = "native nativesdk"