summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-03-06 07:42:27 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-06 16:23:34 +0000
commitd3d0375fa0b4809d2c69837faf5df297d92de683 (patch)
treeaeb13075692d62850d9c90f68810a3e0093aeaac /meta/recipes-graphics
parent7235073a7ee2fb371931922c2d0f28ab09673102 (diff)
downloadopenembedded-core-d3d0375fa0b4809d2c69837faf5df297d92de683.tar.gz
vulkan: upgrade 1.3.268.0 -> 1.3.275.0
Add vulkan-volk recipe to support building latest vulkan-tools. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch13
-rw-r--r--meta/recipes-graphics/glslang/glslang_1.3.275.0.bb (renamed from meta/recipes-graphics/glslang/glslang_1.3.268.0.bb)2
-rw-r--r--meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb (renamed from meta/recipes-graphics/spir/spirv-headers_1.3.268.0.bb)2
-rw-r--r--meta/recipes-graphics/spir/spirv-tools_1.3.275.0.bb (renamed from meta/recipes-graphics/spir/spirv-tools_1.3.268.0.bb)2
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-headers_1.3.275.0.bb (renamed from meta/recipes-graphics/vulkan/vulkan-headers_1.3.268.0.bb)2
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-loader_1.3.275.0.bb (renamed from meta/recipes-graphics/vulkan/vulkan-loader_1.3.268.0.bb)4
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-tools_1.3.275.0.bb (renamed from meta/recipes-graphics/vulkan/vulkan-tools_1.3.268.0.bb)4
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-utility-libraries_1.3.275.0.bb (renamed from meta/recipes-graphics/vulkan/vulkan-utility-libraries_1.3.268.0.bb)2
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-validation-layers_1.3.275.0.bb (renamed from meta/recipes-graphics/vulkan/vulkan-validation-layers_1.3.268.0.bb)4
-rw-r--r--meta/recipes-graphics/vulkan/vulkan-volk_1.3.275.0.bb37
10 files changed, 54 insertions, 18 deletions
diff --git a/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch b/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
index a2dcb13b36..316a57fa4a 100644
--- a/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
+++ b/meta/recipes-graphics/glslang/glslang/0001-generate-glslang-pkg-config.patch
@@ -1,4 +1,4 @@
-From e8c1b7e1dc6d108a3b49d0adfdc4f836cfafcf1a Mon Sep 17 00:00:00 2001
+From 4cede5edcff96134baf35953d58595c4aa5f1fc5 Mon Sep 17 00:00:00 2001
From: Jose Quaresma <quaresma.jose@gmail.com>
Date: Sun, 7 Feb 2021 01:30:39 +0000
Subject: [PATCH] generate glslang pkg-config
@@ -8,7 +8,6 @@ Based on https://src.fedoraproject.org/rpms/glslang/blob/main/f/0001-pkg-config-
Upstream-Status: Pending
Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
-
---
glslang/CMakeLists.txt | 2 ++
glslang/glslang.pc.cmake.in | 11 +++++++++++
@@ -16,21 +15,21 @@ Signed-off-by: Jose Quaresma <quaresma.jose@gmail.com>
create mode 100644 glslang/glslang.pc.cmake.in
diff --git a/glslang/CMakeLists.txt b/glslang/CMakeLists.txt
-index 72e82b48..c6188e12 100644
+index 37eecaad..6974935c 100644
--- a/glslang/CMakeLists.txt
+++ b/glslang/CMakeLists.txt
-@@ -223,6 +223,8 @@ if(ENABLE_GLSLANG_INSTALL)
+@@ -251,6 +251,8 @@ if(PROJECT_IS_TOP_LEVEL)
")
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/glslangTargets.cmake" DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake)
endif()
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/glslang.pc.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/pkgconfig/glslang.pc @ONLY)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pkgconfig/glslang.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
- set(ALL_HEADERS
- ${GLSLANG_HEADERS}
+ set(PUBLIC_HEADERS
+ Public/ResourceLimits.h
diff --git a/glslang/glslang.pc.cmake.in b/glslang/glslang.pc.cmake.in
new file mode 100644
-index 00000000..948a0952
+index 00000000..43104e68
--- /dev/null
+++ b/glslang/glslang.pc.cmake.in
@@ -0,0 +1,11 @@
diff --git a/meta/recipes-graphics/glslang/glslang_1.3.268.0.bb b/meta/recipes-graphics/glslang/glslang_1.3.275.0.bb
index 033830ba36..2fd1e72a26 100644
--- a/meta/recipes-graphics/glslang/glslang_1.3.268.0.bb
+++ b/meta/recipes-graphics/glslang/glslang_1.3.275.0.bb
@@ -8,7 +8,7 @@ HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
-SRCREV = "36d08c0d940cf307a23928299ef52c7970d8cee6"
+SRCREV = "a91631b260cba3f22858d6c6827511e636c2458a"
SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \
file://0001-generate-glslang-pkg-config.patch \
"
diff --git a/meta/recipes-graphics/spir/spirv-headers_1.3.268.0.bb b/meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb
index 7045f70473..598a8fc209 100644
--- a/meta/recipes-graphics/spir/spirv-headers_1.3.268.0.bb
+++ b/meta/recipes-graphics/spir/spirv-headers_1.3.275.0.bb
@@ -4,7 +4,7 @@ HOMEPAGE = "https://www.khronos.org/registry/spir-v"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=c938b85bceb8fb26c1a807f28a52ae2d"
-SRCREV = "e867c06631767a2d96424cbec530f9ee5e78180f"
+SRCREV = "1c6bb2743599e6eb6f37b2969acc0aef812e32e3"
SRC_URI = "git://github.com/KhronosGroup/SPIRV-Headers;protocol=https;branch=main"
PE = "1"
# These recipes need to be updated in lockstep with each other:
diff --git a/meta/recipes-graphics/spir/spirv-tools_1.3.268.0.bb b/meta/recipes-graphics/spir/spirv-tools_1.3.275.0.bb
index 1cccafdad0..05c6de1b50 100644
--- a/meta/recipes-graphics/spir/spirv-tools_1.3.268.0.bb
+++ b/meta/recipes-graphics/spir/spirv-tools_1.3.275.0.bb
@@ -7,7 +7,7 @@ SECTION = "graphics"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRCREV = "360d469b9eac54d6c6e20f609f9ec35e3a5380ad"
+SRCREV = "f0cc85efdbbe3a46eae90e0f915dc1509836d0fc"
SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=main;protocol=https"
PE = "1"
# These recipes need to be updated in lockstep with each other:
diff --git a/meta/recipes-graphics/vulkan/vulkan-headers_1.3.268.0.bb b/meta/recipes-graphics/vulkan/vulkan-headers_1.3.275.0.bb
index a1a83317da..aacec8cab1 100644
--- a/meta/recipes-graphics/vulkan/vulkan-headers_1.3.268.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-headers_1.3.275.0.bb
@@ -11,7 +11,7 @@ LICENSE = "Apache-2.0 & MIT"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=1bc355d8c4196f774c8b87ed1a8dd625"
SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=main;protocol=https"
-SRCREV = "7b3466a1f47a9251ac1113efbe022ff016e2f95b"
+SRCREV = "217e93c664ec6704ec2d8c36fa116c1a4a1e2d40"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-graphics/vulkan/vulkan-loader_1.3.268.0.bb b/meta/recipes-graphics/vulkan/vulkan-loader_1.3.275.0.bb
index 5a5749d40c..7caed67207 100644
--- a/meta/recipes-graphics/vulkan/vulkan-loader_1.3.268.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-loader_1.3.275.0.bb
@@ -9,8 +9,8 @@ SECTION = "libs"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7dbefed23242760aa3475ee42801c5ac"
-SRC_URI = "git://github.com/KhronosGroup/Vulkan-Loader.git;branch=vulkan-sdk-1.3.268;protocol=https"
-SRCREV = "f4c838e2e7358fc450f8112119bbdbb5b03e03fa"
+SRC_URI = "git://github.com/KhronosGroup/Vulkan-Loader.git;branch=vulkan-sdk-1.3.275;protocol=https"
+SRCREV = "00893b9a03e526aec2c5bf487521d16dfa435229"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-graphics/vulkan/vulkan-tools_1.3.268.0.bb b/meta/recipes-graphics/vulkan/vulkan-tools_1.3.275.0.bb
index 78bd9b0e04..f86912c903 100644
--- a/meta/recipes-graphics/vulkan/vulkan-tools_1.3.268.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-tools_1.3.275.0.bb
@@ -7,7 +7,7 @@ SECTION = "libs"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://github.com/KhronosGroup/Vulkan-Tools.git;branch=main;protocol=https"
-SRCREV = "1532001f7edae559af1988293eec90bc5e2607d5"
+SRCREV = "c86d42cf9eb620eeac377e3bff46ae342c5cd664"
S = "${WORKDIR}/git"
@@ -15,7 +15,7 @@ inherit cmake features_check pkgconfig
ANY_OF_DISTRO_FEATURES = "x11 wayland"
REQUIRED_DISTRO_FEATURES = "vulkan"
-DEPENDS += "vulkan-headers vulkan-loader"
+DEPENDS += "vulkan-headers vulkan-loader vulkan-volk"
EXTRA_OECMAKE = "\
-DBUILD_TESTS=OFF \
diff --git a/meta/recipes-graphics/vulkan/vulkan-utility-libraries_1.3.268.0.bb b/meta/recipes-graphics/vulkan/vulkan-utility-libraries_1.3.275.0.bb
index fee4ba6cc9..759a03926b 100644
--- a/meta/recipes-graphics/vulkan/vulkan-utility-libraries_1.3.268.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-utility-libraries_1.3.275.0.bb
@@ -10,7 +10,7 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE.md;md5=4ca2d6799091aaa98a8520f1b793939b"
SRC_URI = "git://github.com/KhronosGroup/Vulkan-Utility-Libraries.git;branch=main;protocol=https"
-SRCREV = "c9ca4ac620a238a93c65d864f2eaa33954d74509"
+SRCREV = "4cfc176e3242b4dbdfd3f6c5680c5d8f2cb7db45"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-graphics/vulkan/vulkan-validation-layers_1.3.268.0.bb b/meta/recipes-graphics/vulkan/vulkan-validation-layers_1.3.275.0.bb
index 6c2715b041..239589108d 100644
--- a/meta/recipes-graphics/vulkan/vulkan-validation-layers_1.3.268.0.bb
+++ b/meta/recipes-graphics/vulkan/vulkan-validation-layers_1.3.275.0.bb
@@ -8,8 +8,8 @@ SECTION = "libs"
LICENSE = "Apache-2.0 & MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cd3c0bc366cd9b6a906e22f0bcb5910f"
-SRC_URI = "git://github.com/KhronosGroup/Vulkan-ValidationLayers.git;branch=vulkan-sdk-1.3.268;protocol=https"
-SRCREV = "3c64adb4e052062fc60b6580c365429fddfbcfbf"
+SRC_URI = "git://github.com/KhronosGroup/Vulkan-ValidationLayers.git;branch=vulkan-sdk-1.3.275;protocol=https"
+SRCREV = "780c65337e111c7385109c7b720d757a778e4fe2"
S = "${WORKDIR}/git"
diff --git a/meta/recipes-graphics/vulkan/vulkan-volk_1.3.275.0.bb b/meta/recipes-graphics/vulkan/vulkan-volk_1.3.275.0.bb
new file mode 100644
index 0000000000..f4e6e89aac
--- /dev/null
+++ b/meta/recipes-graphics/vulkan/vulkan-volk_1.3.275.0.bb
@@ -0,0 +1,37 @@
+SUMMARY = "A meta-loader for Vulkan"
+DESCRIPTION = "Volk allows one to dynamically load entrypoints required \
+to use Vulkan without linking to vulkan-1.dll or statically linking Vulkan loader. \
+"
+HOMEPAGE = "https://www.khronos.org/vulkan/"
+BUGTRACKER = "https://github.com/zeux/volk"
+SECTION = "libs"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=b2dd098d35668a801190a9d9d47461b0"
+
+SRC_URI = "git://github.com/zeux/volk.git;branch=master;protocol=https"
+SRCREV = "f2a16e3e19c2349b873343b2dc38a1d4c25af23a"
+
+S = "${WORKDIR}/git"
+
+REQUIRED_DISTRO_FEATURES = "vulkan"
+
+DEPENDS = "vulkan-headers"
+
+EXTRA_OECMAKE = "\
+ -DVOLK_INSTALL=ON \
+ "
+
+inherit cmake features_check pkgconfig
+
+# These recipes need to be updated in lockstep with each other:
+# glslang, vulkan-headers, vulkan-loader, vulkan-tools,
+# vulkan-validation-layers, spirv-headers, spirv-tools,
+# vulkan-utility-libraries.
+# The tags versions should always be sdk-x.y.z, as this is what
+# upstream considers a release.
+UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
+
+do_install:append() {
+ sed -i -e 's,${STAGING_DIR_TARGET},,g' ${D}${libdir}/cmake/volk/volkTargets.cmake
+}