summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2010-10-07 13:04:23 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-10-08 16:56:44 +0100
commitc449c78c25eacb17797097377802af291247b8c0 (patch)
tree25594e946b96df4a03ca9f40368dc93b64706f49 /meta/recipes-graphics
parent5f17c07331fd0bfcc5aba87587ede385bd896c47 (diff)
downloadopenembedded-core-c449c78c25eacb17797097377802af291247b8c0.tar.gz
Rename MACHINE=netbook to MACHINE=atom-pc
In preparation for the more generic atom-pc, rename the netbook machine and all the relevant overrides. Leave the linux-netbook kernel recipe intact and as the default kernel for the atom-pc machine. A future patch will convert this over to linux-wrs and likely remove the linux-netbook kernel recipe. Cc: Tom Zanussi <tom.zanussi@intel.com> Cc: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/clutter/clutter.inc8
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_7.5.bb8
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_7.7.bb8
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb6
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri_git.bb6
-rw-r--r--meta/recipes-graphics/xorg-xserver/xserver-xf86-config/atom-pc/xorg.conf (renamed from meta/recipes-graphics/xorg-xserver/xserver-xf86-config/netbook/xorg.conf)0
6 files changed, 18 insertions, 18 deletions
diff --git a/meta/recipes-graphics/clutter/clutter.inc b/meta/recipes-graphics/clutter/clutter.inc
index c099309bbb..a42a6c59d6 100644
--- a/meta/recipes-graphics/clutter/clutter.inc
+++ b/meta/recipes-graphics/clutter/clutter.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Clutter graphics library"
HOMEPAGE = "http://www.clutter-project.org/"
LICENSE = "LGPL"
-COMPATIBLE_MACHINE = "(zylonite|mx31litekit|omap-3430ldp|omap-3430sdp|mx31ads|qemuarm|qemux86|ipodtouch|netbook|menlow)"
+COMPATIBLE_MACHINE = "(zylonite|mx31litekit|omap-3430ldp|omap-3430sdp|mx31ads|qemuarm|qemux86|ipodtouch|atom-pc|menlow)"
STDDEPENDS = "virtual/libx11 gtk-doc-native pango glib-2.0 libxfixes gtk+ libxi"
BASE_CONF = "--disable-gtk-doc ${@get_clutter_fpu_setting(bb, d)}"
@@ -35,9 +35,9 @@ EXTRA_OECONF_mx31ads = "${BASE_CONF} --with-flavour=eglnative"
PACKAGE_ARCH_mx31ads = "${MACHINE_ARCH}"
LDFLAGS_append_mx31ads = " -lpvrNULLWSEGL -lstdc++ "
-DEPENDS_netbook = "${STDDEPENDS} virtual/xserver-xf86 virtual/libgl"
-EXTRA_OECONF_netbook = "${BASE_CONF} --with-flavour=glx"
-PACKAGE_ARCH_netbook = "${MACHINE_ARCH}"
+DEPENDS_atom-pc = "${STDDEPENDS} virtual/xserver-xf86 virtual/libgl"
+EXTRA_OECONF_atom-pc = "${BASE_CONF} --with-flavour=glx"
+PACKAGE_ARCH_atom-pc = "${MACHINE_ARCH}"
DEPENDS_menlow = "${STDDEPENDS} virtual/xserver-xf86 virtual/libgl"
EXTRA_OECONF_menlow = "${BASE_CONF} --with-flavour=glx"
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.5.bb b/meta/recipes-graphics/mesa/mesa-dri_7.5.bb
index 6e9cdc9aa8..b50cee8639 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_7.5.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_7.5.bb
@@ -8,13 +8,13 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
-PR = "r11"
+PR = "r12"
# most of our targets do not have DRI so will use mesa-xlib
DEFAULT_PREFERENCE = "-1"
-# Netbooks have DRI support so use mesa-dri by default
-DEFAULT_PREFERENCE_netbook = "1"
+# Atom PCs have DRI support so use mesa-dri by default
+DEFAULT_PREFERENCE_atom-pc = "1"
PACKAGES =+ "${PN}-xprogs"
PACKAGES_DYNAMIC = "mesa-dri-driver-*"
@@ -45,4 +45,4 @@ COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
#
# Header generated by i586-poky-linux-gcc gen_matypes.c -o gen_matypes -I ../../../include/GL -I ../../../include -I .. -I ../main/ -I ../math -I ../glapi/ -I ../tnl
# then run gen_matypes > matypes.h on device
-# \ No newline at end of file
+#
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.7.bb b/meta/recipes-graphics/mesa/mesa-dri_7.7.bb
index a5899f3892..4cae9c8699 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_7.7.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_7.7.bb
@@ -9,13 +9,13 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
-PR = "r11"
+PR = "r12"
# most of our targets do not have DRI so will use mesa-xlib
DEFAULT_PREFERENCE = "-1"
-# Netbooks have DRI support so use mesa-dri by default
-DEFAULT_PREFERENCE_netbook = "1"
+# Atom PCs have DRI support so use mesa-dri by default
+DEFAULT_PREFERENCE_atom-pc = "1"
PACKAGES =+ "${PN}-xprogs"
PACKAGES_DYNAMIC = "mesa-dri-driver-*"
@@ -46,4 +46,4 @@ COMPATIBLE_HOST = '(i.86.*-linux|x86_64.*-linux)'
#
# Header generated by i586-poky-linux-gcc gen_matypes.c -o gen_matypes -I ../../../include/GL -I ../../../include -I .. -I ../main/ -I ../math -I ../glapi/ -I ../tnl
# then run gen_matypes > matypes.h on device
-# \ No newline at end of file
+#
diff --git a/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb b/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb
index ffd885f293..caa9b2ecbc 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_7.8.2.bb
@@ -7,15 +7,15 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
DEPENDS = "${PROTO_DEPS} ${LIB_DEPS} mesa-dri-glsl-native"
-PR = "r1"
+PR = "r2"
SRC_URI += "file://crossfix.patch"
# most of our targets do not have DRI so will use mesa-xlib
DEFAULT_PREFERENCE = "-1"
-# Netbooks have DRI support so use mesa-dri by default
-DEFAULT_PREFERENCE_netbook = "1"
+# Atom PCs have DRI support so use mesa-dri by default
+DEFAULT_PREFERENCE_atom-pc = "1"
LEAD_SONAME = "libGL.so.1"
diff --git a/meta/recipes-graphics/mesa/mesa-dri_git.bb b/meta/recipes-graphics/mesa/mesa-dri_git.bb
index fa0a7c8dc2..20bb9125d4 100644
--- a/meta/recipes-graphics/mesa/mesa-dri_git.bb
+++ b/meta/recipes-graphics/mesa/mesa-dri_git.bb
@@ -12,13 +12,13 @@ LIB_DEPS = "libdrm virtual/libx11 libxext libxxf86vm libxdamage libxfixes expat"
DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
PV = "7.7+git${SRCPV}"
-PR = "r0"
+PR = "r1"
# most of our targets do not have DRI so will use mesa-xlib
DEFAULT_PREFERENCE = "-1"
-# Netbooks have DRI support so use mesa-dri by default
-DEFAULT_PREFERENCE_netbook = "1"
+# Atom PCs have DRI support so use mesa-dri by default
+DEFAULT_PREFERENCE_atom-pc = "1"
PACKAGES =+ "${PN}-xprogs"
PACKAGES_DYNAMIC = "mesa-dri-driver-*"
diff --git a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config/netbook/xorg.conf b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config/atom-pc/xorg.conf
index e18b911199..e18b911199 100644
--- a/meta/recipes-graphics/xorg-xserver/xserver-xf86-config/netbook/xorg.conf
+++ b/meta/recipes-graphics/xorg-xserver/xserver-xf86-config/atom-pc/xorg.conf